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1 Personal notes 


Well, you’ve done it.  You’ve worked hard and long for the Ph.D., and now it's time to start writing the dissertation.  Furthermore, you've decided to use Word for Windows (instead of Latex) to write it.  This means you could use a dissertation template of some sort, which brings us to the current discussion.


When I started working on my dissertation in the spring of 2001, I discovered, to my surprise, that there were no Word templates available that fulfilled the requirements of a UTD dissertation.  Oh, there were guidelines for setting the margins, the page numbers, fonts, and a whole host of things too numerous to mention.  The Office of Graduate Studies will be happy to provide you with a little booklet that describes these things in detail.  But that's not the same thing as having a template that sets up the basic document for you, one that you know is correct.  Wouldn’t it be nice to let go of all the worries about margin settings and the like, so you can focus on the task at hand:  Getting the dissertation written?  I thought so.  To facilitate this, I’ve incorporated the various settings I used with my dissertation into a Word document template that is included with this file.  It worked very well for me, and I believe it will for you too.  


Although I can’t claim that this template is perfect or is even the best available, I can claim that it will pass the formatting requirements of a UTD dissertation.  If you will follow the directions I give you below for its use, this template will not only set the margins, fonts, and other formatting for you, but it will also automatically number your chapters, sub-sections, and figures.  In addition, the creation of a table of contents and a table of figures is much simplified.  All you have to do is supply the content, and this template will make sure that that content is put together properly.  I hope that with a little effort on your part to learn how to use it, it will make the process of writing a dissertation significantly easier and save you quite a bit of time in producing the final document.  


Best of luck!

2 Warning and disclaimer


I am providing this template to UTD with the understanding that it is intended as an aid only.  The user will have to take responsibility for detecting and fixing any mistakes.  


Please note that using a Word template is a non-trivial operation.  To use it successfully you need to have at least an average working knowledge of Word for Windows, and with Windows in general.  For example, it is assumed that the user knows basic operations within Word, such as traversing the menus, setting styles, working with fonts, working with fields, etc.  I will include some brief descriptions of some of these items, but in general, writing complete descriptions of basic Word and Windows operations is beyond the scope of this write-up. 


Although this template will create a dissertation that is acceptable to UTD, there may be some aspects of it that you would like to change.  Perhaps you'd like to use a different font, or a slightly different margin.  This is fine.  The template can be modified to create almost anything you want.  But make sure you know what you are doing if you make any significant changes, especially with the use of styles and outline numbering.  Many of the nice features, such as the ability to generate an entire table of contents with the click of a mouse, are keyed to the style and outline settings.  You can change these in the document or the template, but if they are changed improperly, the related functions may not work. 


Keep in mind that minor variations can appear in the end product for reasons that have nothing to do with the template.  For example, one printer might format margins slightly differently than another.  Problems like this can be fixed, of course, by simply adjusting whatever parameter is not working properly, but I suggest you make test printings of key pages of your dissertation so they can be detected early. 

And finally, let me emphasize the importance of following the directions outlined in this manual very carefully.  Several of the operations described here are somewhat technical, and involve several steps.  If these steps aren’t followed exactly, then the end result might not be correct.  A key example is the problem of having exactly two blank lines between the chapter title information and the beginning of the chapter text.  As you will see below, the template is set up to provide those two blank lines, but the method of obtaining them may vary depending on the needs of an individual dissertation (e.g. whether sub-titles are used or not).  Another example is the method of setting up the figure headings so they will be detected and appear in the table of figures.  In these and all other cases, it is necessary to parse out the directions very carefully to see how they apply to your particular situation.  
3 General Characteristics


As it is, this template will create a dissertation that uses a 12 point Times New Roman font throughout, double spaced, with the acceptable margins, page numbering, etc. already set up.  It includes provisions for the title page of the dissertation, the copyright notice, the acknowledgments, the abstract, the table of contents, the table of figures, the chapters, the bibliography, and the vita.  


My recommendation is that you treat the entire dissertation as one large file, instead of breaking it up into separate files for chapters, etc.  In this way, all page numbering is handled automatically, and cross-referencing between different portions of the document is much simplified.  If you have already written separate chapter files, those files can be copy/pasted into a document based on this template.


I further recommend that you do not use the Word “large document” feature.  This feature is not well regarded by experts in Word.  The general consensus is that it generates more problems than it solves.

The template is divided into sections, which is necessary in order to get the page numbering and other formatting to work out properly.  Each chapter resides in its own section.  It is best to work entirely within a section at any given time.  Don't delete a section break unless you are sure you won't need it.  


Virtually everything in this template is controlled by various style settings.  To control the creation of the table of contents and the table of figures, I used Outline Numbering linked to the styles and various outline levels.  I did not use any Visual Basic in this template.

4 General Setup


You should have the following files: 

1. “Dissertation Template Manual 2005.doc”
this file

2. “dissertation 2005.dot”
the template file

3. “normal.dot”
the basic configuration file for Word


The basic, root level configuration file in Word is called "normal.dot," and it contains the basic settings for styles, numbering, fonts, etc. that are crucial for Word to operate.  “Normal.dot” resides in a special folder, the location of which varies depending on the operating system.  In Windows 98, which I originally used to write this, it is in the “C:\Windows\Application Data\Microsoft\Templates” folder, but it is different for subsequent versions of Windows.  I assume that most people in 2005 are using Windows XP, and therefore provide a description of how to locate the “Templates” folder in that operating system. 

4.1 Locating the Templates folder in Windows XP


As most of you probably know, Windows XP allows multiple user configurations on one machine.  These configurations are stored in a set of folders whose root is the “Documents and Settings” folder on the main drive, usually drive “C:\”.  In the next level of folders within Documents and Settings you will find a folder list of the users who have accounts on your particular machine.  Let’s say that your particular account is called “Account 1.”  Then the template folder for Word that you need to be able to access in the following discussion will be “C:\Documents and Settings\Account 1\Application Data\Microsoft\Templates.”  This is the default folder used by Word for all of its template files for the user designated by “Account 1.”  

Note that the “Application Data” folder is typically marked as “Read only / Hidden” by default.  Therefore, it may not appear in the display in Windows Explorer and other programs.  (You’ll notice this if you use the Windows Explorer, go to the “Documents and Settings\Account 1\” folder, and observe that there is no “Application Data” folder shown.)  To fix this problem, you need to set Windows to display hidden files and folders.  To do this in Windows XP, you (a) open Windows Explorer; (b) go to the “Tools” menu and choose “Folder Options;” (c) choose the “View” tab; (d) scroll down to “Hidden Files and Folders” and activate the “Show Hidden Files and Folders” radio button.  Once hidden files and folders are displayed, you can navigate using Windows Explorer in the normal fashion.  

Secondary template files can be accessed by going to Tools->Options->File Locations (tab) and re-setting the folder that Word looks in for its templates.  The only problem with this approach is that it doesn’t seem to read the “normal.dot” file from the new location.  Therefore, I recommend using the above method, which handles both the “normal.dot” file and the dissertation template in one operation.  
4.2 Installing the Templates

You will need to install both the “normal.dot” and the “dissertation 2005.dot” files into the “Templates” folder described above.  

I strongly suggest that you use my "normal.dot" configuration file if you base your dissertation on this template.  Although it is very possible that your own “normal.dot” file would work just fine, there is a potential for conflict if you have changed some of the settings for various fonts or styles.  By using my configuration file, the behavior of the template is guaranteed to correspond with the directions I've written here.  Furthermore, in the discussion that follows I frequently refer to toolbar icons that will appear only if you use my configuration file.  Don't worry.  Changes in the basic Word configuration file are not permanent.  You can easily revert back to your current settings.  


To install my “normal.dot” file on your system, locate the folder in which your "normal.dot" is stored.  There should be a copy of your existing “normal.dot” file in that folder.  Make a backup of your own “normal.dot” file (simply renaming it works fine), then place a copy of the supplied “normal.dot” file in this same folder.  The next time you start Word, my configuration will be used.  To revert back to your configuration, just reverse this process and restart Word.  You should also place a copy of the “dissertation 2005.dot” file in this same folder.


Once you’ve done this, you can start your new dissertation by basing it on the “dissertation 2005” template.  From within Word, choose the File->New… menu sequence.  If you placed the "dissertation 2005.dot" template file in the same folder as "normal.dot", a "dissertation" option should be available at that point.  Simply choose that option.  This will initialize a new dissertation document with the settings in the dissertation template, and you are ready to go.  


Make sure you do not use the dissertation template directly.  Word templates are not designed to be opened directly, unless they are being modified.  Basing a new document on a template in the manner described is the proper way to use them.

5 Some basic operations and notes


Before we get into the dissertation template itself, I want to describe some basic Word operations that you will use often while working on your dissertation.  Most of the discussion in this section assumes that you are using my “normal.dot” file for your basic Word configuration.  

5.1 Show/Hide


On my toolbar there is an icon that looks like a paragraph mark.  It is just to the left of the zoom window icon, on the right hand side of the toolbar.  This is the "Show/Hide" button, and I suggest you always work with this button turned on.  This will allow paragraph marks, field codes, section breaks, and other hidden features to be visible while you work.  Although this clutters up the display a bit, in my view it is worth it.  It is far more useful to be able to see the hidden codes and fields that Word uses while you are working, than to have a perfectly clean display.  I personally never turn this switch off.

5.2 Context sensitive menus


In this write-up, I frequently refer to "context sensitive menus."  This phrase refers to the menu that appears when you "right click," or otherwise use the secondary mouse button, when the mouse cursor is positioned over some object.  The contents of this menu will change depending on the context, that is, which object the mouse cursor is pointing to, hence the name.

5.3 Fields


Fields are embedded codes that Word uses to control many operations.  They are extremely powerful mini-functions that return results or perform some operation.  Word has over 75 of them that can be used for various things.  In my dissertation, I used mostly TOC fields, which control the creation of the table of contents and table of figures, REF fields, which, in conjunction with bookmarks, can be used to create cross-references to remote parts of the document, and STYLEREF fields, which are more complicated but can be used to generate numbers among other things.  I suggest you become familiar with the use of fields.  In my toolbar, the icon on the right-hand side that has a large red "F" will directly access the Field dialog box.  You can also get to it with the “Insert->Field..” menu sequence. 


Normally Word displays the result of a field rather than the field itself.  At times, however, it is useful to be able to access the field code itself.  This can be done by:  (a) highlighting the result of the field, and (b) choosing "Toggle Field Codes" from the context sensitive menu.  Once the field code is displayed in this manner, it can be edited like any other text string.  

5.4 Updating fields


A very important operation when working with fields is the "update fields" operation.  This causes Word to recalculate the results of a particular field, which is often necessary since Word does not generally recalculate field results unless a document is being loaded or printed.  For example, if you move a picture to a different location in the document, the figure number, if it is calculated by a field code (as it will be if you use my method), will not be updated unless you tell Word explicitly to do that.  Similarly, cross-references to bookmarks or other items will need to be updated manually.


To update a particular field, highlight it and hit F9, or choose “Update Field” from the context sensitive menu.  To update all the fields in a document, first select the entire document with Ctrl-A, and then hit F9.  

5.5 Setting styles


As mentioned, styles are extremely important in Word, and this template uses them extensively to control various formatting requirements and other operations.  In Word 2003, styles can be accessed by going to the “Format” menu, and choosing “Styles and Formatting.”  This causes the “Styles and Formatting” box to appear on the right side of the screen.  Simply put the cursor on the line whose style you want to change, and choose the correct style from the list. 

This process may vary somewhat for different versions of Word, so I won’t dwell on the differences.  You can figure out the correct way to set styles on your system.  
6 General notes for use


When you create your dissertation document, you will notice some fields that say things like “Click here and type the title” or something similar.  To use these fields, highlight the whole line in a block, and then type the title of your dissertation or whatever information the field is asking for.


There are also notes embedded at various positions in the template that do not necessarily require a whole line.  These are placed in angled brackets, like “<” and “>”.  I intended those to be notices to the user of needed information at that point.  To use them, simply highlight the whole note in a block, including the angled brackets, and type in whatever information is asked for.  This will replace that angled bracket and included text with the correct information.


Use the “Body text” style, not the "Normal" style, for all text in your document.  This applies even to text that you have copy/pasted from another document.  If you move text from another document into your dissertation, make sure to change the style of the inserted text to “Body Text”.  


One of the nice things about this template is that it will correctly number chapters, sub-sections within a chapter, pages, and figures for you.  The automatic numbering features available in Word really save time when you need to generate something involving the whole document, like a table of contents, for example.  However, in order for these features to work, the template must be used in a very specific manner when new chapters are created.  The following sections describe this process.

7 To create new chapters

7.1 General Comments


The beginnings of the first two chapters are included with the template so that the page numbering scheme will be correct.  It is very important to use these chapter “stubs” for the first two chapters, otherwise the page numbering scheme doesn't work properly.  Chapters from 3 and beyond are handled differently than chapters 1 and 2, and I will discuss their creation in subsection 7.4.  


Note that format of the chapter headings for each chapter has a required element, and some optional elements.  The required element in the chapter heading is a chapter number line, which has the word "CHAPTER" in capital letters followed by the chapter number.  This line is formatted with the “Heading 1” style.  Beneath the chapter number line may be found two optional elements:  A chapter title for that chapter, and, after the title, a sub-heading for that chapter.  These are formatted with the “Heading 2” and “Subsubtitle” formats respectively.  


In my dissertation I used all three elements at the beginning of each chapter, although, as mentioned above, the chapter title and initial sub-heading are optional.  Here’s an example of those three elements taken from my dissertation: 

Here the chapter number line is “CHAPTER 2,” the chapter title is “PLANAR LAYOUTS,” and the sub-heading is “2.1  Even Height Trees.”  (Note that this is a small example created only for the purposes of illustration only.  I did not use the specified styles in the example.)  

This leads me to a discussion of a difficult formatting problem in a UTD dissertation with regard to the chapter headings:  Whether or not the chapter title and sub-heading are included, there must be exactly two blank lines after the chapter heading element and the actual text of the chapter.  (Remember that this text is formatted with the “Body Text” style, which should be used throughout your dissertation for the main text format.  Also, in this discussion, I am counting the “sub-heading” as part of the chapter text and not as part of the chapter heading.)  Therefore, if a chapter heading has a chapter number line only, with no chapter title, there must be two blank lines between the chapter number line and the chapter text (including the sub-heading).  On the other hand, if the chapter has both a chapter number line and a chapter title, then there must be one blank line between the chapter number line and the chapter title, and two blank lines between the chapter title and the chapter text.  Clearly then, the spacing after the chapter number line changes depending on whether there is a chapter title or not, and therefore, that spacing cannot be set to some default value that will work in all cases.  It must be adjusted by the user depending on the circumstances.  I will describe how to handle this problem in the “Setting up Chapter Headings and Sub-Headings” section below.  

In addition to the above styles, I have provided two styles that can be used to create two levels of sub-headings within each chapter, formatted with the "Heading 3" and "Heading 4" styles respectively.  The “Heading 3” style will be used for every sub-heading except the one that immediately follows the chapter heading.  The “Heading 4” style will be used for sub-sub-headings as described below.  It is very important that these styles be used for these purposes and for no others.  I recommend that you do not change these styles, nor use them for any other purpose.  

7.2 Setting up Chapter Headings and Sub-Headings

Although chapter stubs for Chapters 1 and 2 were included to make the numbering scheme work properly, the following discussion applies to all chapters equally, not just Chapters 1 and 2.  Note that both the Chapter 1 and Chapter 2 stubs have the chapter number line already included.  The line immediately after the chapter number line in each case is formatted to “Body text” by default.  (This same situation will occur even when you create Chapters 3 and above.)  What comes next depends on whether you want a chapter title or not.
7.2.1 If the chapter has a chapter title


If you do want a chapter title, then move the insertion cursor to the line immediately following the chapter number line, and set the style of that line to “Heading 2.”  (Note that “Styles and Formatting” can be accessed by choosing “Format” (menu), followed by “Styles and Formatting.”)  This will set that line to the correct style for a chapter title, which must be capitalized, center aligned, and bolded.  It will also be triple spaced by default, that is, there will be two blank lines inserted afterwards, so you can begin with the chapter text on the line immediately following the chapter title, whether you use a sub-heading or not, and it will be correctly spaced.  

Note that use of the “Heading 2” style for the chapter title is necessary.  When the computer creates a Table of Contents (TOC) later, it will scan your document for that style specifically, and include that text in the TOC.  Therefore, you should not use any other style for the chapter title.  

7.2.2 If there is no chapter title


If you do not want a chapter title, then the situation is slightly more complicated.  The style for the chapter number line, i.e. the “Heading 1” style, is set to double space by default, in order for the spacing between the chapter number line and the chapter title to be correct.  Consequently, the “Heading 1” style inserts only one blank line afterwards by default.  Since two blank lines are needed after the chapter number line if there is no chapter title, it is necessary for the user to insert an extra blank line manually.  This is done with the style called “SingleLine,” which was created for this purpose.  That style has no special formatting, that is, it is not bolded or centered, etc.  It does nothing more than create one single-spaced blank line, so the heading will comply with the UTD requirements.  

Therefore, the steps for creating a chapter heading that has a chapter number line but no chapter title are:  (a) move the insertion cursor to the line immediately following the chapter number line; (b) set the style of that line to “SingleLine” (this inserts an extra blank line); (c) move the insertion cursor to the line immediately following the SingleLine; (d) begin either the chapter text or a sub-heading (as described below).  
7.2.3 Setting up Sub-Headings


If you want to have a sub-heading follow the chapter number line or chapter title, simply manually format the appropriate line with the “Subsubtitle” format.  This will begin the numbering process within the chapter for sub-headings, and supply the correct formatting (i.e. bold, non-capitalized, etc.).  In addition, that style will also be scanned and included in the table of contents.  


Important point:
The “Subsubtitle” format is used only for this first sub-heading, i.e. the one that immediately follows the chapter title.  The “Heading 3” style should be used for all other sub-headings within the chapter at the same sub-heading level.  (This complication was not strictly necessary, but I did it to improve the spacing with the chapters.  If you look, you’ll notice that the “Heading 3” style has some spacing added before and after the style to improve the visual appearance.  Since this was not allowed in the chapter headings, I created a new style, i.e. the “Subsubtitle” style, which does not have the extra spacing.)  

7.3 Working with chapters 1 and 2


As mentioned, chapter stubs for Chapters 1 and 2 were included to make the chapter numbering scheme work properly.  However, all the heading format information previously discussed applies to these chapter stubs as well, so there is really no new information to add with regard to Chapter 1 and 2.  The main issue at this point is how to create chapters 3 and above, and that is described below.  
7.4 Creating chapters 3 and greater


To create all subsequent chapters, assuming that the first two have already been created, do the following:

1. move the cursor to a point immediately above the section break for the preceding chapter, but after any chapter text. 

2. choose Insert->Break->Section Break Next page.
This will create a new section for the next chapter.  (If you are using my "normal.dot" file, I have an icon set up for this, so you can avoid going through the menu system.  The icon looks like a page with two columns, and is right next to the "square root alpha" icon.)

3. with the cursor on the first line of the new section, simply set the style of that line to the style “Heading 1”.  This will automatically insert the word “CHAPTER X”, where “X” stands for the next chapter number.  Word will automatically calculate that number for you.

4. proceed as with the directions for chapters 1 and 2 above to create chapter titles, sub-headings, or chapter text as desired. 

In this way, you can create as many chapters as you need.  They will all have the correct formatting for page numbers:  The number for the first page of a chapter will be located in the middle of the bottom of the page, and all other page numbers will be located at the upper right.

8 To create subheadings within a chapter


The section applies to all sub-headings that do not immediately follow the chapter heading.  (For sub-headings that do immediately follow the chapter heading, see the discussion above.) 


Move the cursor to an empty line at the desired position in the document.  Set the style of that line to “Heading 3”.  This will cause the correct numbering and format of a sub-heading to appear.  (It is important that this be done on a new, empty line, otherwise you’ll simply change the format of an existing paragraph.)  


Sub-sub-headings can also be created by following the same steps with the style “Heading 4”.  This style will cause Word to create a heading number like "2.3.4", which would indicate chapter 2, sub-section 3, sub-sub-section 4.  I have only created built-in styles for sub-headings two levels deep.  If you want to go deeper, it will be necessary to reformat the “Heading 5” style, and link it to level 5 in the outline.


Again, note that the “SubSubTitle” style, and not the “Heading 3” style, should be used to create sub-headings that immediately follow the chapter heading.  

9 To create figures with captions


This is a difficult problem with Word, and it is one of several areas that Latex handles more naturally.  The problem in Word is that the figures must reside in the text layer (not the graphics layer) of the document if the figure captions are to be automatically detected when the table of figures is created, whereas the graphics, of course, reside in the graphics layer.  To keep these two items together and still allow the captions to be detected I used frames, since frames by definition reside in the text layer.  I recommend you familiarize yourself with the use of frames before attempting to do use my method.

9.1 Specific Steps

I followed the following steps to place a figure within my document:

1. create an empty frame where you want the figure to go.  I suggest creating a new blank line to do this.  Again, if you are using my "normal.dot" configuration file, you will find an "Insert frame" icon on the toolbar.  It's about in the middle of the toolbar, three icons to the right of the "Spelling and Grammar" icon.

2. click inside the frame to select the internal region.  A blinking cursor should appear inside the frame.  (Note that this is not the same as clicking on and selecting the frame itself.)  
3. the following steps vary depending on whether you are creating the figure itself from scratch or importing it from outside the document.

3.1. Creating a figure from scratch.  

3.1.1. Earlier versions of Word.

3.1.1.1. If you are creating the figure yourself in earlier versions of Word you can use the Word picture editor, activated by choosing Insert->Object->Word Picture, or by clicking on the "Word Picture" icon if you are using my "normal.dot" file.  When you are finished with creating the picture, it will reside inside the frame.

3.1.2. Word XP (2003)
3.1.2.1. Word 2003 also offers the picture editor described above, but in addition, includes the more powerful Picture Canvas option.  This can be accessed by choosing Insert->Picture->New Drawing option from the menu.  The picture canvas is more powerful than the older picture editor, and includes some of the formatting features available with frames, which it is intended to replace. 

3.1.2.2. In spite of the greater power of picture canvases, I still recommend that you use the frames feature, since it allows the picture and the caption for the picture to be treated as one unit.  

3.2. You have two options if importing a figure from a separate file:  You can choose either to include the picture in the document, or to include only a link to the figure.  In the latter case, the picture will continue to reside in a separate file.  Obviously if you link to the picture you can minimize the file size of your main document at the cost of having to manage more than one file.  

To insert a picture, choose Insert->Picture->From File.  To store the picture in the file, simply double click on the correct file.  To link to the picture in Word 2003, first select the file by single clicking, then use the downward arrow next to the “Insert” button to call down the small menu associated with the insert operation.  One of the options there is “Link to file.”  
4. after the picture has been inserted into the frame, select the frame itself by clicking on it.  When the frame is properly selected, small black sizing boxes will appear at the corners and the midpoints of all four sides of the frame. 
5. choose Insert->Caption from the Word menus.  The label defaults to "Figure" and the numbering defaults to Arabic.  Note that this dialog will not let you enter anything into the caption box, but that is not a problem.  

5.1. If you want to have the chapter number included with the figure:

5.1.1. Choose the “Numbering..” button in the dialog

5.1.2. Make sure the “Include Chapter Number” check box is checked

5.1.3. Set the format the way you want it (I personally used a period, “.”, between the chapter and section numbers.)

5.1.4. Hit “OK”

6. after exiting that dialog, the words "Figure X.Y" will be added below your figure, where "X" refers to the chapter number and "Y" to the sub-section number.  (This assumes you used chapter numbers, of course.  If not, then just the “Y” will appear.  These words will automatically be in the "Caption" style, and will therefore be detected when the table of figures is created later.

7. to create another line of text in the caption that contains some description of the figure, and which you want to appear in the table of figures, make sure the cursor is on the same line as "Figure X.Y", hold down the shift key, and hit <enter>.  The next line will still be in the "Caption" style, and will automatically appear in the tables of figures.

8. to create another line of text in the caption that contains some description of the figure, and which you do not want to appear in the table of figures, make sure the cursor is on the same line as "Figure X.Y", and hit <enter> without the shift key.  This next line will then be formatted with the "CaptionExtra" style, which is not detected when the table of figures is created.  

9. note that you may have to manually format the captions after they are inserted.  For example, you may want to center or bold them. 

9.2 An example of figure creation


There are many variations that can be used when dealing with figures; the steps I followed above are certainly not exclusive.  For example, you can import your figure into your document without creating a frame first, select the figure, make sure it resides in the text layer (the figure should have filled rather than open sizing handles when selected), and then put it in a frame by hitting the "Insert Frame" icon on the toolbar.  This will work fine.  But whatever you do, once the figure and caption are in a frame, you have quite a bit of control over figure placement and size.  Again, this is the method I used, and although it takes a bit of time to master, it will work.


[image: image1.wmf] 


Figure 9.1
Example Figure with Caption


The preceding figure is an example.  To create it, I performed the following steps:  (1) created a frame using the “Insert Frame” icon on the toolbar, (2) activated the Word Picture editor, again from the icon on the toolbar, (3) drew the picture of a circle and a long arrow, (4) closed the picture, (5) highlighted the frame and chose Insert‑>Caption from the menus, (6) clicked “OK”, which put in a default “Figure X.Y” type caption which was automatically formatted to the “Caption” style, (7) made some changes to the field codes (discussed below), (8) manually formatted the caption to be bold and centered, and finally, (9) hit Shift-<enter> to put in a soft carriage return and typed the “Example Figure…” line.  The result is a nice caption that will move with the figure wherever it is placed.  Furthermore, the figure number, “9.1” in this case, was automatically calculated by Word and will be recalculated if the figure is moved to another position in the document.  


Although this last point is not directly relevant to the template, it is such a useful technique that I thought I’d spend a few minutes on it while we are discussing the figure.  Take a look at the number “9.1”, which was also used in the preceding paragraph.  If you highlight that brief segment of text and choose “Toggle Field Codes” from the context sensitive menu, you will see that a REF field creates the number.  That is, the number itself is not “hard coded” into the document in any way; it is the result of a calculation.  The phrase “ExampleFigure” inside the REF field is the name of a bookmark that surrounds the actual number in the figure caption.  (If you click on the “Bookmark” icon on the toolbar, just to the right of the double exclamation point icon for insertion of a sequence field, you can go to that bookmark to verify.)  When the REF field is used in this way, it simply copies the information inside the bookmark to the location of the REF field.  If the information inside the bookmark is updated in any way, that change will be reflected in the REF field with no effort on your part (except to instruct the computer to “update fields”).  For example, if this figure were moved to a different section, say to section “8” instead of section “9,” as it is in this case, the values inside the REF field would be automatically updated when the field codes for the whole document are updated.  Therefore, it would not be necessary to manually search through your document looking for references to that figure to make sure they are correct; the computer will handle the change of section automatically.  This “bookmark / REF field” combination is an incredibly useful technique, and I used it throughout my dissertation.  


The slight problem I had with step (7) above was that the STYLEREF field, which is used to get the number that appears before the period in the “X.Y” number format, is set by default to use the “Heading 1” style to calculate the number.  You can see this if you “Toggle Field Codes” immediately after the caption is installed.  The field at that point will read “{STYLEREF 1 \s}”, where the “1” refers to the “Heading 1” style.  The problem is that I didn’t use the “Heading 1” style in this write-up to create the heading numbers; I used the “Heading 3” style.  Therefore, STYLEREF returned an error message indicating that it could not find the correct style.  To fix this problem, I simply changed that “1” to a “3” in the STYLEREF field code and thereafter the numbering worked fine.  (In the “dissertion 2005.dot” template this should not be not a problem, since the Chapter numbers were created by the “Heading 1” style.  The default caption should therefore work fine.)

10 To create the Table of Contents (TOC)


Do the following steps exactly:

1. highlight the line that says “Click and Insert Table of Contents”

2. Choose Insert->Index and Tables

2.1. In Word 2003, this is accessed by Insert->Reference->Index and Tables

3. go to the Table of Contents tab

4. make sure that "Show page numbers" and "Right align page numbers" are both checked, the tab leader is “…”, and that "Show levels" through 4 are set.

5. choose the “Options” button

6. make sure the “Styles” box is checked

7. in the “Available Styles” list, do the following

7.1. clear the number for “Heading 1”

7.2. make sure Heading 2 through 4 are set with the numbers 2 through 4

7.3. set the “Section Label” style to the number 9

7.4. set the “SectionLabel2” style to the number 7

7.5. verify that the style “SubSubTitle” is set to number 3

8. choose “OK” to close the options box

9. choose “OK” to create the TOC


This will create a pretty nice TOC.  All page numbers should be automatically calculated.  If not, highlight the entire TOC and choose “Update Field” from the context sensitive menu.  Sometimes it is necessary to do this even after the table has been created to get the correct page numbers.


Note that TOC’s can be directly edited after they are created.  You can use this feature to adjust the formatting if necessary.  (For example, if you want to manually change the spacing between some lines after the TOC is calculated, Word allows you to do that.)  


Also, be aware that TOC’s in Word are created by a TOC field.  To access the field code itself, highlight the entire TOC and choose “Toggle field codes”, which will display the field code itself instead of the result of the field.  Note that all Word fields have codes that can be directly edited if the field code is displayed, and many of the formatting and other characteristics can be controlled by switches embedded in these fields.  (For example, in the case of the TOC field, if you remove the “\h” switch, the TOC entries will no longer function as hyperlinks.)  

11 To create the Table of Figures (TOF)


Do the following steps exactly:

1. highlight the line that says “Click and Insert Table of Figures”

2. Choose Insert->Index and Tables

2.1. In Word 2003, this is accessed by Insert->Reference->Index and Tables

3. go to the Table of Figures tab

4. make sure that "Show page numbers" and "Right align page numbers" are both checked, the tab leader is “…”, the formats are "From templates", and the "Include label and number" box is checked.

5. choose the “Options” button

6. make sure the “Style” box is checked

7. in the styles drop-down list, choose "Caption"

8. choose “OK” to close the options box

9. choose “OK” to create the TOF

10. if the computer asks you if you want to overwrite an existing table, and highlights the TOC while asking you this, say “No”.  This will prevent the computer from replacing your TOC with the TOF.  If it is highlighting an existing TOF, and you want to replace it, then it is okay to say “Yes.”  


This will create an initial TOF, and again, all page numbers should be automatically calculated.  However, I personally was not completely satisfied with the format of the result in this case.  For example, since I used the automatic captioning feature for my figures, the word "Figure" was repeated on each line, which seemed redundant to me.  Therefore, I typically edited the TOF after creating it.  First, I used Find/Replace to eliminate the word "Figure" from each line.  I then manually edited each line to place a tab, instead of a space, between the figure number and the following text.  This is tedious, I admit, but I have not yet figured out how to make this happen automatically.  Nevertheless, it is still faster than creating the TOF by hand if you have a lot of figures.

12 Getting copies of the dissertation made


I got my dissertation copied by first printing a copy on a laser printer, and then taking the copy over to the UTD Copy Center to be copied.  Since it is extremely difficult to generate a smudge free printout, this was a very difficult and time consuming process, and several of us at the time had real problems getting the whole task done.

Fortunately, this process has been considerably improved.  My understanding is that the Graduate Dean’s Office has a program that will convert your Word document to a PDF file which is then taken to the copy center and printed from there.  This removes several intermediate steps and should make it much easier to get a clean copy of your dissertation.  Be glad!  

13 Miscellaneous suggestions

13.1 Outline view


Learn to use the Outline View feature in Word for Windows.  Outline View is designed to operate from the built-in Word styles, like "Heading 1" and "Heading 2", so this template works very well with outline view.  In Outline View you can instantly go from Chapter 1 to Chapter 5, for example, then change back to Normal or Page Layout View to work.  It is a very powerful and easy way to navigate through a large document.  


You can change between the various “views” by using the small icons at the lower left hand corner of the screen, or by using the “View” menu, but I used the following keyboard shortcuts to good effect:  Ctrl+Alt+P (Page Layout View), Ctrl+Alt+O (Outline View), Ctrl+Alt+N (Normal View).  

13.2 Table of Contents generation


Every time a TOC is generated, Word produces a series of hidden bookmarks.  Word does not delete these bookmarks when the tables are updated, so they can build up over time if the TOC is updated repeatedly, eventually corrupting the document.


I suggest that you wait until your document is completely finished before generating the table of contents and the table of figures.  If you want to experiment with these functions at any point, create a copy of your dissertation and do your experiments in the copy.  (I did this several times to make sure everything was working properly.)  This will avoid any problems with the hidden bookmarks.  

13.3 Getting help


If you have trouble while working with a large document per se, I suggest visiting the "Microsoft.public.word.formatting.longdocs" newsgroup.  I used that newsgroup extensively when I was developing this template and writing my dissertation, and the folks there are very competent.  They won't be able to help you with specific questions regarding this template, of course, but they are very helpful otherwise.  It's a great resource.  

14 Final notes


My feeling is that getting a Ph.D. is tough enough without having to mess with the huge set of extraneous details involved in writing and formatting the dissertation.  I hope this template helps smooth that difficult process.  

Unfortunately, I won't be able to answer any direct questions about it, but if you spend some time with it, I'm sure you can make it work.  

Best of luck with your dissertation and subsequent career!


Regards,  

Charles Shields, Jr., Ph.D.
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