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An  ArcScene  Example  for the UTD Area  (as used in GIS Fundamentals)
The data for this demo is available in:   P:\briggs\g6381\av3d
ArcScene is basically a 3-D version of  ArcMap,  and can be launched from the Start menu, or from within ArcCatalog or ArcMap if the 3-D extension has been loaded. (Extensions are loaded thru Tools/Extensions. You generally then need to also open specialized toolbars for these extensions via View/Toolbars.)

Go to Start/Programs/ArcGIS/ and select ArcScene—the ArcScene application opens.

Go to File/open, navigate to P:\briggs\g6381\av3d and load  utdsurface9.sxd

The top graphic is a 3-D TIN with elevation shade, “draped” with a road file and digital otho (40% transparency).

--use the Navigate tool (1st--space ship) to rotate the view and change your  perspective

--use the 3-D Zoom In/Out tool (2nd) to zoom in (drag across screen)


e.g look at lakes in lower left (Cambell west  of Coit), or WaterView Parkway  

--click Globe icon to return to full extent after zooming

select the Identity (info) tool ( blue “i”)

--click on the map (away from roads) and you are given its elevation, slope, aspect

Turn on the TIN display layer (last layer in TofC):  this shows the construction of the TIN surface.


(it’s actually a copy of the utdtin layer displayed in a different manner—see step 3 below)


TINs can only be displayed with ArScene and 3-D Analyst.

The lower graphic is a 2-D contour line and raster representations of the same elevation surface.

Consists of a shapefile of contour lines, on top of an elevation raster (in ESRI’s GRID format)

--turn off contours: raster depicts surface features quite well

-

--select magnifier tool: zoom in to show rasters.


Right click Raster Elevation GRID in Tof C, select Properties,  and click Source tab

Note: Cell size: 48.12 feet 
  
48.12(cell size)x166(rows)=approx 8,000ft  



Data is for 8,000 by 12,000 “tile”
48.12(cell size)x249(cols)=approx 12,000ft 

Contours (in shapefile format) and GRIDs can be displayed in regular 2-D ArcMap. However, to do analyses with GRIDs you need the Spatial Analyst extension. 

Creating the  UTD ArcScene Example

1. Open Blank  ArcScene document

Go to Start/Programs/ArcGIS/ and select ArcScene—the ArcScene application opens.

A toolbar beginning with 3-D Analyst button should be available. If not, go to View/Toolbars and load it.


Click the Add Data icon (big black +), navigate to P:\briggs\g6381\av3dand select utdtin


--a map appears; it is in 3-D but there isn’t much relief in North Dallas!

2. Modify Vertical Exageration for the Scene 

In the ArcScene Tof C, right click on the Scene Layer title (at the very top) and select Scene Properties


--The Scene Properties dialog opens: here you can set properties to apply to all layers in the scene 



--Under General tab, click Calculate from Extent on vertical exaggeration line, then click Apply



--north Dallas turns into the Rockies




--type “6” into the vertical exaggeration box, then click Apply button, then OK button 
 

3. Show TIN construction 

Double click (or right click)  utdtin entry in ArcScene  TofC 

--the Layer Properties dialog opens:   select the Symbology tab



The Show box (on left side) controls which  features of the TIN are displayed



The right box controls the symbology used for the display of a particular feature



Faces with same symbol is selected, which is not very useful!   


--click the Add button below the Show box: 

the Add Renderer dialog lists more features to display

Click on Edges with same symbol to select it, then click Add button in Add Renderer dialog

Click on Nodes with same symbol to select it, then click Add button in Add Renderer dialog

Click on Face Elevation with graduated color ramp to select it, then click Add button 





Click Dismiss button to close Add Renderer dialog



--in the Show box, place check marks next to Elevation, Edges  and Nodes,(not Faces)

       



--click Apply button,  then the OK button to close the Layer Properties dialog


You can now see the TIN triangles from which the elevation surface is constructed. 

4. Show slope or aspect (direction of slope)


again, double click (or right click)  utdtin entry in ArcScene  TofC  to open the Layer Properties dialog


again, click the Add button below the Show box to open the Add Renderer dialog



Click Face slope with graduated color ramp then click Add button in Add Renderer dialog



Click Face aspect with grad. color ramp to select it, then click Add button in Add Renderer dialog



 
Click Dismiss button to close Add Renderer dialog

in the Show box, place check marks next to Slope, Edges, &  Nodes and remove all other checks
       



--click Apply button,  then the OK button to close the Layer Properties dialog



--the slope of each TIN is now color coded



--to display aspect, place check against Aspect rather than Slope in the Show box 


Return things to the original by placing check against Elevation in the Show box and removing all others.

5. Add Roads for orientation


Click the Add Data icon (big black +), navigate to P:\briggs\g6381\av3d, and select utdcnli.shp



--roads display below the surface ‘cos they have no elevation


Double click utdcnli.shp in Tof C—Layer Properties dialog opens. Select Base Heights tab.



In Height box, click Obtain heights form surface and be sure utdtin shows in the window



In Offset box, type in 2  (this raises roads 2 units above the surface (prevents overlaying)



Click Apply button, then OK button to close.



Use the Zoom tool (magnifier glass) to zoom to the upper right corner. 

Note the stream channel by Floyd Rd and the ditch between the two carriageways of Waterview Parkway


6. Add  Digital Ortho Image 

Click the Add Data icon (big black +), navigate to P:\briggs\g6381\av3d, and select 24967042.jpg



--again, image displays below the surface ‘cos it has no elevation


Double click 24967042.jpg in Tof C—Layer Properties dialog opens. Select Base Heights tab:



In Height box, click Obtain heights from surface 

Click down arrow in box below and select  utdtin  

In Offset box, type in 1  (this raises ortho 1 unit above the surface (prevents overlaying))



Click Apply button, then OK button to close.


The digital ortho image has been “draped” over the surface—but you can’t see the elevation shading.


Again, double click 24967042.jpg in Tof C, and select the Display tab

In the Transparent box, type in  40.  In the Resample box select Bilinear Interpolation (looks better)

Click Apply button, then OK button to close. Elevation shading shows thru.

7. Create Contour Lines (2-D surface display)

Click the 3-D Analyst button on the toolbar, select Surface Analysis,  click Contour, and the Contour dialog opens.


Select utdtin in drop down box.  In the Contour interval box, type 10 

On the Output features line, click the browse button and navigate to a folder to save contour shape file 


Click OK, and a new shapefile containing contour lines is created, added to the TofC, and displayed.

Contours are inherently a  2-D display of elevation and can be added to any  2-D ArcMap view.

You can also “drape” them on the surface 3-D ArcScene surface if you wish, as we did with roads.

8. Creating Elevation Raster (2-D surface display)

Click 3-D Analyst button on 3-D Analyst toolbar and select Convert/Tin to Raster


Input TIN: utdtin


Attribute: Elevation (other option are slope (degrees), slope (%), and aspect )


Output raster: navigate to folder where you can save a file (it’s saved as utdtingrid on p:\)


Click OK button

A raster (in ESRI’s GRID file format) is created and added to the display.

9. Additional capabilities are available by adding other toolbars via View/Toolbars
Obtaining Elevation Data :   Create a raster GRID using USGS Data

1. For a summary of elevation data set availability, go to:  http://edc.usgs.gov/products/elevation.html
More detail about those from USGS (as well as other USGS data) is at http://edc.usgs.gov/geodata/
2. Elevation Data 

· The original Digital Elevation Model (DEM) 7.5 minute tiled data, in Spatial Data Transfer Standard (SDTS) form only,  is available at no cost via downloads from several places e.g.: GeoComm International Corporation at http://gisdatadepot.com/dem, from MapMart.com at http://www.mapmart.com. Data is NAD27, NAVD1929, UTM projection, elevations in feet (a few are in meters), 30 meter (approx 100 feet) spacing. US only.  Has been superceded by NED data

· The  National Elevation Dataset (NED) for the US “merges the highest-resolution, best-quality elevation data available across the United States into a seamless raster format.” NED is a cleaned up DEM converted to NAD 83  lat/long with elevations in meters. Spacing is again 30 meters. Again derived from 1:24,000 7.5 minute (1:63,360-scale DEM data for Alaska).” Seamless Data Distribution System (SDDS) offers seamless data for sale (and, as of 2005, for free), by user-defined area, in a variety of formats. Available data formats include ArcGrid, Floating Point, and BILS. Go to http://seamless.usgs.gov/ for download and more info.  Completed around 2000
Note: higher resolution  data (up to “1/9”th DEM = 3 meter) is being developed from other data sources such as LIDAR but full national coverage is not yet available.
· GTOPO30 global digital elevation model (DEM) with a horizontal grid spacing of 30 arc seconds (approximately 1 kilometer) derived from several raster and vector sources (uses USGS DEMS for US) completed in 1996. Go to http://edc.usgs.gov/products/elevation/gtopo30/gtopo30.html
· ASTER DEM  30 meter resolution derived from stereoscopic analysis of ASTER imagery collected by the Terra satellite launched in 1999 as part of NASA’s Earth Observing System (jointly with Japan). Coverage is global but limited: Go to http://lpdaac.usgs.gov/aster/dem_map.asp  
· The  Shuttle Radar Topography Mission (SRTM) provides a 30 m (1 arc second—Level  2) resolution DEM for the US and 90 meter (3 arc second—Level 2) for rest of world with data collected in 2000 from Space Shuttle Endeavor and released around 2005. For details, go to  http://srtm.usgs.gov/.  “Finished” data is distributed in two formats:  SRTM Format, and SRTM DTED (Digital Terrain Elevation Model) format. (You can also get the data in original ‘unfinished,’ prior to processing form.) For download of data for US, go to http://seamless.usgs.gov/.  For CD/DVDs of all data, use links at http://edc.usgs.gov/products/elevation.html  
· LIDAR (Light Detection and Ranging) Data:  airborne system which collects elevation data using laser light pulses. Can collect data at resolutions down to 1 foot spacing. Many local government organizations have collected data for their areas, and some make it available. Provides two elevations: bare earth and canopy (tree or building tops).

Go to the following Technology Assessment Report  from GISC 6383 for detailed overview of sources:

http://charlotte.utdallas.edu/mgis/ClassFiles/gisc6383/techassess_2004/Cooper_tech.ppt#1
and for a discussion of elevation data collection methodologies:

http://charlotte.utdallas.edu/mgis/ClassFiles/gisc6383/techassess_2003/Elevation%20Data%20Collection3_files/frame.htm
3. For Texas, DEM and NED data is available free from www.tnris.state.tx.us: click the  digital data button and then enter the name of the county, or of  the USGS quad., for which you want  data and click Submit button. You will then see the options for various data sets including DEM and NED. Note: Addison quad covers west  part of UTD campus and Garland covers east part.  (Again, this confirms the truth that any area a user wishes to map will be on the border between 2 or more map tiles.!). 
4. Samples for DFW.  The folder P:\briggs\g6382\Exercise_data\surfaces contains DEM and NED data downloaded from TNRIS and unzipped, and SRTM data downloaded from the  USGS and unzipped,  for selected DFW areas. Data must be in a format that ESRI software can read, most commonly ESRI’s GRID format
· For the DEM data:

a. Data are selected 7.5 minute USGS quads including Addison, Garland, Cedar Hill.

b. usgs_dem_txt is generic documentation for all USGS DEMS. Read with Word.

c. Ordr6dem.txt lists the DEM files for this region, resolution, datums, units for elevation, etc. Read with Excel, specifying comma delimited. 

d. 3296020g.dem (and similar) is the actual DEM data. It’s an ASCII file so you can look at it in Excel (use fixed field format) to get an idea of the data.

· For the NED data (which was obtained from TNRIS):
a. the file is in ESRI’s E00 interchange format 
b. It is in 1 degree x 1 degree tiles with the lower left at 32N 96W (for the sample file)

· For the SRTM data:

a. The file is a user defined area (e.g. UTD campus area) in ESRI’s GRID format (unzipped)

5. DEMs must be converted to GRID (ESRI”S raster format) before they can be used in ArcGIS
e. Add a folder  c:\usr\initials\surfaces

f. Go to ArcToolbox>Conversion tools>To raster/DEM to Raster 

In USGS DEM box navigate to p:\…surfaces\DEM\ 3296020g.dem

Select float for Grid type (integer is used for classifications e.g soil type)

Z-factor is 1 (could be used to convert feet to meters)

Output grid:  Addison_dem

g. Repeat for Garland  (3296030g.dem)

h. If you preview the data in ArcCatalog, note that projection system has been automatically assigned (NAD27, UTM) by the conversion tool.

6. To convert the NED data
· Depending on format, you may need to convert. If in “E00” format (ESRI Interchange format), go to:

 ArcToolbox>Coverage Tools>Conversion>To coverage>import from Interchange File 
Input file:  …NED\ dem3296.e00

Output grid:  dfw_SE_ned      Save as file type:  GRID


Again, the projection system will be automatically picked-up: its NAD83, Lat/Long

7. The SRTM needs no conversion. It is already in GRID format from the USGS’s ArcIMS download site.

8. Open  ArcMap and display the elevation data

· To orient yourself and define projection, add  P:\briggs\g6382\DataSets\Coverages\rdstr95 (roads) and label using Street 

· add the NED file  and build pyramids

· add DEM data: you will get a warning ‘cos DEM has a different datum (ArcMap does on the fly projection conversions but  not datum transformations)

· add SRTM data

· Right click on garland_dem (or addisson_dem), and select Properties/Source

--note that X cell size and Y sell size are 30:  reflects  the 30 meter spacing 

· Right click on dfw_SE_ned  or UTD_SRTM  and select Properties/Source

--X and Y cell size are not 30:  because the data is in lat/long

--however, if you measure grids they are 100 feet (30 meters) in N/S direction 

· To change coloring, right click on garland_dem  and select Properties/Symbology 

· Zoom into the UTD campus area, if desired

Create TIN from .csv file
9. The easiest form of elevation data is a .csv (comma separated variables)  text file. This file can be created in Excel and should contain either ID, X, Y, Z. or just X,Y, Z variables.  It must contain a header row identifying the X, Y and Z variables.  24967042_all.cvs is an example of  a file with header and ID.  (This was created from the North Texas GIS consortium points and lines files.  See section below.) (There is an alternative approach if the file has no header and consists of just X,Y,Z)  
To convert this data to a TIN:
(1) Open ArcScene, and use Add  Data to bring in the 24967042_all.cvs 

          (Note:  in Show of Type box, you will need to specify All filters listed in order to see .csv files.) 
          (Note 2: actually, this step is not needed. You can  directly read the data with the following tool)        

(2) Use ArcToolbox/Data Management/Layers and Table Views/Make XY Event layer to create an event layer

     (unlike in ArcMap, this process is not available simply by right-clicking the .csv layer in the Table of Contents)
(3)  Click 3-D Analyst drop down menu and select  Create/Modify TIN>Create TIN from Features   
          --in Layers box, place check by 24967042_all_layer and, while this line is highlighted, check that:

                      Height source: z
                     Triangulate as:  mass points

          --for Output TIN  specify utdtin_csv
Alternative approach to (1) &  (2) if your .csv file does not have header row or ID variable, open ArcScene and run the tool: 
    ArcToolbox>3D Analyst Tools>Conversion>From File>ASCII to Features 

                    Click the browswer button  and Input… surfaces/TIN/249067042_nohead.cvs 

                 Input File Format:  XYZ

                 Output Feature Class:  24977042_csv.shp


          Output Feature Class Type: POINT

                   Click OK  and the shapefile should be added to ArcScene

To create the TIN, repeat the same process as in (3)  above,

Click 3-D Analyst drop down menu and select  Create/Modify TIN>Create TIN from Features             
             ---in Layers box, place check in 24967042_cvs.shp and, while this line is highlighted check that:

                      Height source: feature Z-values
                     Triangulate as:  mass points
              ---For Output TIN, specify  utdtin_csv2        -    

Create TIN from North Texas GIS Consortium Points and Breaklines data

10. In 1994/95, the North Texas GIS Consortium, sponsored by UTD, developed the first region-wide high resolution elevation data for the DF/W area in conjunction with the creation of   digital orthophotographs for the region. It had ½ meter resolution, 1 meter positional accuracy. The raw elevation was in “points and break lines” format suitable for the creation of 6 foot contours. These data are particularly suited for TINs, but will also work for rasters or contours. These data are available in the lab at:  Q:\NTGISC.

     An example of this data for the tile covering UTD is in …surfaces/TIN. 

The .lns and .pts files are often referred to as GENERATE files based on the name of the command which was used in the old ArcINFO to read them. They are simple ASCII files. Open them in Wordpad (not Notepad)  and you will see they are nothing more than: 

 For points:  ID (1 in this case), X coord, Y coord, elevation   with END in the very last line 

 For lines: a line ID in the first row (3), followed by X,Y, Z in subsequent rows, ending with an END 

                   --this pattern is repeated for each line;  the IDs are all 3 in this example

For more information on GENERATE files see ArcHelp: How Generate (Coverage) works 
      Note:  the 24967042_all.cvs discussed above was created by combining the  .lns and .shps files,  

              removing the END rows, etc
11. To create a TIN in ArcGIS 9 using the original .lns and .pts file you first create shapefiles,  then build the TIN

Open ArcScene, then  ArcToolbox.

     To create shapefiles with Z field: 
             Go to ArcToolbox>3D Analyst Tools>Conversion>From File>ASCII to Features 
       Click the browswer button  and Input… surfaces/TIN/249067042.PTS  

                 Input File Format:  GENERATE 
                 Output Feature Class:  24977042_pts.shp


          Output Feature Class Type: POINT

                   Click OK and the shapefile should be added to ArcScene
       Run the same tool again and Input:…surfaces/TIN/249067042.LNS


Input File Format:  GENERATE 

                 Output Feature Class:  24977042_lns.shp


          Output Feature Class Type: POLYLINE

                   Click OK and the shapefile should be added to ArcScene
           To create the TIN:  
                Click 3-D Analyst drop down menu and select  Create/Modify TIN
                          We will build the TIN from both shapefiles 

               (If in ArcMap,  use View/Toolbars to open 3-D Analyst toolbar)
          --in Layers box, place check in 24967042_pts.shp and, while this line is highlighted check that:

                      Height source: feature Z-values

                     Triangulate as:  mass points
          --in Layers box, place check in 24967042_lns.shp and, while this line is highlighted check that:

                      Height source: feature Z-values

                     Triangulate as:  hard line  (or soft line if these are not hardbreaklines)  
          For Output TIN, specify   UTDTINptslns
            --Click OK and TIN should be created

              --you may need to adjust the vertical exaggeration (Scene Properties) to see it more clearly.

Note:  because we were  able to specify hard breaklines, this TIN will be more precise than the TIN cerated with the .csv file.above.  Stream and road edges are “sharper”.

Other ways of Creating TINS

12. You can  create a TIN from any shapefile, gdb feature class or coverage providing that there is “height” or z field available.  If you use  ArcToolbox,  it is a two step process:


(1) Create empty TIN  with ArcToolbox\3-D Analyst Tools\TIN Creation\Create TIN
 
(2) Bring in data from using ArcToolbox\3-D Analyst Tools\TIN Creation\Edit  TIN


There must, of course, be a “height” filed in the input data

                   For shapefiles used in the NTGISC example above:

                                  Height field is specified as “shape”  

                                  SF_type  is:   masspoints points

                                                       Hardlines for line files,  if these are hard breaklines (as in the example data) 
                  If you have a coverage, for heights field specify angle  .

13. To create a TIN from points and lines in ArcInfo Workstation

Run the AML   utd_newtin.aml  (see   ex6_custom.doc    and the corresponding data folder)
Alternatively, the following ArcInfo command can be issued individually:

PRECISION Single Highest

CREATETIN C:\usr\ron\surfaces\utd_newtin # # 1

GENERATE P:\briggs\g6382\Exercise_data\surfaces\TIN\24967042.pts Point Mass # 

GENERATE P:\briggs\g6382\Exercise_data\surfaces\TIN\24967042.lns Line Hardline # 

END

Lab/Homework  Exercise
Create a 3-D scene using the DEM for the Cedar Hill quad (p:\..surfaces\3296250g.dem or  download from the TNRIS web site) and the digital orthos 24366906.jpg  and 24246906.jpg (in p:\…surfaces\othos). 

Hint: the dem and the orthos are in State Plane North Central Texas zone but the DEM is NAD27 whereas the orthos are in NAD83 which has a different origin for coordinates. They will not overlay unless you define the coordinate system for the display as NAD83 North Central Texas zone (e.g. by importing from rdstr95 coverage) first, then bring in the DEM and the orthos. Also, the DEM was created before the lake!  Get SRTM data and repeat. 
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