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1 Introduction 

CHAPTER 1 
Introduction 

/* The first time you say how to run WMS is in section 4.1.  It should either be 
in the beginning of every section, or moved to this first chapter.  

Chapters 5-19 have a different format than chapters 1-4.  Maybe add overview, 
objectives, and estimated times to chapters 1-4. 

In some of the tutorials, it says “if you are continuing from another tutorial, 
select New . . . “  (see 12.1).  Either put this at the beginning of every chapter 
or only at the beginning.  Sometimes when consecutive chapters talk about 
similar processes it’s unclear whether you should start over.  

14.2, 2nd list, step 2 – it says outlets are displayed as a yellow circle with a 
black center.  Either include this earlier, like the first time you talk about an 
outlet, or maybe make a legend of symbols at the beginning. */ 

 

This document contains tutorials for the Watershed Modeling System (WMS).  
Each tutorial provides training on a specific component of WMS.  Since the 
WMS interface contains a large number of options and commands, you are 
strongly encouraged to complete the tutorials before attempting to use WMS on 
a routine basis. 

In addition to this document, the WMS Help File also describes the WMS 
interface.  Typically, the most effective approach to learning WMS is to 
complete the tutorials and use the help file when encountering a portion of 
WMS that is unclear. 
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1.1 Suggested Order Of Completion 
Tutorials 2-7 cover the basic data structures used in WMS (GIS vector data or 
feature objects, DEMs, and TINs) and how watersheds can be delineated to set 
up hydrologic models from them.  Tutorials 2-3 cover feature objects, 4-5 
DEMs, and 6-7 TINs.  After going through the basics, tutorials 9 and 14 cover 
supporting hydrologic calculations such as curve number generation from land 
use and soil data layers (14) and time of concentration (or lag time) 
computations from computed geometric values.  Tutorials 8 and 10-12 cover 
some of the supported models, and the rest of the chapters cover advanced 
tools and miscellaneous topics. 

It is unlikely that you will need to work through all of the tutorials, but we 
recommend that you go through 2-7 and then the remaining tutorials, which 
cover model interfaces and advanced tools, can be completed according to the 
interfaces you use and as you have time.   

1.2 Demo vs. Normal Mode 
The interface for WMS is divided into six separate modules.  Some of the 
modules contain interfaces to models such as HEC-1.  Such interfaces are 
typically contained within a single menu.  Since some users may not require all 
of the modules or model interfaces provided in WMS, modules and model 
interfaces can be licensed individually.  The modules and interfaces that have 
been licensed are enabled using the Register command in the File menu.  The 
icons for the unlicensed modules or the menus for model interfaces are 
dimmed and cannot be accessed. 

You can complete all of the tutorials if you have licensed the digital terrain 
and map modules.  However, if you have only licensed one (or more) of the 
hydrologic models separate from the digital terrain and map modules, there 
will be some tutorials which cannot be completed.  By switching to Demo 
mode you will be able to run all of the tutorials, but printing and saving will be 
disabled.  This is done by selecting the Demo Version On command in the File 
menu.  When you wish to return to normal mode, select the Demo Version Off 
command in the File menu.  If you are using a demo copy of WMS and you 
have not licensed any modules, you will be in demo mode by default and will 
not be able to switch to normal mode. 

It is suggested that you start WMS new at the beginning of each tutorial.  If 
you continue from one tutorial to another without quitting, then data, display 
options, and other WMS settings may not be in sync with the tutorial 
instructions causing the exercise to become confusing. 



 

2 Basic Feature Object Manipulation 

CHAPTER 2 
Basic Feature Object Manipulation 

The Map Module is at the heart of most operations in WMS, so it is important 
to gain a good understanding of how to create, edit, and apply feature objects. 
Within WMS, feature object data can be used for drainage characterization, 
land use, soil types, time of travel calculations, and many other applications.  
Often, the data you will want to use already exists in some other format.  This 
tutorial session will focus on the basic concepts behind manipulating feature 
objects and coverages.  Also, this tutorial will discuss creating feature objects 
from background images. 

2.1 Feature Object Definitions 
Feature objects in WMS have been patterned after Geographic Information 
Systems (GIS) data objects and include points, nodes, arcs, and polygons 
(Figure 2-1).   
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Figure 2-1 Feature Objects. 

Feature objects can be grouped into coverages.  Each coverage represents a 
particular set or group of data.  The following coverage types can be used in 
WMS: 

• Drainage - defines basin boundaries and stream networks. 

• Land Use – defines land use type polygons 

• Soil – defines soil type polygons 

• Time Computation – used for determining lag times and times of 
concentration. 

• Generic 

• Other model specific coverages 

In this tutorial you will learn how to create points, arcs, and polygons to 
develop these coverage types. 

2.2 Display and Manipulation of Coverages 
Because there are several different data layers represented by feature objects, it 
is important to understand a few rules about how they are created and edited.  
There is always one and only one active coverage at a time in WMS.  Any time 
you wish to edit points, arcs, or polygons in a coverage, that coverage must be 
designated as the active coverage.  Also, any new feature objects that are 
created are added to the active coverage.  The active coverage is the only one 
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displayed in full colors.  All feature objects of the inactive coverages are 
displayed in a single color (light gray by default). 

In this section you will learn how to open a file and work with multiple 
coverages. 

1. Select the Map module icon . 

2. Open “asptutor.map”.  This file should be found in the tutorial 
directory.    

3. Select the Coverages… command from the Feature Objects menu. 

4. Notice that for each coverage, the name, attribute set, active status, and 
visible status can be changed.  To change the attributes for a coverage, 
select the coverage name from the text window and set its attributes. 

 

Figure 2-2 The Coverages Dialog. 

5. Select the Soil Type coverage from the text window and turn off the 
Visible option.  Then, select the Land Use coverage from the text 
window and turn off the Visible option.  Select the OK button to exit 
the Coverages dialog.  Notice that the only coverage displayed is the 
drainage coverage. 

6. Select the Coverages… command from the Feature Objects menu.  Set 
the Soil Type and Land Use coverages to visible.  Select the Land Use 
coverage and select the Active button.  Select the OK button to exit the 
Coverages dialog.  Notice how the Land Use coverage is now drawn in 
different colors, while the other coverages are drawn in the inactive 
coverage color. 
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7. Select the select polygon tool , select one of the polygons in the 
Land Use coverage, and select the Attributes… command from the 
Feature Objects menu.  Notice that the Land Use Mapping dialog 
comes up.  This dialog can be used to assign land use ID’s to selected 
land use polygons.  The Land Use Mapping dialog can also be used to 
change the attributes assigned to each land use ID and to create new 
land use ID’s.  Select Close to exit the Land Use Mapping dialog. 

8. Select the Display Options… command from the Display menu.   

9. Select the Map tab. 

10. Turn on the Land Use Legend option and select the OK button.  Notice 
that a land use legend is displayed on the screen. 

11. The upper left corner of the edit window displays the active coverage 
and the drop-down combo box allows you to change the active 
coverage without invoking the Coverages dialog as demonstrated 
previously.  Change the active coverage to the Drainage coverage by 
choosing it from the active coverages drop-down combo box in the 
Edit window. 

12. Select the select polygon tool, select one of the polygons in the 
Drainage coverage, and select the Attributes… command from the 
Feature Objects menu.  Notice that the Drainage Feature Polygon 
Type dialog comes up. 

13. The Drainage Feature Polygon Type dialog can be used to change the 
type of a drainage polygon to a Generic, Drainage, or a Lake/Reservoir 
polygon.  The polygon (as well as the point and arc) attribute dialog 
changes are based on the type of the active coverage and the selected 
tool.  For example, if the active coverage is a land use coverage and 
the select polygon tool is selected, the Land Use Mapping dialog will 
come up.  However, if the active coverage is a drainage coverage and 
the select polygon tool is selected, the Drainage Feature Polygon Type 
dialog comes up.  Select the Cancel button to close the Drainage 
Feature Polygon Type dialog. 

14. Select the Display Options… command from the Display menu. 

15. Select the Map tab. 

16. Select the Land Use coverage from the drop-down list at the top of the 
dialog. 

17. Toggle the Land Use Legend option off and select OK. 

18. Select the New command from the File menu to delete all your data. 
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2.3 Using TIFF Images to Create Feature Objects 
An image is an excellent way to provide a “background” picture from which 
streams or other features may be digitized directly from the screen.  However, 
before an image can be used to define feature objects with accurate 
coordinates, it must be properly registered.  All of the tools necessary to 
register and use images are available within the WMS interface. 

There are three basic scenarios for registering images: 

1. You must determine the correct coordinates and enter them manually 
in the image registration dialog.  This is what is demonstrated in this 
tutorial and generally is applicable if you have scanned the image 
yourself using a desktop scanner. 

2. You image file (.tif) contains a corresponding tiff world file (.tfw).  
The tiff world file will have the correct registration information for the 
image and can be imported into WMS.  The USGS digital raster 
graphics files (DRGs) have the .tfw files and most organizations that 
distribute them include the world files as well. 

3. Many of the newer tiff files contain the registration information within 
the image file (.tif) itself.  This is referred to as a geotiff file.  When 
WMS reads a geotiff file it will bypass the registration window.  The 
image will be registered automatically. 

You can obtain TIFF images using a standard desktop scanner, by purchasing 
from a digital data provider, or from some locations on the internet (see 
http://www.emrl.byu.edu/gishydrodata/images.htm for a list of some of these 
sites).  The image used for this tutorial was obtained from a USGS digital 
raster graphics file (DRG). 

2.3.1 Importing and Registering a TIFF Image 
To import and register the TIFF image being used in this tutorial do the 
following: 

1. Select the Map module icon . 

2. Select the Import… command from the Images menu. 

3. Use the file browser to locate and open the file named “jonescyn.tif”.  
By default this file is found in the tutorial directory. 

After a few seconds of reading the file an image of a portion of USGS quad 
map will appear in the Register Image dialog as shown in Figure 2-3. 

http://www.emrl.byu.edu/gishydrodata/images.htm
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Figure 2-3 Image Registration Dialog. 

Pixel coordinates of the image must be registered to proper ground locations so 
that feature objects created by on-screen digitization will have the proper 
coordinates. 

• Set the values for the u,v and x,y pairs of each point according to the 
table below and select the OK button: 

Registration Points 
 Point 1 Point 2 Point 3 

U 0 0 715 
V 756 0 0 
X 422424 422424 426273 
Y 4519461 4515391 4515391 

The image will be resampled so that as much of the image as possible is fit 
into the Graphics window (an image will often be of a higher resolution than 
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the screen).  After a few seconds you should see the image in the Graphics 
window. 

2.3.2 Displaying and Manipulating Images 

1. Select the zoom tool . 

2. Zoom in on any portion of the image. 

3. Select the pan tool . 

4. Pan to a different portion of the image by dragging the cursor in the 
Graphics window. 

After any sequence of zooming and panning you can restore the original image 
by doing the following: 

1. Select the Fit Entire Image command from the Image menu. 

2. Select the frame macro . 

2.3.3 Using an Image to Define Feature Objects 
As mentioned previously, the TIFF image you have imported is a scanned 
image of a USGS quadrangle map.  This particular map corresponds to the 
northwest corner of Salt Lake City, Utah. 

1. Select the Create Point tool . 

2. Click on the point labeled as the beginning boundary point in Figure 
2-4. 

3. Select the Create Arc tool . 

4. Select the Attributes… command from the Feature Objects menu. 

5. Choose the Generic arc type and select the OK button. 

6. Define a single arc, which will serve as the boundary, by clicking on 
the feature point already created and then along several other points of 
the polygon shown in Figure 2-4 until you close the arc on itself by 
clicking on the first point a second time. 

7. Select the Attributes… command from the Feature Objects menu.  

8. Choose the Stream arc type and select the OK button. 
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9. Using the streams/road from the image in Figure 2-4 as a guide, enter 
the two stream branches starting from the point marked “outlet” in 
Figure 2-4.  Be sure to double-click to end the entry of a stream 
segment. 

You may need to zoom and/or pan the image in order to see features more 
clearly. 

 
Figure 2-4 Completed Feature Objects for Jones Canyon Watershed. 

If you have troubles defining the feature objects you can read in the map file 
named “jonescyn.map” to see what the final boundary and streams should look 
like. 

2.3.4 Saving a File and Deleting the Feature Objects 
If you would like to save your feature objects for later use in creating a TIN: 

1. Select Save As… from the File menu. 

2. Select Feature Object Files (*.map) from the Save as type field. 

3. Click on the directory button and specify a directory where you want 
to save your files. 

4. Enter “jones1.map” for the filename. 

5. Hit Save to exit the dialog and save the map file. 
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Now that you have saved this map file you may delete these feature objects by 
doing the following commands: 

1. Select New from the File menu. 

2. Select OK to confirm that you want to delete all data. 

2.4 Conclusion 
This concludes the Basic Feature Object Manipulation tutorial.  In this 
tutorial, you have learned some of the basic concepts behind manipulating 
feature objects and coverages.  You have also learned how to digitize feature 
objects from background images. 





 

3 Advanced Feature Object Manipulation 

CHAPTER 3 
Advanced Feature Object Manipulation 

The previous tutorial focused on some basic concepts needed for creating and 
editing feature objects.  This tutorial will focus on more advanced topics.  
First, you will learn about tools for cleaning and editing feature objects.  Then, 
you will learn how to import and use data in ArcView Shapefile and DXF 
format as feature objects in WMS.  

3.1 Cleaning and Editing Feature Objects 
Two scenarios can exist when using feature objects in WMS.  The first is that 
you have feature objects in another format that you have read into WMS.  The 
second is that you use WMS to develop your data.  In this section, you will 
first learn to import and clean existing data.  Then, you will learn some 
techniques for creating feature object data in WMS. 

3.1.1 Importing and Cleaning Feature Object Data 
This section will demonstrate various options for cleaning feature objects in 
WMS.  Options to intersect selected arcs, snap selected nodes, and remove 
dangling arcs will be discussed.  Then, the arcs will be converted to streams 
for input into a watershed model. 

Importing the Feature Object Data 
1. Select the Open… command from the File menu. 
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2. Find and Open “arco.sup”.  This file should be found in the tutorial 
directory.  It may take a few seconds for the superfile to read in. 

3. Switch to the Map module by clicking on the Map icon  at the top 
of the Toolbox. 

4. Select the Import… command from the File menu. 

5. Select Feature object arcs Shapefile (*.shp) from the Files of type 
field. 

6. Find and Open “arco.shp”. 

 HINT: In the arc attribute text window of the Import Shapefile Data 
dialog, notice that the DRAINTYPE database field is automatically 
mapped to the Drainage Arc type attribute in WMS.  This occurred 
only because the attribute name in the stream file was DRAINTYPE.  If 
the drainage type attribute name is anything other than DRAINTYPE it 
can still be assigned to the WMS Drainage Arc type variable manually 
using the Attribute mapping…button. 

7. Select OK and wait a few seconds while the stream shapefile for the 
Arco watershed is read in and displayed. 

Intersecting Selected Arcs 
There are two arcs that overlap each other in this model.  Overlapping arcs are 
not allowed in WMS, so you should intersect these arcs. 

1. Select the zoom tool  and drag a box around the location of the 
intersecting arcs.  The intersecting arcs are marked with an arrow that 
is labeled “Intersect”, as in Figure 3-1. 

2. Select the Select Arcs tool  in the toolbox. 

3. Find and use SHIFT-select to select the two intersecting arcs (See 
Figure 3-1). 
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Figure 3-1 Cleaning Intersections and Dangling Arcs. 

4. Select the Clean… command from the Feature Objects menu. 

5. Make sure the Intersect selected arcs option is selected and select the 
OK button.  The two selected arcs will be intersected and a node will 
be created at their intersection point. 

Removing Dangling Arcs 
After intersecting the overlapping arcs, a small dangling arc was created.  
Deleting a dangling arc is easy… simply select the arc and delete it. 

1. Find and select the dangling arc (See Figure 3-1). 

2. Select the Delete command from the Edit menu.  If prompted, select 
OK to delete the selected arc. 

Snapping Selected Nodes 
Occasionally, arcs or nodes on arcs that should be connected are not.  
Sometimes, these problems can be fixed by intersecting all the overlapping 
arcs and removing the dangling arcs using the automatic clean functions in 
WMS.  Other times, you need to snap a node or vertex on one arc to a node or 
vertex on another arc. 

1. Select the Frame Image macro . 
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2. Select the zoom tool  and drag a box around the location of the 
nodes that need to be snapped together.  The nodes that need to be 
snapped are marked with an arrow that is labeled “Snap”, as in Figure 
3-2.  You may have to zoom in very close to see that the nodes are not 
connected to each other. 

3. Select the Select Point/Node tool . 

4. Select the node at the end of the arc to snap (See Figure 3-2). 

 
Figure 3-2 Snapping Selected Nodes 

5. Select the Clean… command from the Feature Objects menu. 

6. Make sure the Snap selected nodes option is selected and select the 
OK button.  You will be prompted in the Help window to select a 
snapping point.  Select a vertex on the arc adjacent to the selected 
node.  The two points will be snapped together and a node will be 
created at the intersection of the arcs. 

Creating Streams from Existing Feature Objects 
Now that the arcs are cleaned, you are ready to convert your generic arcs to 
stream arcs. 

1. Select the Frame Image macro . 
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2. Select the zoom tool  and drag a box around the location of the 
downstream point.  The downstream point is marked with an arrow 
that is labeled “Downstream point”, as in Figure 3-3. 

 
Figure 3-3 Reordering Streams. 

3. Select the Select Point/Node tool . 

4. Select the downstream node (See Figure 3-3). 

5. Select the Reorder Streams command from the Feature Objects menu. 

6. Select the Frame Image macro . 

7. Select the Select Stream Network tool . 

8. Select any location on the arc network. 

9. Select the Attributes… command from the Feature Objects menu.  
Change the current feature arc type to Stream and select the OK 
button.  The stream network will be generated and linked to the 
hydrologic modeling tree. 

3.1.2 Creating Feature Objects from Images 
Sometimes, you may have existing GIS data that you have been able to read 
into WMS, but the data may not have all the attributes required for your model.  
In addition, some data may not be in a format usable by WMS.  Some data, 
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such as land use data or soil type data, must be digitized in WMS as feature 
objects before it can be put to use. 

Creating and Removing Attributes 
In this section, you will learn how to convert a vertex to a node and how to 
assign an attribute to that node.  Recall that each arc consists of two nodes and 
any number of vertices.  The vertices define the shape of the arc and the nodes 
define the arc’s endpoints.  Nodes can have attributes, but vertices cannot. 

1. Select the Select Feature Vertex tool . 

2. Use SHIFT-select to select the two vertices labeled as outlet points. 

 
Figure 3-4 Creating Outlet Points. 

3. Select the Vertex <-> Node command from the Feature Objects menu. 

4. Select the Select Point/Node tool . 

5. Use SHIFT-select to select the two nodes labeled as outlet points. 

6. Select the Attributes… command from the Feature Objects menu. 

7. Change the attributes of the selected nodes to Drainage outlet and 
select the OK button.  The newly created outlets will be linked to the 
hydrologic modeling tree. 
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Creating Soils Data from Image Data 
To compute composite curve numbers or runoff coefficients, you need a soil 
coverage defining the boundaries of each soil in your watershed.  In the Arco 
watershed model, the boundaries of each soil are defined in the image, but not 
as a coverage. 

1. Select the Coverages… command from the Feature Objects menu. 

2. Select the New button in the Coverages dialog. 

3. Change the name of the new coverage to Soil Type and change the 
coverage’s Attribute set to Soil Type. 

4. Select the OK button in the Coverages window. 

5. There are now two coverages: the drainage coverage and the soils 
coverage.  Your next task will be to create arcs and polygons defining 

the soils coverage.  Select the Create Feature Arc tool . 

6. Create a rectangular boundary around your entire model by selecting 
one corner.  Then select each of the remaining corners and create a 
single closed arc around your entire model, as shown in Figure 3-5. 

 
Figure 3-5 Step 1—Create a Single Arc around the Entire Window. 
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7. The pink lines in the image represent soil type boundaries.  Select a 
point on the rectangular boundary that intersects with one of the pink 
lines and create an arc along the pink line until another boundary line 
is reached. 

 HINT: If you click close to an existing arc when creating an arc, the 
arc you are creating will automatically snap to that existing arc.  All 
the arcs you create in a soil type coverage must be connected to each 
other and form closed polygons.  If closed polygons are not created, 
WMS will not be able to determine the type of soil for each point in 
your watershed model. 

8. Create arcs from the other soil boundary lines, as shown in Figure 3-6.  
Be sure all the soil arcs form closed polygons.  You don’t have to be 
too accurate when creating the soil boundary arcs.  If you are creating 
a real model, of course, you should try to be more accurate. 

 
Figure 3-6 Step 2—Create Arcs Along the Soil Type Boundaries. 

3.1.3 Building Polygons 
Now that you have defined the boundaries for the soils in your coverage, you 
are ready to build polygons and assign soil attributes to each polygon.  
Polygons must be built to assign soil types to areas in the soil coverage. 

1. Select the Build Polygon command from the Feature Objects menu. 
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2. When prompted if you want to use all arcs to build the polygons, 
select OK to build the polygons.  If you built the soil arcs correctly, 
polygons will be generated from your soil arcs. 

3. Select the Select Polygon tool .  This tool must be selected to 
access the polygon attributes for the land use coverage. 

4. Notice that the type of each soil is written on the background image.  
Use SHIFT-select to select all the soil type A polygons and select the 
Attributes… command from the Feature Objects menu. 

5. Note in the Soil type mapping dialog (Figure 3-7) that SCS soil type A 
is the default soil type when a soil polygon is created.  Select the 
Apply button to assign this default value to all the selected polygons. 

 
Figure 3-7 The Soil Type Mapping Dialog. 

6. Perform steps 4 and 5 for soil types B, and C.  For soil type B, you will 
need to select “Add soil ID to list”, select the Soil Type soil property, 
and change the SCS soil ID to Type B.  For soil type C, you will need 
to select “Add soil ID to list”, select the Soil Type soil property, and 
change the SCS soil ID to Type C. 

7. Select the Display Options… command from the Display menu. 
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8. Toggle the Color fill polygons option on and select the OK button. 

9. Select the New command from the File menu. 

10. Select OK to confirm that you want to delete all data. 

3.2 Importing Feature Objects from Arc/Info (ArcView) Shape 
Files 

You have now learned how to create watershed boundaries and streams in the 
map module from digital image data and digital elevation data.  What if you 
already have watershed boundaries, streams, or both in a Geographic 
Information System (GIS) and you want to read this data into WMS?  Or what 
if you have soil type and land use information stored in a GIS? 

WMS provides tools to import and export ArcView GIS shapefiles.  Some 
basic functions of these tools will be discussed in this section.  For more 
information on where you can download these data see: 
www.emrl.byu.edu/gishydrodata. 

3.2.1 Reading a WMS Map Drainage File 
First, you will read in a map file containing basins and streams in the Aspen 
Grove, Utah watershed. 

1. Select the Open… command from the File menu. 

2. Find and Open “aspencn.map,” a map drainage file of a watershed 
containing streams, basin boundaries, and outlet points. 

3.2.2 Importing a Soil Type Shape File 
In this section, you will perform the next step in computing a composite curve 
number—importing a soil type shapefile. 

1. Select the Import… command from the File menu. 

2. Select Feature object polygons Shapefile (*.shp) from the Files of type 
field.  

3. Find and Open “aspenso.shp”. 

4. In the polygon attribute text window (see Figure 3-8), notice that the 
HYDGRP database field is automatically mapped to the SCS soil type 
attribute in WMS.  This occurred only because the attribute name in 
the soil type file was HYDGRP.  If the attribute name is anything other 

http://www.emrl.byu.edu/gishydrodata
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than HYDGRP it can still be assigned to the WMS SCS soil type 
variable manually using the Attribute mapping…button. 

 HINT: It is extremely important that you create a new soil type 
coverage when importing a soil type shapefile or any other type of 
attribute shapefile.  After creating the new coverage, you must specify 
the coverage attribute type as explained below. 

5. Select the Coverage options… button in the Import Shapefile Data 
dialog. 

6. Select the New button in the Coverages window. 

7. Change the name of the coverage to Soil Type and change the 
coverage’s Attribute set to Soil Type. 

8. Select the OK button in the Coverages window. 

 
Figure 3-8 The Import Shapefile Dialog. 

9. Select OK and wait a few seconds while the soil type shapefile for the 
Aspen Grove watershed is read in and displayed. 
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3.2.3 Importing a Land Use Shape File 
After importing or creating your watershed model, you can import other GIS 
data to compute hydrologic parameters such as curve numbers or runoff 
coefficients.  To compute a curve number, for example, you need land use and 
soil type coverages.  You will now import a land use shapefile. 

1. Select the Import… command from the File menu. 

2. Select Feature object polygons Shapefile (*.shp) from the Files of type 
field. 

3. Find and Open “aspenlu.shp”. 

4. In the polygon attribute text window, notice that the LU_CODE 
database field is automatically mapped to the Land use attribute in 
WMS.  This occurred only because the attribute name in the land use 
file was LU_CODE.  If the attribute name is anything other than 
LU_CODE it can still be assigned to the WMS Land Use variable 
manually using the Attribute mapping…button. 

 HINT: It is extremely important that you create a new land use 
coverage when importing a land use shapefile or any other type of 
attribute shapefile.  After creating the new coverage, you must specify 
the coverage attribute type as explained below. 

5. Select the Coverage options… button in the Import Shapefile Data 
dialog. 

6. Select the New button in the Coverages window. 

7. Change the name of the coverage to Land Use and change the 
coverage’s Attribute set to Land Use. 

8. Select the OK button in the Coverages window. 

9. Select OK and wait a few seconds while the land use shapefile for the 
Aspen Grove watershed is read in and displayed. 

3.2.4 Assigning Attributes to Feature Objects 
When reading in your land use and soil type shapefiles, an ID is read in for 
each land use and soil type polygon.  However, you still need to be able to 
compute a curve number for each basin in the Aspen Grove watershed.  But 
how do you relate the soil type ID and land use ID in each of these polygons to 
a curve number? 

WMS stores a separate table for each land use ID.  This table relates each land 
use ID to a land use name, a curve number for each SCS soil type (A, B, C, 
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and D), and other land use properties.  When WMS computes the curve number 
for each basin, it determines the soil type and land use for several locations in 
the sub-basin.  WMS then determines the curve number for each of these 
locations using the land use table.  Fortunately, WMS provides an easy method 
of setting up this land use table in the land use polygon attributes dialog. 

In this section, you will learn how to set up a land use table using the land use 
polygon attributes dialog. 

1. Switch to the Map module by clicking on the Map icon  at the top 
of the Toolbox. 

2. In the Coverage box in the Edit Window, make sure the “Land Use” 
coverage is the active coverage. 

3. Select the Display Options… command from the Display menu. 

4. Toggle the Land Use Legend option on and select the OK button to 
close the Display Options dialog.  Notice that a land use legend 
appears on your Graphics window (see Figure 3-9).  Three land use 
ID’s are shown on the legend.  You must assign data to each of these 
land use ID’s. 

 
Figure 3-9 The Land Use Polygon Attributes (Land Use Mapping) Dialog. 

5. Select the Select Polygon tool .  This tool must be selected to 
access the polygon attributes for the land use coverage. 
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6. Select the Attributes… command from the Feature Objects menu. 

7. In the Land use mapping dialog window, select Land ID 32 from the 
WMS landuse ID window.  In the Selected land use properties 
window, select the Land name row and change the name of the land 
use to “Shrub and Brush Rangeland”, as in Figure 3-9. 

8. In the Selected land use properties window, select the SCS Soil type A 
CN row and change the Type A CN Value to 49.  Select the SCS Soil 
type B CN row and change the Type B CN Value to 69. Select the SCS 
Soil type C CN row and change the Type C CN Value to 79. Select the 
SCS Soil type D CN row and change the Type D CN Value to 84. 

9. Repeat steps 8 and 9 for soil types 41 and 42 with the following Curve 
number and name values:  

 Property  Land use ID 41  Land use ID 42 
 Name  Deciduous Forest Land  Evergreen Forest Land 

 Type A CN  45  36 

 Type B CN  66  60 

 Type C CN  77  73 

 Type D CN  83  79 

10. In the Export file type field, select the option to export an SCS Land 
use file.  Select the Export SCS file button, go to the directory where 
you want to save the land use file, and call the SCS land use file 
“aspencn.tbl”.  After exporting, this file can be used later without 
having to set it up again. 

11. Select the Close button to close the Land use mapping dialog. 

12. In the Coverage box in the Edit Window, make sure the “Drainage” 
coverage is the active coverage. 

13. Switch to the Tree module by clicking on the Hydrologic Modeling 

module icon  at the top of the Toolbox. 

14. Select the Compute GIS Attributes… command from the Calculators 
menu. 

15. Select SCS Curve numbers for the Computation type and select the OK 
button to compute the composite Curve numbers for each basin.  WMS 
will take a few seconds while the curve numbers for each basin are 
computed.  If you want to display the curve numbers for each sub-
basin, you can turn them by selecting the Display Options… command 
from the Display menu and then selecting the Drainage tab and 
marking the Basin CN’s (curve numbers) toggle box. 



 Advanced Feature Object Manipulation 3-15 

16. Switch to the Map module by clicking on the Map icon  at the top 
of the Toolbox. 

17. In the Coverage box in the Edit Window, select the “Land Use” 
coverage to make it active. 

18. Select the Display Options… command from the Display menu. 

19. Under the Map tab, toggle the Land Use Legend option off and select 
the OK button to close the Display Options dialog. Delete all your data 
by selecting the New option from the File menu.  Select OK to delete 
all your data. 

3.3 Creating Feature Objects from DXF Data 
DXF data files can be imported and used in WMS for creating streams or other 
feature object data in two different ways: 1) direct conversion, or 2) using 
them as a background map.  DXF files from any application can be used, but 
must be in R-12 format.  See the user manual for help in converting to R-12 
format if you have problems reading a particular DXF file. 

3.3.1 Creating a Boundary Polygon 
Although the DXF file can contain data for the boundary of the watershed, the 
file that you will import contains data for the stream.  The boundary that will 
be used in this portion of the tutorial will be read from an existing map file 
(“.map”).  To read the file: 

1. Select Open… from the File menu. 

2. Using the file browser, find and Open “aspenbnd.map.” 

3. Select YES if prompted to delete the current feature objects. 

3.3.2 Importing a DXF File 
To import the DXF file: 

1. Select Import… from the DXF menu. 

2. Find and Open the file named “aspen.dxf.” 

The file will be imported and then displayed in the main window.  The next 
two sections illustrate the two different ways DXF data can be used to create 
feature objects. 
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3.3.3 Digitizing Feature Objects From DXF Data 
The first way DXF data can be used to create feature objects is by simply 
digitizing new arcs/polygons over the top of the existing data. 

1. Select the Create Arc tool .m 

2. Select the Attributes… command from the Feature Objects menu. 

3. Change the arc attribute type to Stream and select OK. 

4. Create the arc along the main stream by clicking on the outlet point 
(lower right) and then clicking on additional points along the DXF 
stream data.  Be sure to click (create a vertex) at locations along the 
main stream at branching locations. 

5. Finish the stream arc by double clicking on the last point. 

Repeat steps 4 and 5 for each of the stream branches.  If you missed placing a 
vertex at one of the stream branches you can: 

1. Select the Create Feature Vertex tool . 

2. Click on any locations along the stream arc where the stream branches. 

3. Select the Create Feature Arc tool . 

If you wish to save the completed feature objects to a map file you may do so, 
but you must delete the feature objects before proceeding to the next section. 

1. Select the Delete command from the Feature Objects menu. 

2. Select OK to confirm that you want to delete the feature objects. 

3.3.4 Converting DXF Data to Feature Objects 
A more direct approach, especially for large data files, is to convert the DXF 
data to Feature Objects.  This is done using the following steps: 

1. Select the DXF->Feature Objects command from the DXF menu.  

2. Turn on the toggle to Create feature arcs from DXF lines and turn off 
the toggle to Create feature points from DXF points (nodes for arcs 
will automatically be placed at the beginning and ending locations of 
the DXF lines). 

3. Select the option to Add to currently active coverage. 
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4. Select OK. 

Since the DXF line segments may not be ordered properly for stream arcs 
(connected from downstream to upstream) they are defined as generic arcs.  
You must now reorder the arcs for streams, and then convert them to stream 
type. 

1. Select the Select Points/Nodes tool . 

2. Select the downstream most point in the lower right of the main 
window. 

3. Select the Reorder Streams command from the Feature Objects menu. 

4. Select the Select Network tool . 

5. Select any one of the stream arcs. 

6. Select the Attributes… command from the Feature Objects menu. 

7. Choose the stream type option and select OK. 

3.3.5 Saving the Feature Objects to a Map File 
Now that you have created feature objects you can save them to a map file if 
you want to use them later. 

1. Select Save As… from the File menu. 

2. Select Feature Object Files (*.map) from the Save as type field. 

3. Specify the directory where you want to save your files. 

4. Enter “aspen3.map” for the filename. 

5. Select Save to exit the dialog and save the map file. 

6. Select the New command from the File menu. 

7. Select OK to confirm that you want all data deleted. 

3.4 Conclusion 
This concludes the Advanced Feature Object Manipulation tutorial.  In this 
tutorial, you have learned about some of the tools in WMS for cleaning and 
editing feature objects.  You have also learned how to assign some attributes to 
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feature objects.  Finally you have learned how to import and use data in 
ArcView Shapefile and DXF format as feature objects in WMS. 



 

4 Hydrologic Models from Feature Objects 

CHAPTER 4 
Hydrologic Models from Feature 
Objects 

This tutorial demonstrates how feature objects alone can be used to define 
hydrologic models.  Feature objects may be digitized on-screen using a 
registered image, or imported as a shape file from an Arc/Info or ArcView 
layer.  Using the drainage coverage type, features can be converted to streams, 
outlets, and basins to represent the watershed being modeled.  If GIS layers are 
imported as shape files, their corresponding attributes (i.e. area, curve number, 
time of concentration, etc.) are also imported and assigned to the appropriate 
basins. 

4.1 Launching WMS 
To launch the PC version of WMS: 

 Double click on the WMS icon . 

To launch the Unix version of WMS: 

1. Bring up an xterm window. 

2. Change to the directory containing the WMS executable or make sure 
the directory containing WMS is in your Unix path environment. 

3. Type wms at the command line. 
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4.2 Creating a Watershed from Scratch with Feature Objects 
By using a combination of stream arcs, outlet nodes, and basin polygons, you 
can develop an entire watershed even without the use of a digital terrain 
model.  The watershed can be to scale or a schematic.  Of course, if it were not 
to scale, polygon areas and stream lengths would not be valid for your 
hydrologic model. 

In this section of the tutorial you will create the aspen grove watershed from an 
image of a scanned paper map with clearly marked streams and basin 
boundaries. 

1. Select the Map module icon . 

2. Select the Open… command from the File menu. 

3. Find and Open the file named “aspentrc.img”.  This file should be 
found in the tutorial directory.   

You should see a portion of a USGS quad map with basin boundaries outlined 
in red and the stream network in black. 

4.2.1 Creating Basin Boundaries 
We will begin by creating the basin boundaries, but it does not matter whether 
the basins or streams are created first. 

1. Select the Create Arcs tool . 

2. Select the Attributes… command from the Feature Objects menu. 

3. Make sure that the arc type is Generic and select OK. 

4. Beginning at the outlet point (lower right) trace out the entire 
watershed boundary.  You do not need to follow every detail, take as 
much time as you want.  End by double-clicking near the same point 
where you began. 

Note: Whenever you create feature arcs in WMS a snapping tolerance is used 
to snap the new vertex to an existing node, vertex or arc.  Therefore, you do 
not have to click “exactly” on the same point when ending.  For the most part 
this is very useful because it avoids the necessity of creating vertices at all arc 
intersection/branching points the first time it is encountered (i.e. at a stream 
branching point, or where sub-basin boundaries join). 

1. Now create each of the other three sub-basin boundary arcs on the 
interior of the watershed.  Begin by clicking on a point near the 
junction in the center of the watershed and ending by double-clicking 
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near the intersection of the arc previously created for the exterior 
boundary. 

4.2.2 Creating the Stream Network 
The stream network is created in much the same way the basin boundaries 
were.  The only thing to note is that the upper basin the basin boundary comes 
very close to the stream.  You will need to zoom in on this region in order to 
avoid conflicts with the snapping tolerance. 

1. Select the Attributes… command from the Feature Objects menu. 

2. Choose the Stream feature arc type. 

3. Select OK. 

4. Create the main channel from the outlet of the watershed to the outlet 
point for the two upper basins.  Begin by clicking near enough to the 
boundary arc at the outlet so that it snaps to it and end by double- 
clicking on the basin junction point. 

5. Create the two branches of the lower basin by clicking on a point near 
the stream arc just created and double-clicking at the most upstream 
point of the branches in the image. 

NOTE: As you create new vertices on stream arcs you should always do so 
from downstream to upstream. 

1. Select the Zoom tool . 

2. Zoom in on the region shown in Figure 4-1. 

 
Figure 4-1 Junction of Main Channel in Aspen Grove Watershed. 
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3. Select the Create Arcs tool . 

4. Create the initial portion of each portion of the stream by clicking on 
the junction point (intersection of red boundary lines in the image) and 
going as far upstream as is possible on the zoomed image.  End by 
double-clicking. 

You needed to zoom in order to avoid conflicts with the auto-snapping feature.  
If you do click too close to an existing arc you will get a message that the 
stream is illegal and you will need to try again. 

You can end the stream at one location and then continue defining after 
zooming out by beginning at the point where you left off. 

1. Select the View Last command from the View menu. 

2. Finish defining each branch.  Begin the branch by clicking near the 
point you left off with and ending by double clicking at the terminal 
point of the stream. 

In order to define separate basins at the junction point you will need to convert 
the node at the junction to an outlet node. 

1. Select the Select Feature Point/Node tool . 

2. Select the junction point in the center of the watershed corresponding 
to the intersection of the streams and the sub-basin boundary arcs that 
you just created. 

3. Select the Attributes command from the Feature Objects menu. 

4. Change the attribute to Drainage outlet. 

5. Select OK. 

4.2.3 Building Polygons 
At this point the watershed boundaries are only arcs.  In order for them to 
become polygons you must create the polygon topology. 

1. Select the Select Polygon tool . 

2. Select the Attributes… command from the Feature Objects menu. 

3. Change the attribute to Drainage boundary.  Select the OK button. 

4. Select the Select Arcs tool . 
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5. Select the Select All command from the Edit menu. 

6. Select the Select Network tool . 

7. While holding down the SHIFT key, select any one of the stream arcs.  
This should un-select the stream arcs and leave the remainder selected 
for use in polygon generation. 

8. Select the Build Polygon command from the Feature Objects menu. 

4.2.4 Updating Geometric Parameters 
1. Select Display Options… from the Display menu. 

2. Turn on the Color fill polygons option. 

3. Select OK. 

In order to transfer the basin area and stream lengths, and to compute them in 
appropriate units for hydrologic modeling you need to compute the basin data.  
This will make it possible to use the polygon area in any of the hydrologic 
modeling interfaces. 

1. Select the Compute Basin Data… command from the Feature Objects 
menu.  This command computes areas, perimeters, and centroids for 
each of the sub-basins and assigns these values to the hydrologic 
modeling tree. 

2. Set the Model units to Meters (the base units were UTM meters). 

3. Set the Basin Areas units to Square miles. 

4. Set the Distances units to Feet. 

5. Select the OK button to compute the sub-basin data. 

4.3 Importing GIS Data to Create a Watershed 
Many times stream networks and/or basin boundaries already exist as layers in 
a GIS.  In such cases the data can be imported from a shape file (ArcView’s 
native file format), and all applicable attributes inherited by the WMS feature 
objects for hydrologic modeling.  If you have an ARC/INFO coverage you will 
need to convert it to a shape file first using the ARCSHAPE command.  You 
will also want to pay attention to the keywords used for automatically mapping 
attributes, and some of the issues associated with importing GIS data as 
explained in Chapter 4 of the WMS Reference manual. 
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This part of the tutorial shows how GIS data developed with the end goal of 
importing into WMS can be used.  The next three sections in the tutorial 
discuss how any watershed data layer(s) can be imported and then modified for 
use within WMS. 

In order for WMS to be able to import GIS layers and automatically create a 
watershed for use in a hydrologic model, the following conditions must exist. 

• You must have a polygon layer representing basin polygons with an 
attribute item named draintype, and the draintype value for each basin 
polygon needs to be 1. 

• You must have an arc layer representing streams with an attribute item 
named draintype, and for each stream arc the value of draintype should 
be 3.  Also the arcs must be ordered so that the from-node is always 
downstream of the to-node (if this is not the case it may be easier to 
follow the guidelines shown in the next section). 

• You must have a point layer representing outlets with an attribute item 
named draintype, and for each outlet point the draintype should be 5. 

A special extension in ArcView, called WMSHydro, has been developed which 
automatically creates these three layers.  If you are not using this extension it 
may be more trouble to develop these three layers in the required format than it 
is to import them in one of the ways described in sections 4.4-4.6. 

In addition to the required attributes, the shape file may also contain other 
hydrologic modeling parameters that can be mapped to corresponding values 
in WMS.  Table 2.1 in the reference manual lists the attributes that can be 
mapped and the keywords used by WMS to automatically define the mapping.  
If your shape file contains the correct parameter, but does not use the specified 
keyword, you can still manually specify the mapping. 

4.3.1 Importing Shape Files 
1. Select the New command from the File menu to make sure that all 

existing data is removed. 

2. Select OK to delete everything. 

3. Select the Map module icon  if it isn’t active already. 

4. Select the Import… command from the File menu. 

5. Select Feature object polygons Shapefile (*.shp) from the Files of type 
field. 

6. Find and Open the polygon shape file named “asppoly1.shp”. 
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You should now see the Import Shapefile Data dialog.  It allows you to define 
the shape files and mappings for points, arcs, and polygons.  You can also 
access the coverage options dialog in case you need to change coverage types, 
create a new coverage, etc. 

1. Click on the open points shape file button. 

2. Find and Open the point shape file named “asppnts1.shp”. 

3. Click on the open arcs shape file button. 

4. Find and Open the arc shape file named “asparcs1.shp”. 

Attribute items are automatically mapped to WMS parameters if they have the 
appropriate keywords.  Mappings are shown in the text window to the right of 
the shape file name.  If an attribute name doesn’t match a keyword as listed in 
Table 3.1 of the reference manual you can manually map it by doing the 
following: 

1. Select the Attribute Mapping… button below the polygon shape file. 

2. Select AREA in the Database fields window. 

3. Select Basin area in the Coverage attributes window (you may have to 
use the scroll bar to find Basin area). 

4. Select the Map button.  If you want, scroll the Mapped fields window 
so that you can see that the area mapping has been added.  An attribute 
could be similarly unmapped by selecting it in the Mapped fields 
window and selecting the Unmap button. 

5. Select the Done button. 

6. Select OK to close the Import Shapefile Data dialog. 

Your watershed data will be read in and all parameters that were mapped will 
be set inside of WMS.  If you are running a licensed version of WMS you could 
very easily run an HEC-1 model as outlined in the next section.  If you are 
running a demonstration version skip to section 4.4. 

4.3.2 Running HEC-1 with Data Defined in a GIS 
Since many of the required parameters to run the SCS options within HEC-1 
were included in the shape files just imported, you can very quickly get to the 
point where you can run HEC-1 (this assumes of course that at some point 
these parameters were correctly computed and stored in the GIS).  In order to 
complete the HEC-1 model definition, do the following. 

1. Select the Hydrologic Modeling icon . 
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2. Select Job Control… from the HEC-1 menu. 

3. Change the Computational time interval to 5 (minutes). 

4. Change the Number of hydrograph ordinates to 50. 

5. Select OK. 

You have specified your simulation to last for 5 times 50 minutes or 4 hours 10 
minutes. 

1. Select the basin named 3B in the Graphics window. 

2. Select Edit HEC-1 Parameters… from the HEC-1 menu. 

3. Select the Precipitation button. 

4. Choose the Basin average option. 

5. Select the Define Series button. 

6. Select the Import… button. 

7. Select and Open the file “scstabls.ser”. 

8. Make sure that the SCS-StdEmergencySpillway is highlighted. 

9. Select OK twice to close the XY Series Editor and HEC-1 
Precipitation dialogs. 

10. Select basin 1B from the Hydrologic Modeling window. 

11. Repeat steps 3-9 for basin 1B - be sure that you highlight the SCS-
StdEmergencySpillway option in the XY Series Editor, as it will not be 
the default. 

12. Repeat for basin 2B. 

13. After defining precipitation for all three basins select the Done button 
on the Edit HEC-1 Parameters dialog. 

You are now ready to run HEC-1 and review the results. 

1. Select Run HEC-1… from the HEC-1 menu. 

2. If you want to change the names of the files you can do so, but keeping 
the files named untitled is okay. 

3. Select a directory where you can save your HEC-1 files using the 
directory browser button. 
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4. Select OK. 

5. After HEC-1 completes the simulation it will ask if you want to exit 
window, select YES. 

6. WMS will automatically open the files that you created with the HEC-
1 program. 

If you wish to examine the hydrographs in more detail: 

1. Select Show Hydrograph Window from the Display menu. 

2. Select any of the hydrograph icons in the Hydrologic Modeling 
window. 

This completes the tutorial on using “ideal” GIS data to define hydrologic 
models.  More often than not you will have one or more of the three required 
layers, and your data will need to be modified a bit after you read it in.  The 
next three sections demonstrate some of the kinds of problems you might run 
into and what you can do about them. 

4.4 Creating a Watershed with a GIS Stream and Basin Layers 
In this section you will learn how to create the same watershed model done in 
the last two sections when you lack a point file defining outlets and/or the data 
does not meet the requirements for automatic creation as outlined at the 
beginning of section 4.3. 

If you are continuing from the previous section you will want to delete your 
data before going on. 

1. Select the New command from the File menu. 

2. Select OK to confirm that you want to delete everything. 

3. Select the Map module icon . 

4.4.1 Importing the Basin and Stream Layer 
1. Select the Import… command from the File menu. 

2. Select Feature object polygons Shapefile (*.shp) from the Files of type 
field. 

3. Find and Open the polygon shape file named “asppoly2.shp”. 

4. In the Import Shapefile Data dialog, click on the open arcs shape file 
button. 
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5. Find and Open the arc shape file named “asparcs2.shp”. 

6. Select OK to close the Import Shapefile Data dialog. 

The data looks almost exactly like the shape files of the previous section.  
With a closer look though you will notice the following differences: 

• The streams are not colored blue and the basin boundaries are not 
colored brown because the “Draintype” field is not present for these 
shape files.  You may wish to turn off the color-filled option for 
polygons using the Display Options… command from the Display 
menu. 

• The watershed outlet and stream branching points do not connect to 
the basin boundaries. 

4.4.2 Converting Generic Arcs to Stream Arcs 
The first task will be to convert the existing set of “generic” streams to stream 
arcs. 

1. Select the Zoom tool . 

2. Zoom in around the watershed outlet (lower right). 

3. Select the Select Points/Nodes tool . 

4. Select the last node (the outlet point) on the stream network. 

5. Select the Reorder Stream command from the Feature Objects menu. 

This will insure that the arcs connected to the selected point will be ordered 
from downstream to upstream (from-node at the downstream end and to-node 
at the upstream end).  This MUST be done before the stream arcs can be 
assigned a stream attribute type. 

1. Select the Stream Network tool . 

2. Select an arc on the stream network (this will actually select all arcs 
connected to this network). 

3. Select the Attributes… command from the Feature Objects menu. 

4. Choose the Stream attribute type. 

5. Select OK. 

Now you need to “snap” the stream outlet point to a point on the boundary of 
the watershed polygon. 
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1. Select the Select Points/Nodes tool . 

2. Select the downstream most point on the stream network. 

3. Select the Clean… command from the Feature Objects menu. 

4. Make sure only the Snap selected nodes option is on. 

5. Select OK. 

6. You will now be prompted to select in the Help window a point to 
snap to.  Click on a point on the polygon near the stream outlet point. 

7. Select the Frame Image macro . 

8. Select the Zoom tool . 

9. Zoom in around the outlet point at the junction of the streams from the 
two upper basins. 

If you have zoomed in around the right location your display should look 
something like Figure 4-2.  You will notice that the outlet point does not 
coincide with the intersection of the three basins.  You will now need to snap it 
in the same way you did for the watershed outlet. 

 
Figure 4-2 Snapping Nodes Together. 

1. Select the Select Points/Nodes tool . 

2. Select the outlet junction point on the stream network. 
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3. Select the Clean… command from the Feature Objects menu. 

4. Make sure only the Snap selected nodes option is on. 

5. Select OK. 

6. Click on a point on the basin intersection point. 

7. Select the newly snapped node (the intersection of the basins and 
stream network). 

8. Select the Attributes… command from the Feature Objects menu. 

9. Choose the Drainage outlet option. 

10. Select OK. 

11. Select the Frame Image macro . 

4.4.3 Converting Generic Polygons to Basin Boundary Polygons 
In order to “tie” the polygons to the topologic tree you must change them from 
Generic to Drainage boundary. 

1. Select the Select Polygon tool . 

2. While holding the left mouse button down, drag a box around all three 
polygons (you could also multi-select the polygons by clicking inside 
each while holding down the SHIFT key or by using the Select All 
command from the Edit menu). 

3. Select the Attributes… command from the Feature Objects menu. 

4. Choose the Drainage boundary option. 

5. Select OK. 

6. Select the Compute Basin Data command from the Feature Objects 
menu.   

7. Choose Meters for Model units and select OK. 

This will insure that the units for polygon area and arc length are 
converted/stored for hydrologic modeling. 

You have now converted your stream and polygon shape file to a watershed 
model that is ready for use with any of the hydrologic model interfaces.  
Notice how if you select a single basin icon, the corresponding polygon is  also 
highlighted. 
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4.5 Creating a Watershed with a GIS Basin Layer 
In this section, using the same watershed boundary data as the previous 
section, you will learn how to create a watershed model if you only have a GIS 
layer for basin boundaries.  In such cases you will need to create the stream 
network within WMS.  The stream network does not have to correspond to the 
actual network, but is primarily used to determine how flow is combined and 
routed from the different basins.  If you have a scanned map, or other source of 
stream data you can create the actual stream, but it is not required.  However, 
keep in mind that unless you create streams that represent the actual channel, 
stream length information will be incorrect. 

If you are continuing from the previous section you will want to delete your 
data before going on. 

1. Select the New command from the File menu. 

2. Select OK to confirm that you want to delete everything. 

3. Select the Map module icon . 

4.5.1 Importing the Basin Layer 
1. Select the Import… command from the File menu. 

2. Select Feature object polygons Shapefile (*.shp) from the Files of type 
field. 

3. Find and Open the polygon shape file named “asppoly2.shp”. 

7. Select OK to close the Import Shapefile Data dialog. 

You should now have the basin file read in with three different sub-basins.  
There is no stream network associated with these basins and so you must 
define it. 

4.5.2 Creating a Stream Network 

1. Select the Zoom tool . 

2. Zoom in around the intersection of the three sub-basins near the center 
of the watershed. 

3. Select the Create Arcs tool . 

4. Select the Attributes… command from the Feature Objects menu. 

5. Choose the Stream attribute type. 
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6. Select OK. 

Use Figure 4-3 as a guide in the next few steps. 

1. Click on the intersection point of the polygons to begin a new stream 
segment. 

2. Double-click on an interior point of the upper-left basin. 

3. Repeat the last two steps for the upper-right basin. 

4. For the lower basin reverse the two steps by first clicking on an 
interior point and then double-clicking on the intersection point. 

 
Figure 4-3 Creating Streams for Basin Polygons. 

1. Select the Frame Image macro . 

2. Click on a location on the boundary of the basin polygons near the 
watershed outlet (lower right portion of the screen), and then double-
click on the stream point you just created in the middle of the lower 
sub-basin.  See Figure 4-4 as a guide. 

 
Figure 4-4 Finishing the Stream. 
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Now you will want to eliminate the outlet point in the interior of the lower 
basin polygon. 

1. Select the Select Point/Node tool . 

2. Select the node on the stream arc where you just double-clicked to join 
the outlet to the stream network. 

3. Select the Vertex<->Node command in the Feature Objects menu. 

4.5.3 Converting Polygons to Basins 
In order to “tie” the polygons to the topologic tree you must change them from 
generic to Drainage boundary. 

1. Select the Select Polygon tool . 

2. While holding the left mouse button down, drag a box around all three 
polygons (you could also multi-select the polygons by clicking inside 
each while holding down the SHIFT key or by using the Select All 
command from the Edit menu). 

3. Select the Attributes… command from the Feature Objects menu. 

4. Choose the Drainage boundary option. 

5. Select OK. 

6. Select the Compute Basin Data… command from the Feature Objects 
menu. 

7. Choose Meters for Model units and select OK. 

This will insure that the units for polygon area and arc length are 
converted/stored for hydrologic modeling. 

4.6 Creating a Watershed with a GIS Stream Layer 
In this section, using the same stream data as section 4.4, you will learn how to 
create a watershed model if you only have a GIS layer for streams.  In such 
cases you will need to create within WMS the basin boundaries.  The boundary 
polygons do not have to correspond to the actual watershed/sub-basin 
boundaries, but they are primarily used to identify the watershed and sub-
basins of a watershed model.  If you have a scanned map, or other source of 
drainage boundary data you can create the actual basin polygons, but it is not 
required.  However, keep in mind that unless you create polygons that 
represent the actual basin boundaries, polygon (basin) areas will be incorrect. 
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If you are continuing from the previous section you will want to delete your 
data before going on. 

1. Select the New command from the File menu. 

2. Select OK to confirm that you want to delete everything. 

3. Select the Map module icon . 

4.6.1 Importing the Stream Layer 
1. Select the Import… command from the File menu. 

2. Select Feature object arcs Shapefile (*.shp) from the Files of type 
field. 

3. Find and Open the arc shape file named “asparcs1.shp”. 

8. Select OK to close the Import Shapefile Data dialog. 

You should now have the stream file.  There are no basin polygons associated 
with the stream this network and so you must define them. 

4.6.2 Creating Basin Polygons 
Figure 4-5 is an example of basins created for the imported stream layer.  
Refer to it as you create your own basin polygons.  In particular you will want 
to note the point on the stream where the three sub-basins intersect. 

 
Figure 4-5 Sub-basins of Stream Network. 
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1. Select the Select Point/Node tool . 

2. Double click on the node at the intersection point shown in Figure 4-5. 

3. Set the attribute type to Drainage Outlet and select OK. 

4. Select the Create Arcs tool . 

5. Select the Attributes… command from the Feature Objects menu. 

6. Select the Generic option. 

7. Select OK. 

8. Select the Zoom tool . 

9. Zoom in around the point on the stream where you will create the 
intersection of the three sub-basins (see Figure 4-5). 

10. Select the Create Arcs tool . 

11. Create the three arcs shown in Figure 4-6 that will define the 
boundaries of the three basins at the intersection point.  For each arc 
begin by clicking on the intersection point in the stream and end by 
double-clicking. 

 
Figure 4-6 Interior Boundary Arcs. 

1. Select the Frame Image macro . 
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2. Now finish defining the arcs to close the three basin boundaries by 
starting from the end point(s) of the three arcs at the intersection and 
continue tracing out the boundaries shown in Figure Figure 4-5. 

At this point you have all the necessary arcs to define the basin polygons, but 
you need to convert them to polygons. 

1. Select the Select Network tool . 

2. Select any of the arcs that will be used for the basin boundaries (this 
should cause all of the basin boundary arcs to become selected). 

3. Select the Build Polygons command from the Feature Objects menu. 

4. Select the Select Polygons tool . 

5. Select all the polygons by dragging a box around them, or selecting 
each while holding down the SHIFT key. 

6. Select the Attributes… command from the Feature Objects menu. 

7. Make sure that Drainage boundary is chosen as the polygon type (if 
you are continuing from another part of the tutorial the polygons are 
likely already set to Drainage boundary, but in many cases they will 
by default be Generic and you will need to change them). 

8. Select OK. 

You now have defined basins for each part of the watershed.  The boundaries 
are not actual boundaries, but rather an approximation.  Still, the hydrologic 
modeling tree can now be used to finish defining input for the watershed 
model. 

Practically speaking, the only time you will want to define a watershed model 
in this fashion is if you already know areas for the sub-basin boundaries. 

4.7 Conclusions 
In this tutorial you have learned how to create watershed models using the map 
module objects.  In particular, you have learned how to import shape files 
representing streams and boundaries and use them for setting up a watershed 
model. 

 



 

5 DEM Basics 

CHAPTER 5 
DEM Basics 

Estimated Time: 15 minutes 

A DEM (Digital Elevation Model) is a file containing x, y, and elevation data 
(in UTM coordinates) for a portion of the earth's surface.  While DEM data 
can be obtained from the USGS, it is often supplied by state, county or other 
local agencies involved in GIS work.  For a listing of web sites where DEMs 
can be obtained see www.emrl.byu.edu/gishydrodata/dem.htm.  WMS can use 
DEMs to directly delineate watersheds, or as background elevation maps when 
constructing TINs. 

In this tutorial you will learn about WMS's DEM importing and visualization 
tools.  After you have completed this tutorial you should be able to: 

• Import DEMs into WMS. 

• Smooth elevations to eliminate round-off error. 

• Use WMS's three-dimensional viewing tools to visualize DEMs. 

• Use WMS's elevation contouring options. 

• Display a hill shade of the DEM. 

5.1 Importing a USGS DEM 
The process of importing a USGS DEM can be subdivided into three steps. 

• Opening the DEM file. 
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• Selecting the portion of the DEM that you would like to import. 

• Importing the desired portion of the DEM. 

The DEM that you will be importing in this tutorial contains data for Aspen 
Grove, Utah.  Aspen Grove is located about 50 miles south of Salt Lake City, 
Utah.  The Aspen Grove DEM was used in previous tutorial for creating 
feature object data and will be used by later tutorials to construct a TIN 
representing the watershed located near Aspen Grove. 

5.1.1 Opening the File 

1. Switch to the DEM module by selecting the DEM module icon  
from the top of the Toolbox. 

2. Select the Import… command from the File menu. 

3. Select USGS DEM File (*.dem;*.ddf) from the Files of type field. 

4. Use the file browser to find and Open the file “aspen.dem”.  This file 
should be found in the tutorial directory.  This will add the DEM 
contained in the file to the list in the Importing USGS DEMs. The 
window at the top of the Import USGS DEMs dialog shows a list of the 
DEM files that will be imported.   

5. Select OK. 

5.2 Selecting an Active Area 
Whether you are using a single DEM, or several tiled together, it is likely that 
your watershed will not cover the entire area of the DEM.  You can inactivate 
the portions of the DEM that you know are outside of your watershed and then 
delete them from memory in order to conserve RAM.  There are actually 
several ways to do this, but the easiest and most frequently used one is 
demonstrated here. 

1. Select the Open… command from the File menu. 

2. Use the file browser to find and Open the file “aspenrgn.map”.  This 
file should be found in the tutorial directory. 

After reading this file you should see a bounding box around the portion of the 
aspen grove DEM that contains the watershed we will be working with.  You 
now need to eliminate the DEM outside of this bounding box. 

1. Select the Select DEM points tool . 
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2. Drag a rectangle that encompasses the black box defined in 
“aspenrgn.map” (see Figure 5-1). 

3. Select the Set Active Region command from the DEMs menu. 

4. When asked if you want to delete the inactive region, select No. 

 
Figure 5-1 DEM Region Selection Box. 

It appears that portion of the DEM outside the box is gone, but actually these 
elevations have just been toggled to inactive.  You could bring them back by 
selecting the Activate All command, but in this instance you won't be needing 
these data so go ahead and delete them, by doing the following: 

1. Select the Display Options… command from the Display menu. 
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2. Turn on the display of Inactive cells and select OK. 

The inactive portion of the DEM will now be displayed in red.  Since you 
won't need this part of the DEM you can go ahead and remove it altogether. 

1. Select the Delete Inactive command from the DEMs menu.  

5.3 Viewing the DEM 
WMS features many options for viewing DEMs.  These options include: 

1. Elevation contours of the DEM. 

2. Hill Shade display. 

These tools will allow you to better visualize the topography of the region 
represented by the DEM. 

5.3.1 Displaying Contours 
WMS has the capability of displaying elevation contours on DEMs.  Elevation 
contours are used to determine where the peaks, canyons, and valleys are in the 
DEM.  Contours are especially useful while digitizing feature lines from the 
display window.  WMS can display either normal linear contours or color filled 
contours.  By default linear contours are on and you have already seen this 
option. 

1. Select Contour Options… in the Display menu. 

2. Turn on the Display Legend toggle.  

3. Turn on the Color fill between contours radio button. 

4. Select OK. 

Note:  The escape key can be used to abort drawing at any time if it is taking to 
long to refresh the display. 

The color legend in the top left corner of the display indicates that the blue 
regions are of high elevation while the red regions are of low elevation. 

5.3.2 Display Speed 
Depending upon the type of computer you are using, the display of the color 
filled contours may have been slow.  To speed up the display process you can 
change the Point display step. 

1. Select Display Options… from the Display menu. 
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2. Change the Point display step to 5. 

3. Select OK. 

With a larger Point display step, the display is faster but the resulting contours 
are not as smooth. 

5.3.3 Displaying a Hill Shade View 
By creating a hill shade view of the DEM you will get a nice image depicting 
the overall topographic layout.  A light source is used to determine the 
direction of the sun, and therefore the “shadow” or shaded areas. 

1. Select the Shade command from the Display menu. 

With color filled contours on, the hill shade uses the contour values for 
shading the DEM.  You can also shade the DEM in a single color (the DEM 
point display color) by turning off DEM contouring. 

1. Select the Display Options… command from the Display menu. 

2. Turn off DEM contours. 

3. Select OK. 

4. Select the Shade command from the Display menu. 

The lighting direction can be changed to highlight the DEM from a different 
angle. 

1. Select the Light Angle command from the Display menu. 

2. Click on a location on the sphere to indicate a new direction for the 
light source (the white regions on the sphere indicate the current light 
source direction). 

3. Select the Shade command again from the Display menu. 

4. Select OK. 

While a true hidden surface algorithm is not used to shade the DEM, an 
oblique view can be used.  Some angles will be more effective/accurate than 

others, so you may wish to experiment a little with the Rotate tool . 

1. Select the Oblique View command from the View menu. 

2. Select the Shade command from the Display menu. 
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5.4 Importing ASCII Grid Files 
Besides standard USGS DEMs, gridded elevation data from the ARC/INFO or 
GRASS GIS files can be imported and used as a DEM.  WMS also has its own 
data file for gridded elevation, which can be used when trying to convert a file 
from other non-supported formats.  Refer to the reference manual for a 
description of the DEM file format. 

5.4.1 Importing an ARC/INFO ASCII Grid 
For ARC/INFO and GRASS formatted grid files the following sequence can be 
used to import an ASCII file. 

1. Select the Map module icon . 

2. Select the Delete All command from the Edit menu. 

3. Select the DEM module icon . 

4. Select Contour Options… from the Display menu. 

5. Turn on the Normal linear contours radio button in the lower left 
portion of the dialog. 

6. Select OK. 

7. Select the Import… command from the File menu. 

8. Select Arc/Info grid (*.asc) from the Files of type field. 

9. In the File name: field type “jonescyn.grd”. 

10. Select Open to import the file. 

11. Select OK to delete existing DEM data. 

The Importing ARC Info dialog will open. In this dialog you can add more 
grid files to import or adjust the coordinates of the DEM coverage. 

12. Select OK to close the Importing ArcInfo Grid dialog and to import 
“jonescyn.grd”. 

This DEM represents a small hill with a couple of small canyons that empty 
into a valley region.  DEM elevations are typically rounded to the nearest 
meter.  For areas of high relief this rounding has little noticeable affect.  
However, in valley areas it may cause artificial flat areas to appear.  It is 
important to remove these flat areas before creating a TIN for drainage basin 
delineation.  In order to see the flat areas: 
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1. Select the Display Options… command from the Display menu. 

2. Turn on DEM Contours and Flat DEM cells, and turn everything else 
off. 

3. Change the Point display step to 1. 

4. Select OK. 

The regions colored in red are locations in the DEM where four elevation 
points, defining a square, all have the same elevation.  While it would be rare 
for this to occur naturally (except for where a lake exists), this often happens 
with DEM data because of the roundoff errors.  The natural smoothness can be 
restored using the following commands. 

1. Select the Smooth DEM command from the DEMs menu. 

This opens a dialog with options that determine how the DEM will be 
smoothed.  By keeping the maximum change in elevation to 0.5 we won’t 
smooth the elevations beyond what would be justified based on the original 
rounding to the nearest meter.  Sometimes several iterations of smoothing are 
required to propagate changes over a large flat area.  However, for this DEM 
you can use the default smoothing values. 

1. Select OK. 

Most of the red regions should be gone.  If you decide you would like to 
change the options for smoothing you can restore the original elevations by 
selecting the Restore Elevations command from the DEMs menu. 

5.5 Conclusion 
This concludes the DEM Basics tutorial.  In this tutorial you have learned how 
to: 

1. Import DEMs into WMS. 

2. Use WMS's DEM visualization tools. 

3. Smooth DEM data. 

In subsequent tutorials you will use DEMs as background elevation data for 
creating TINs. 
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CHAPTER 6 
Watershed Delineation from DEMs 

Estimated Time: 25 minutes 

In the last tutorials you were introduced to DEMs as a source of digital 
elevation data.  In WMS, DEMs can be used to develop watershed boundaries 
and important geometric parameters, or as a background elevation source for 
defining elevations at TIN vertices (see the tutorial in chapter 8). 

In this tutorial you will learn how watersheds can be delineated from DEM 
data and then converted to feature arcs and polygons for use in defining a 
hydrologic model. 

Specifically this tutorial covers the following topics: 

• Importing a DEM. 

• Computing flow directions with the TOPAZ program. 

• Computing flow accumulations and conversion of DEM stream points 
to a stream feature arc. 

• Addition of outlet points at any location along the stream network. 

• Basin delineation and computing basin geometric parameters. 

• Conversion of DEM basins to feature polygons. 
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6.1 Preparing the DEM 
There are five DEM elevation files supported by WMS; USGS, USGS–SDTS, 
DTED, ARC/INFO ASCII grids, and GRASS ASCII grids.  In this tutorial we 
will import a USGS formatted DEM file, but recognize that the same 
operations could be done using any of the supported formats. 

6.1.1 Importing a USGS DEM 

1. Switch to the DEM module by selecting the DEM module icon  
from the top of the Toolbox. 

2. Select Import… command from the File menu. 

3. Select USGS DEM File (*.dem;*.dbf) from the Files of type field. 

4. Find and Open the file “aspen.dem”.  This file should be found in the 
tutorial directory.  This will add the DEM contained in the file to the 
list in the Import USGS DEMs dialog.   

The window at the top of the dialog shows a list of the DEM files that will be 
imported.   

1. Select the OK button in the Import USGS DEMs window. 

6.1.2 Clipping a Region for Analysis 
In the previous tutorial you learned how to specify a bounding box for 
importing only a portion of a USGS DEM file.  You can also limit the area of 
analysis using the activate and inactivate DEM points commands. 

1. Select the Open… command from the File menu. 

2. Find and Open the file “aspenrgn.map”.  

This file contains a rectangle that illustrates the region you need active for 
analysis.  In order to inactivate the remaining regions do the following: 

1. Select the Select DEM Point tool . 

2. While holding the left mouse button down drag a rectangle around the 
rectangle you just read in. 

3. Select the Set Active Region command from the DEMs menu. 

4. Select Yes, deleting the inactive DEM region. 

5. Select the Display Options… command from the Display menu. 
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6. Turn off the display of Flow Accumulation and select OK. 

6.2 Delineating Stream Networks and Watershed Boundaries 

6.2.1 Computing Flow Directions 
Now that you have the region you want for analysis the next step is to compute 
the flow directions for the DEM using the TOPAZ program.  This is done 
automatically in two steps: 1) Computing the flow directions, which requires 
launching the TOPAZ program from within WMS, and 2) reading in the 
resulting flow directions file. 

1. Select the Compute TOPAZ Flow Data… command from the Drainage 
menu. 

2. Use the default options and select OK. 

3. Select Yes to close the application window when TOPAZ finishes. 

TOPAZ creates a file called “flovec.dat” in which the flow direction data 
is stored.  WMS then automatically reads the flow directions file, but you 
must change the Display Options to show the flow directions in the 
graphics window. 

1. Select the Display Options… command from the Display menu. 

2. Turn on the display of Flow directions and select OK. 

A flow direction vector for each DEM point will be drawn.  Because of the 
resolution of DEM points it will be difficult to see the vectors so you will want 
to do the following: 

1. Select the Zoom tool . 

2. Zoom in on a small portion of the DEM until the vectors become 
visible.  You should be able to get an idea of what TOPAZ has done in 
creating flow directions from the elevations. 

3. Select the Display Options… command from the Display menu. 

4. Restore the display settings by turning the flow directions option off. 

5. Select OK. 

6. Select the Frame Image macro . 
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6.2.2 Drawing Flow Paths 
Once a flow direction grid has been imported into WMS, flow paths for any 
location may be drawn interactively. 

1. Select the Flow Path tool . 

2. Click on any location of the DEM. 

A flow path will be traced across the DEM from point to point according to the 
flow direction grid.  You may wish to continue clicking on several locations of 
the DEM to examine the flow patterns.  You can also draw all flow patterns at 
once: 

1. Select the Draw Flow Patterns command from the Drainage menu. 

This command draws a flow path from each DEM point.  It is controlled by the 
display step so if you wish to see a higher or lower density of flow paths you 
need to adjust the display step in the DEM Display Options dialog. 

6.2.3 Computing Flow Accumulations 
In order to delineate a stream network a flow accumulation grid “uparea.dat” 
was computed with TOPAZ.  The Flow Accumulation is determined by using 
the flow directions to compute how many DEM points “drain” to a given DEM 
point for every DEM point in the analysis area.  The flow accumulations will 
be displayed when you have either read them in or computed them in WMS.  
As with the flow directions, WMS has automatically read in the flow 
accumulation file computed by TOPAZ.  All you have to do is display it. 

1. Select the Display Options… command from the Display menu. 

2. Turn on the display of Flow accumulation and select OK. 

The DEM points colored in blue represent locations likely to be in a natural 
channel because their accumulation is high.  The default threshold for display 
is typically 200, but you can change this: 

3. Select the Display Options… command from the Display menu. 

4. Set the Min accumulation for display value to be 1000. 

5. Select OK. 

Notice how the streams are smaller and have fewer branches.  You can 
continue to experiment with this display option if you wish.  When finished 
experimenting, set the threshold back to 200. 
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6.2.4 Converting Raster Streams to Stream Feature Arcs 
Up until now the display of streams has been based solely on a threshold value, 
and before basin delineation can take place you must identify where you want 
watershed and sub-basin outlets to be along a stream vector. 

1. Select the Zoom tool . 

2. Zoom in around the branch identified in Figure 6-1. 

 
Figure 6-1 Aspen Grove Stream Network Branching Point. 

1. Select the Create Feature Point tool . (Note that the map module 
tools are repeated in the DEM module because of the interaction with 
feature objects when delineating basins with DEMs). 

2. Create a new feature point just upstream from the branching location 
in the stream you have just zoomed in on (see Figure 6-2). 
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Figure 6-2 Aspen Grove Watershed Outlet Location. 

1. Select the Frame Image macro . 

2. Select the DEM->Streams Arcs… command from the Drainage menu. 

3. Turn on the Display stream feature arc creation and Use feature 
points to create streams options. 

4. Set the Threshold value to 400. 

5. Select OK. 

Starting at the outlet point just created and working upstream, WMS converts 
the DEM points with accumulation values greater than or equal to 400 into a 
series of feature arcs.  The feature arcs are assigned to be stream type. 

6.2.5 Delineating Watershed and Sub-basin Boundaries 
With the stream network defined as an arc you are ready to define the 
watershed boundaries. 

1. Select the Define Basins command from the Drainage menu. 

2. Select the Refresh macro . 

The DEM points which “drain” to the outlet of the stream network previously 
defined are identified by using the flow direction information.  You can now 
inactivate and eliminate all DEM points outside of the watershed. 

1. Select the Inactivate NULL Basin command from the Drainage menu. 
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2. Select the Delete Inactive from the DEMs menu. 

You can further subdivide the watershed into subbasins by converting some of 
the feature points to outlets. 

1. Select the Select Feature Point/Node tool . 

2. Select the two junction points identified in Figure 6-3.  Remember you 
can multi-select the two points by holding down the SHIFT key. 

3. Select the Node<->Outlet command from the DEM Drainage menu to 
assign the nodes attribute type to be an outlet. 

4. Redefine the basins with the new outlets by selecting the Define 
Basins command from the DEM Drainage menu. 

 
Figure 6-3 Sub-basin Outlets of Aspen Grove Watershed. 

6.2.6 Converting Raster Basin Boundaries to Feature Polygons 
Now that the basins have been delineated you can convert the boundaries to 
polygons. 

1. Select the Basins->Polygons command in the Drainage menu. 

6.2.7 Computing Basin Geometric Parameters 
Finally you will want to compute the basin areas, slopes, runoff distances, etc. 
and associate them with the polygons. 
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1. Select the Compute Basin Data… command from the Drainage menu. 

2. Set the Model units to Meters and leave the Parameter units settings at 
their default values. 

3. Select OK. 

4. Select the Display Options… command from the Display menu. 

5. Select the Drainage tab. 

6. Insure that the Show units, Basin areas, and Basin slopes options are 
toggled on. 

7. Select OK for both dialogs. 

6.2.8 Hill Shade With Stream and Watershed Boundaries 
The hill shade command demonstrated in the previous tutorial functions 
slightly differently once streams and watershed boundaries have been 
delineated.  Any DEM point that is part of the stream or a basin boundary is 
colored accordingly when performing a hill shade. 

1. Select the Shade command from the Display menu. 

6.3 Conclusions 
This concludes the tutorial on basin delineation from DEM data.  You may 
wish to continue experimenting with the different options. 

In summary, you have learned how to: 

• Import a DEM and activate a region for analysis. 

• Compute flow directions and flow accumulations for a DEM. 

• Convert raster streams to vector streams (feature objects). 

• Define watershed and sub-basin boundaries. 

• Convert raster basin boundaries to polygons. 

• Compute basin data. 

With the watershed delineated and basin data computed you could now 
continue to define a hydrologic model. 
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CHAPTER 7 
TIN Basics 

WMS allows you to quickly and easily import and manipulate terrain data.  
Besides DEM data, WMS can also use TINs (Triangulated Irregular Networks) 
for surface representation.  Each TIN is constructed from a scattered set of x y 
z vertices.  From the TINs generated by WMS, drainage basins can be 
delineated. 

The vertices used to create a TIN can be imported from an ASCII file, from 
another TIN file (such as InRoads), or by interpolation from a DEM.  

To use TINs in WMS effectively you will want to learn about the following: 

• Importing data files. 

• Using WMS's viewing tools to change perspectives, allowing you to 
visualize a TIN in 3-D. 

• Contouring the TIN. 

• Using TIN display options to identify important features of the terrain 
model. 

• Editing the TIN. 

7.1 Reading Vertex Data Files Into WMS 
After familiarizing yourself with the WMS window, you will be ready to load 
the sample vertex file that you will be using for the rest of this tutorial.  This 
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ASCII text file is simply a list of XYZ coordinates.  To load the sample vertex 
file, do the following: 

1. Select the TINs module icon . 

2. Under the File menu select Open…. 

3. Find and Open the file named “jonescyn.tin”.  By default this file is 
found in the tutorial directory. 

 A group of vertices will appear in the graphics window.  If you can’t 
see the vertices try selecting Display Options… from the Display menu 
and turn vertices on. 

7.2 Triangulating Vertices To Make a TIN 
After the vertices have been read into WMS, they must be triangulated into a 
TIN. 

1. Select Triangulate from the TINs menu. 

2. Select OK if you are told that retriangulating will delete existing 
triangles. 

During the triangulation process several long, thin triangles may be created 
around the perimeter of the TIN.  Often these triangles are not wanted and so 
WMS provides a way of automatically selecting thin boundary triangles, so that 
you may delete them.  To delete the triangles, do the following: 

1. Select the Select Boundary Triangles from the TINs menu. 

2. Choose the Select thin boundary triangles only option and select OK. 

 All thin boundary triangles will be shaded, indicating they are 
selected. 

3. Select the Delete command from the Edit menu (You can also do this 
by selecting the DELETE or BACKSPACE key). 

4. Select OK if the confirmation dialog box appears. 

7.3 Changing the Viewing Parameters 
To help you better visualize a three-dimensional terrain model, WMS provides 
multiple viewing perspectives of your TIN. The default view is plan view, 
where you are looking at your TIN from directly overhead. This is the easiest 
view in which to edit and do most of the drainage analysis with your TIN. 



 TIN Basics 7-3

The Oblique View option in the View menu allows you to display the TIN in a 
perspective view. 

1. Select Oblique view from the View menu. (You could also use the 

macro ) 

The display will be updated, and you will be viewing your TIN from a 
perspective view. This view emphasizes the peaks and valleys on your terrain 
model. 

Oblique view shifts you from plan view to a viewing angle determined by the 
bearing and dip angles entered in the View Angle dialog box under the View 
menu. The default or plan view corresponds to a bearing of 0 degrees and a dip 
of 90 degrees. 

You can use the Rotate Image tool  to quickly change viewing angles 
without having to use the View Angle dialog box in the View menu. Use the 
View Angle dialog box when you want to set the view angle to an exact value 
or to check what the current viewing angle is.  

To use the Rotate Image tool to change viewing perspectives, do the following 
steps: 

1. Select the Rotate Image tool . 

2. Hold down the CONTROL key on your keyboard, move your cursor to 
the middle of the graphics window, and click and hold down the 
mouse button while you drag the cursor in different directions.  As you 
move the mouse, the TIN is constantly redrawn to reflect your 
changes.  The bearing is changed by dragging the mouse horizontally, 
and the dip is changed by moving the mouse vertically.  Any 
combination of the two directions can be used.  The amount an object 
is rotated depends on how far the mouse is dragged.  Dragging from 
the left edge of the edit window to the right edge rotates the object 180 
degrees. 

 When working with complex TINs, your computer may not update the 
screen quickly enough.  To change the viewing perspective in one step 
without any intermediate screen updates, do the same steps outlined 
above without holding down the CONTROL key. 

3. When you are finished, select Plan view macro . 

7.4 Displaying Contours on a TIN 
WMS has several options for displaying contours on a TIN.  WMS can display 
lined contours, color-filled contours, and contour elevation labels. 
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To display contour lines, do the following steps: 

1. Select Display Options… from the Display menu. 

2. Click on the Tin Contours option so that it is enabled. 

3. Click on the OK button. 

 The screen will redraw, and the TIN will be overlaid with contour 
lines. 

As you can see, vertices and triangles were also displayed along with the 
contour lines.  Often when displaying contours you want to disable vertex and 
triangle display.  To disable vertex and triangle display, do the following: 

1. Select the Display Options… command from the Display menu. 

2. Click on both the Vertices and Triangles options so they are disabled.  

3. Click on the OK button. 

 The screen will now redraw with only the contour lines and the outer 
boundary of the TIN. 

In addition to displaying lined contours, WMS can display color filled 
contours.  When active, this option fills the area between two adjacent contour 
lines with a color corresponding to the upper contour value.  Two types of 
shading are available: hues of varying colors and multiple shades of a single 
color. 

To display color filled contours shaded with hues of varying colors, do the 
following steps: 

1. Select Contour Options… from the Display menu. 

2. Select the Color fill between contours option. 

3. Click on the OK button. 

To display contours shaded with multiple shades of a single color, do the 
following: 

1. Select Contour Options… from the Display menu. 

2. Select the Color Options tab. 

3. Select the Intensity Ramp option. 

4. Click on the OK button. 
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 After the screen redraws, your TIN will be shaded with multiple 
shades of a single color indicating various elevations. 

WMS allows Contour labels to be created and placed manually on a TIN.  To 
display contour labels, do the following: 

1. Select Plan View from the View menu. 

 Contour labels can be displayed only in Plan view. 

2. Select the Create Contour Label tool . 

3. Click on a point interior to your TIN. 

 A value indicating the elevation of the nearest contour to the point 
clicked will appear. Multiple labels can be displayed on a TIN.  A 
label can be removed by holding down the SHIFT key while clicking 
on the label.  Labels remain and are displayed each time the model is 
redrawn until the TIN is edited in any way at which time they are 
deleted. 

For the next section of this tutorial you will want contours turned off.  To turn 
off the contours and restore vertex and triangle display, do the following: 

1. Select Display Options… from the Display menu. 

2. Turn Tin Contours off. 

3. Turn Triangles back on. 

4. Change the color of triangles to a color of your choice by clicking on 
the color-filled box adjacent to the toggle.  Click on the color box in 
the attributes dialog.  In the color chooser select any color you want, 
except black.  If triangles are black no shading will occur. 

5. Click on the OK button. 

7.5 Creating a Shaded Image of Your TIN 
WMS provides several options for generating shaded images of TINs.  TIN 
shading converts the wire frame TIN that you normally see into a shaded 
image.  To shade a TIN, do the following: 

1. Select Oblique View from the View menu. 

2. Select Shade from the Display menu. 

 The screen will redraw and your TIN will appear as a solid shaded 
object rather than as a wire-frame image. 
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WMS also allows you to vary the simulated light source’s position.  This is 
useful when the default setting does not provide enough contrast in the shaded 
image.  To vary the light source position, do the following: 

1. Select Light Angle… from the Display menu. 

 A dialog containing a shaded sphere will appear.  The way the sphere 
is shaded indicates how the light source is directed at the TIN when 
shading. 

2. Click on the sphere at a new location to change the light source 
direction. 

3. Click on the OK button. 

4. Select Shade from the Display menu. 

5. If the shaded image is too dark or too light, change the light angle 
again. 

6. When you are finished shading, select Plan View from the View menu 
to restore the default view. 

7.6 Mapping an Image to a TIN 
You can map an image to your TIN so that you can see the effects of shading 
with an image “draped” over the TIN.  This operation is relatively simple and 
can be a highly effective way to show-off your data. 

You will need to be sure that the image is appropriately registered.  In this 
example you will read in an already registered image, but if you need to review 
this see section 2.3 of this tutorial manual. 

1. Select the Map module . 

2. Select the Open… command from the File menu. 

3. Find and Open the file named “jonescyn.img”. 

4. Select the Display Options… command from the Display menu. 

5. Select the Image Display Options button. 

6. Turn on the Texture map to surface when shaded option. 

7. Set the option to Map to active TIN. 

8. Select OK twice to close the Image Display Options and Display 
Options dialogs. 
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9. Select the TINs module . 

10. Select the Shade command from the Display menu.  This may take 30-
60 seconds depending on the speed of your computer processor. 

You may want to experiment with the following adjustments to get the best 
view of a mapped image: 

• Change the view angle using the Rotate tool .  Then choose the 
Shade  command from the Display menu. 

• Change the Z-magnification by selecting Z Magnification… command 
from the View menu.  This will exaggerate the 3-D effect so that terrain 
features appear more prominently.  A value of 1-3 is generally 
appropriate if the value is too large the TIN will become overly 
distorted. 

• Change the lighting angle by selecting the Light Angle… command from 
the Display menu and then choose the Shade command from the Display 
menu. 

When you are finished reset the display options. 

1. Select Display Options… command from the Display menu. 

2. Select the Map tab. 

3. Select the Image Display Options button. 

4. Turn off the Texture map to surface when shaded option. 

5. Select OK. 

6. Select the TIN tab. 

7. Turn on Tin Contours. 

8. Select OK. 

9. Select the Plan View macro . 

7.7 Adding Breaklines to Preserve Geometric Features 
Because of the way WMS triangulates vertices, geometric features such as 
ridges or valleys may not appear on your TIN as they do in the original terrain. 
You can use the Add Breakline(s) option to enter these features manually. 

To add a breakline, do the following: 
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1. Select the Select Vertex Strings tool . 

2. Click on any vertex in your TIN. 

 The vertex you clicked on will now be highlighted in red. 

3. Click on another vertex that is not attached to your original vertex (i.e. 
connected by a triangle edge). 

 The two vertices you selected are now connected by a solid red line.  
This red line, when processed, will force triangle edges to be honored 
along it.   

4. Select Add Breakline(s) from the TINs menu. 

WMS adds vertices and retriangulates your TIN so that triangle edges are 
honored along the line you entered with the Select Vertex String tool.   

Several vertices can be added to a string before selecting the Add Breaklines 
command.  If a mistake is made entering a vertex string single vertices can be 
removed by pressing the DELETE/BACKSPACE key.  To abort entering a 
vertex string, use the ESCAPE key. 

7.8 Swapping Triangle Edges 
Local changes in the TIN topology can be made by swapping the edges of two 
adjacent triangles.  This process is similar to the breakline method described 
above since it allows you to force triangle edges to coincide with important 
TIN features. 

To swap triangle edges, do the following: 

1. Click on the Swap Edges tool . 

2. Click on the edges of several triangles and notice how the edge 
configuration is swapped. 

Some triangle edges cannot be swapped, since by so doing overlapping 
triangles would be formed.  If you try to swap one of these edges, you will hear 
a beep and the edge will not be swapped. 

7.9 Selecting and Deleting Vertices on a TIN 
Some functions require one or more vertices to be selected before you perform 
the function.  This portion of the tutorial familiarizes you with the different 
options for selecting vertices and how they are used in conjunction with 
deleting and dragging. 
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When selecting vertices, WMS allows you to work with either single or 
multiple vertices simultaneously. 

To select a single vertex: 

1. Click on the Select Vertices tool . 

2. Move the mouse pointer over a vertex on your TIN and click on that 
vertex.  The vertex will now be highlighted, indicating it is selected. 

3. Click on another vertex.  The vertex you selected originally is now 
unselected, and the new vertex is now the selected one.  Notice that 
the xyz values of the vertex are placed in the vertex edit box. 

Often you will want to manipulate multiple vertices, as when you are deleting 
a section of a TIN.  WMS provides three methods for selecting multiple 
vertices: 

• Select multiple vertices individually by holding down the SHIFT key 
and selecting several points. 

 If the SHIFT key is depressed while selecting, you are allowed to 
select multiple points. If the SHIFT key is not depressed, only one 
point can be selected at a time. 

• Select multiple vertices by holding down the mouse button and 
dragging a box enclosing the portion of the TIN you want selected.  
(Be careful not to select a vertex when you begin to drag your box.) 
When the mouse button is released, all vertices lying within the box 
are selected. 

• Select multiple vertices by using a selection polygon.  Under the Edit 
menu, select Select With Polygon. 

Before a vertex can be deleted it must be selected.  To delete a vertex, do the 
following:  

1. Select a single vertex on your TIN. 

2. Press the DELETE/BACKSPACE key. 

 Remember that by selecting multiple vertices before pressing the 
DELETE key, you can delete multiple vertices in one step. 

7.10 Dragging Vertices on a TIN 
WMS allows you to easily move a vertex with the select vertices tool. The 
dimensions on which a vertex is dragged depends upon the editing view.  In 
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Plan view, only the x and y values are changed.  In any view other than plan, 
the z value is the only value affected. 

First, turn on several display options so you can see the effects of vertex 
modifications more easily: 

1. Select Display Options… from the Display menu. 

2. Enable the Vertices, Triangles, Tin Contours, Ridge Edges, Channel 
edges, and Pits options. 

3. From within the Display Options dialog click on the Contours… 
button.  Select the Normal linear contours option. 

4. Click on the OK buttons of each dialog. 

To drag a vertex, do the following: 

1. Make sure you are in Plan view, and with the Select Vertices tool  
active, click on a vertex near the center of your TIN.  While holding 
down the mouse button, drag the point to a new location.  Notice how 
the TIN stretches to follow your changes and how only the x and y 
values of that point are changed in the vertex edit dialog in the upper 
left side of your screen.  Notice also how there are limits to the amount 
a vertex may be dragged so that the triangulation will remain valid. 

2. With the vertex still selected (four squares are drawn around the vertex 
to indicate that it is selected), click in the x, y, or z vertex edit box in 
the upper left of the screen and change the value.  Notice that you can 
not change the x or y value in such a way that the triangulation will 
become invalid in the same way that there was a limit to the distance a 
node could be dragged above. 

3. Enter a new value into the z edit box in the edit window adjust the 
elevation of the selected vertex.  Notice how the contours, channel 
edges, pits, etc. display, are all updated instantaneously as the values 
are modified. 

4. Continue moving/editing the vertices until you are comfortable with 
how these options work. 

7.11 Inserting Vertices on a TIN 
After you have triangulated your initial set of vertices, it might be necessary to 
manually add vertices in certain locations to help improve the definition of the 
TIN. 

Before adding vertices, it is wise to lock the existing vertices.  Locking 
vertices serves two purposes.  First, it prevents them from being moved 
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(intentionally or accidentally) as described above.  It also distinguishes them 
from points which are subsequently added.  This distinction is often important 
since the original vertices represent data with a greater amount of certainty 
(and which you are less likely to want to change). 

To lock the vertices, do the following: 

1. Select Lock/Unlock Vertices from the TIN menu.  If prompted, select 
Lock All to lock all the vertices. 

The color of the vertices will change from the unlocked color (black by 
default) to the locked color (red by default). 

To add vertices, do the following: 

1. Select Plan view from the View menu. 

 Plan view is the only view that you can use to enter new vertices. 

2. Select the Create Vertices tool  from the tool palette. 

3. Click anywhere within the TIN. 

4. Accept the default z-value by selecting the OK button. 

 WMS will retriangulate the affected portion of the TIN, incorporating 
the new vertex.  Notice that the new vertex is black indicating that is 
unlocked and can be adjusted.  A default z value for the new vertex 
will be determined from the surrounding triangles. 

5. Add a few more vertices, this time experimenting with different Z-
values.  Watch how the TIN changes as the new vertices are inserted 
into the triangulation. 

6. Select Refresh from the Display menu. 

7.12 Changing Display Attributes 
Throughout this tutorial you have turned various display attributes (contours, 
vertices, triangles, etc.) off and on using the TIN display options.  Besides 
toggling the display, colors, line widths, and line styles may be changed for 
contours, triangles, or any of the different objects which can be displayed. 

To change display attributes, do the following: 

1. Select the Display Options command from the Display menu. 

2. Select the color box to the left of the Contours display option toggle. 
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3. Change the width of the line to 2. 

4. Select the color box from the Attributes dialog. 

5. A color palette appears from which you may assign a new contour 
color. 

6. Click on the OK button for the Color Palette dialog. 

7. Click on the OK button for the Attributes dialog. 

8. Click on the OK buttons for the Display options dialog. 

Continue experimenting with turning off and on display options and changing 
any of their attributes.  PC NOTE: MS Windows only allows dashed lines 
when the thickness is 1. 

The ability to change line thicknesses and styles comes in particularly handy 
when creating hard copies where all lines are typically drawn in black. 

7.13 Conclusion 
TINs are one of the different types of terrain models that can be used for 
performing drainage analysis in WMS.  The next tutorial illustrates how TINs 
can be created from feature object data.  This is important since an arbitrary 
triangulation of scattered data points may not produce a TIN that is suitable for 
drainage analysis (i.e. triangle edges enforced along streams and ridges).  If 
you have a set of scattered data points initially it may be a good idea to 
triangulate them and then treat them as a background elevation map (similar to 
the DEMs of the previous tutorial) for creating a new TIN from feature object 
data. 

In this tutorial you have learned the basics of viewing and manipulating TINs.  
These concepts apply whether you are using the TIN for visualization only, as 
a background elevation map for creating a more suitable TIN for drainage 
analysis, or as a TIN from which a watershed will be characterized. 
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CHAPTER 8 
Watershed Delineation from TINs 

Estimated Time: 20 minutes 

The last three tutorials have introduced you to using Feature Objects and 
DEMs and TINs for background elevation maps.  In this tutorial you will 
combine these tools together to create a TIN that can be used for watershed 
delineation parameter computation. 

Specifically this tutorial covers the following topics: 

• Reading in a registered TIFF image. 

• Reading in a map file for use in defining key watershed features. 

• Importing a DEM and using the feature objects to create a TIN. 

• Delineating a watershed and sub basin boundaries from the TIN. 

• Computing basin geometric parameters. 

• Using drawing objects for annotations. 

8.1 Reading a Registered TIFF Image 
The feature object data you will be using in this tutorial was created from a 
TIFF map in the same way shown in section 2.2 of these tutorials.  This same 
TIFF image, which was previously registered, can be read into WMS by: 

1. Select the Map module icon . 
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2. Select Open… from the File menu. 

3. Type *.img in the file name edit field (this will cause the file browser 
to only list file names ending with img). 

4. Find and Open the file named “jonescyn.img”.  This file should be 
found in the tutorial directory.   

After a few seconds of reading the file and registering the image, the TIFF 
image of a portion of USGS quad map will appear in the Graphics window. 

8.2 Reading in a Map File 
As stated in the previous section, the registered image can be used as a 
backdrop for on-screen digitization of streams and a rough boundary.  These 
feature objects will be used to create a TIN that will conform to the boundary 
polygon and maintain triangle edges along all streams or other interior feature 
arcs. 

If you haven’t done the tutorial on creating feature objects from images, or if 
you need a refresher, refer to section 2.3.3 in this tutorial manual before 
proceeding to the next section.  If you have completed the Feature Objects 
tutorial and already feel comfortable with how feature objects are created, then 
do the following: 

1. Select Open… from the File menu. 

2. Find and Open the file named “jonescyn.map”. 

This map files contains a bounding polygon and two stream branches.  

8.3 Importing a Background Elevation Map 
Elevations for vertices created inside the boundary polygon can be interpolated 
from a background elevation source such as a DEM or another TIN.  Without a 
background elevation map the TIN will not have z values and therefore will be 
unusable for watershed delineation.  The tutorial in Chapter 5 teaches you how 
to work with DEMs as background elevation maps.  If you have not yet done 
this tutorial or need a refresher you may wish to do it now. To import a 
background elevation map: 

1. Select Import… from the File menu. 

2. Find and select, but do not open, “jonescyn.grd”. 

3. Select Arc/Info Grid from the Files of type field. 

4. Select the Open button. 
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5. Select OK to close the Importing ArcInfo Grid. 

6. Select the DEM module . 

7. Select the Smooth DEM… command from the DEMs menu. 

8. Set the number of iterations to 3. 

9. Select OK. 

Smoothing the DEM will help to eliminate the affects of rounding to the 
nearest meter. 

Contours of the DEM will be overlaid on the image.  If the color filled contour 
options is active you may wish to change to linear contours by: 

1. Select the Contour Options…  command from the Display menu. 

2. Choose the Normal linear contours option. 

3. Select OK. 

8.4 Creating a TIN and Defining a Watershed 
With the feature objects defined, and a background elevation map you are 
ready to create the TIN. 

8.4.1 Redistributing Vertices 
The density of vertices that are created inside the boundary polygon will be 
proportional to the density of vertices along the feature arcs.  In order to have 
control over the TIN vertex density, WMS allows you to automatically 
redistribute vertices along arcs to a higher or lower density (decrease or 
increase spacing between arc vertices).  To redistribute the vertices: 

1. Select the Map module . 

2. Select the Select Arc tool . 

3. Choose the Select All command from the Edit menu. 

4. Choose the Redistribute command from the Feature Objects menu. 

5. Specify the Subdivide each end uniformly with a Specified spacing of 
100 (meters). 

6. Select the OK button. 
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8.4.2 Creating a TIN 
To create a TIN from the defined feature objects: 

1. Select the Select Polygon tool . 

2. Click anywhere inside the boundary polygon. 

3. Select the Create TIN command from the Feature Objects menu. 

4. Select No when asked if you would like to save your data before 
proceeding.  The drainage coverage and TIN cannot coexist in WMS 
so the drainage coverage is deleted as a result creating the TIN.  This 
prompt allows you to save the drainage coverage prior to having it 
deleted from WMS so that you can come back and use it later should 
you need to. 

5. Turn on the Display triangulation process option in the Create Tin 
Options dialog (this will allow you to see, and better understand, how 
the TIN creation process works). 

6. Select OK. 

7. Select the Display Options… command from the Display menu. 

8. Select the Image Display Options button. 

9. Turn off the Draw on xy plane behind all objects option. 

10. Select OK to the Image Display Options and Display Options dialogs. 

11. Select the Delete command from the Drawing Objects menu. 

12. Confirm that you want to delete all drawing objects. 

A TIN should be generated inside the bounding polygon and a stream enforced 
along the stream arcs.  The TIN does not represent the actual watershed 
boundary, but can now be used to delineate the watershed and define sub 
basins. 

8.5 Watershed Delineation 
The feature object boundary used to create the TIN was not the watershed 
boundary.  In fact it was created to be larger than the watershed boundary so 
that a more precise watershed boundary can be delineated from the TIN. 

1. Switch to the TINs module . 

2. Select the Display Options… from the Display menu. 
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3. Turn off Vertices and turn on Flat triangles and Pits. 

4. Select the OK button. 

8.5.1 Eliminating Pits and Defining Boundaries 
You should not have any flat triangles, but there may be a few pits that must be 
removed before defining watershed and sub basin boundaries. 

1. Select the Smooth Pits command from the TINs menu. 

A single pit will likely remain along the stream, but since it is part of the 
stream it will not affect basin delineation. 

1. Choose the Define Basins command from the Drainage menu. 

8.5.2 Correcting Split Flow Problems 
For some models locations of split flow occur, causing an ambiguity in sub 
basin definition.  If this occurs for your model, you will get an error message 
stating that “triangles drawn in red belong in two drainage basins.”  If this 
happens you can correct the problem: 

1. Select the Correct Split Flow command from the Drainage menu. 

You no longer need the display of pits, flat triangles and split flow vertices. 

1. Select the Define Basins command from the Drainage menu. 

2. Select the Display Options… from the Display menu. 

3. Turn off all of the display options. 

4. Select the Drainage tab. 

5. Turn on Fill drainage basins. 

6. Select OK. 

8.5.3 Refining Boundaries and Eliminating Exterior Triangles 
Triangles are assigned to drainage basins based on following a flow path from 
the centroid of the triangle to the stream/outlet encountered first.  Since some 
triangles will straddle the basin boundaries there is a small amount of error in 
the current basin definition.  You can correct this by refining the boundaries. 

1. Choose the Refine Boundaries command from the Drainage menu. 
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2. Remove the exterior triangles by choosing the Delete Null Basin 
Triangles command from the Drainage menu. 

8.5.4 Computing Basin Geometric Parameters 
The brown and orange areas represent the sub basins of the two stream 
branches.  By default WMS created an outlet point at the downstream-most 
part of the feature arcs.  Basins were created for each upstream branch of the 
outlet.  You can now compute the basin geometric parameters for the 
watershed, and alter the delineation by eliminating exterior triangles, merging 
basins, adding additional outlets, etc. 

1. Choose the Compute Basin Data… command from the Drainage 
menu.  Be sure the Model units are set to Meters and specify the 
parameter units to be whatever you wish. 

2. Select OK to compute the basin data. 

8.5.5 Adding a New Stream 
Additional streams and outlets can be created for the TIN, even after disposing 
of the feature objects and establishing an initial delineation. 

1. Select Display Options… from the Display menu. 

2. Turn on Triangles and Tin Contours. 

3. Select the Drainage tab. 

4. Turn off Fill drainage basins. 

5. Select OK. 

6. Select the Zoom tool . 

7. Drag a rectangle around the region identified in Figure 8-1. 
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Figure 8-1 Zoom Window. 

You will now add a new stream that was not present in the initial feature 
object definition. 

1. Select the Select Vertex String tool . 

2. Starting with the vertex already in the stream, click one by one on the 
vertices identified in Figure 8-2.  A red line will indicate the string of 
vertices selected. 

 
Figure 8-2 Entering a Vertex String to Create a New Stream. 
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1. After selecting the last vertex, select the Create Stream command in 
the Streams menu. 

2. Select Yes to process the breakline before entering the stream. 

8.5.6 Creating Additional Outlets 

1. Select the Select Vertex tool . 

2. Select the vertex where the newly created stream meets the existing 
stream. 

3. Select the Add Outlets command in the Streams menu. 

4. Select the Frame Image command from the View menu. 

5. Select the vertex midway up the upper branch as indicated in Figure 
8-3. 

6. Select the Add Outlets command in the Streams menu. 

 
Figure 8-3 Vertex for New Stream 

You must now redefine the boundaries so that the new outlet is recognized. 

1. Select the Display Options… command in the Display menu. 

2. Turn off Tin Contours. 

3. Select the Drainage tab. 
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4. Turn on Fill drainage basins. 

5. Select OK to close the Display Options dialog. 

6. Select the Define Basins command from the Drainage menu. 

7. Select Refine Boundaries from the Drainage menu. 

8. Select the Compute Basin Data… command from the Drainage menu. 

9. Select OK on the Units dialog. 

8.5.7 Merging and Splitting Basins 
WMS always creates a basin for each upstream branch from an outlet point.  
However, it is sometimes preferable to merge these two basins together. 

1. Select the Select Basins tool . 

2. Click inside the small, central basin. 

3. Hold the SHIFT key down and click inside the basin to the right of 
that. 

4. Select the Merge Basins command from the Drainage menu. 

The text displaying the area of the basins disappears.  This means that the 
basin geometry has changed, and the basin data must be recomputed. 

1. Select the Compute Basin Data… command from the Drainage menu. 

2. Select OK on the Units dialog. 

3. Select the newly created basin. 

4. Select the Split Basins command from the Drainage menu to again 
split the watershed into separate basins for each branch. 

5. Select the Compute Basin Data… command from the Drainage menu. 

6. Select OK on the Units dialog. 

8.5.8 Deleting an Existing Outlet 
You can eliminate outlets once they have been created by doing the following: 

1. Select the Select Vertex tool . 
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2. Select the outlet of the stream branch of the basin you just split and 
SHIFT-select the outlet that you created on the upper stream. 

3. Select the Delete Outlets command from the Streams menu. 

4. Select the Compute Basin Data… command from the Drainage menu. 

5. Select OK on the Units dialog. 

8.5.9 Basin Label Text 
By default some text annotations for the basin geometric parameters are placed 
at the centroid of the basin.  You can view any of the computed parameters by: 

1. Select the Display Options… from the Display menu. 

2. Select the Drainage tab. 

3. Examine all of the different parameters.  Turn on Basin slopes and 
Average overland flow. 

4. Select the OK button. 

Text showing these values, in addition to the area now appears at the basin 
centroid.  When many attributes are displayed, or for larger models, it is 
sometimes convenient to relocate the display of text attributes. 

1. Select the Place Basin Labels tool . 

2. Click inside of one of the basins and while holding the mouse button 
down, drag the cursor to a region outside of the TIN but relatively 
close to the selected basin and release the mouse button. 

3. Select the Refresh command from the Display menu. 

The label moves to the location where you let up on the mouse button and an 
arrow from this point to the location where you first clicked inside the basin is 
drawn.  If you want to place the label in a different position (or have the arrow 
point to a different location inside the basin) repeat the process. 

8.6 Adding Annotations to a Project 
Annotations include text, lines (with or without arrows), rectangles, and 
ellipses (filled or outlined).  This section of the tutorial could be part of any or 
all of the tutorials but is included here to highlight the use of the annotation 
tools.  

1. Switch to the Map module . 
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2. Select the create text tool . 

3. Click on any point near the boundary of the defined watershed.  A 
dialog will appear which allows you to specify the text string, the color 
and the font.  Type “Jones Canyon Basin” in the text edit field and 
change the color to blue. 

4. Select the OK button. 

If the text did not appear where you want, or if you would like to move it after 
it has been created you can do the following: 

1. Select the select drawing object tool . 

2. Click on the text.  It will be outlined with a box. 

3. Click anywhere in the box and while holding down the cursor drag the 
text to a new location. 

4. Select the create line tool . 

5. Click on a point that is near the text and then double-click on a point in 
the center of the upper basin. 

6. Select the select drawing object tool . 

7. Double-click somewhere along the newly created line.  This is 
equivalent to clicking once on the line and then choosing the attributes 
command as was done with the rectangle.  Double-clicking to change 
attributes can be done with any of the drawing objects. 

8. Change the line arrowhead attributes so that an arrow is placed at the 
end. 

9. Change any other attributes you wish and select the OK button. 

Your display should look similar to Figure 8-4.  Try adding other annotations 
and experiment with the different options available to each drawing object. 
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Figure 8-4 Annotations for Jones Canyon Watershed. 

8.7 Conclusions 
In this tutorial you have learned how to use images in conjunction with DEM 
and feature object data to define a TIN that can be used for basin delineation.  
You have also learned how to use annotations to “dress” up the final display of 
any project. 
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CHAPTER 9 
HEC-1 Interface 

Estimated Time: 30 minutes. 

Once a watershed has been appropriately subdivided into smaller basins, you 
can use WMS to enter parameters for defining a complete HEC-1 input file.  
Geometric attributes such as areas, lengths, and slopes are computed 
automatically from the TIN geometry.  Parameters such as loss rates, base 
flow, unit hydrograph method, and routing data are entered through a series of 
interactive dialog boxes.  Once the parameters needed to define an HEC-1 
model have been entered, an input file with the proper format for HEC-1 can 
be written automatically.  There is no need to use an editor or even look at the 
file. 

Since only parts of the HEC-1 input file are defined in this tutorial, you are 
encouraged to explore the different available options of each dialog, being sure 
to select the given method and values before exiting the dialog. 

9.1 Objectives 
In this tutorial you will load a TIN that has already been delineated into several 
different sub basins.  You will read in a partially defined HEC-1 input file and 
finish defining all necessary parameters.  Finally you will run HEC-1 and view 
the resulting hydrographs from within WMS.  The steps covered include the 
following: 

• Reading TIN, Map and HEC-1 data files. 

• Defining gages and precipitation for the watershed. 
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• Defining the SCS loss rate for all basins. 

• Defining a hydrograph method and an equation to compute lag time 
for the basins. 

• Defining the routing parameters from one outlet to the next. 

• Computing geometric attributes. 

• Computing curve numbers (CN) from land use and soil type 
coverages. 

• Creating an HEC-1 input file. 

• Running HEC-1. 

• Reading the TAPE22 hydrograph results file and displaying the 
results. 

• Computing time area curves. 

• Defining elevation zone areas for a snow melt analysis. 

9.2 Reading the Data Files 
A super file will be used to read in the necessary data files. A super file simply 
contains the names of other files that may be components of your project, and 
works best if each component is in the same directory as the super file.  You 
may edit the super file with any standard editor such as Notepad or DOS Edit 
if you find it necessary.  On UNIX operating systems you will undoubtedly 
need to change the directories to match where WMS has been installed. 

The TIN you will be reading is the same one used in the last tutorial, except 
that a stream network and five drainage basins have already been defined.  
Land use and soil type coverages have been defined and saved in a WMS map 
(*.map) file.  An HEC-1 input file will also be read as part of the input so that 
some of the basic input can be predefined.  To read in the file, do the 
following: 

1. If you are continuing from a previous tutorial select New from the File 
menu and confirm that all data should be deleted. 

2. Change to the Hydrologic Modeling module . 

3. Select Open… command from the File menu. 

4. Find and Open the file named “rockyhec.sup”.  By default it should be 
in the tutorial directory. 
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 Once the files are read in you should see the Rocky TIN and two 
polygon coverages. 

5. Select Display Options… from the Display menu. 

6. Turn the display of all entities off. 

7. Select the Drainage tab. 

8. Be sure the display of Outlets, Outlet names, Stream networks, Storm 
gages, Temporal distribution gages, and Drainage basin boundaries are 
all turned on. 

9. Select the OK button.  The display is updated and you should see the 
watershed divided into five sub basins. 

 You may want to move or turn off basin labels as described in 
previous tutorials. 

9.3 Computing Geometric Attributes 
Some of the geometric attributes are not saved as part of the TIN file, therefore 
be sure to compute them each time you wish to define an HEC-1 input file. 

1. Change to the TINs module . 

2. Select the Compute Basin Data… command from the Drainage menu. 

3. Specify Feet for the Model units, Square miles for Basin Areas, and 
Feet for Distances and then select the OK button. 

After the computation, the basin areas will be displayed at the centroids of the 
drainage basins.  If you wish, you can turn these labels off from the drainage 
display options dialog. 

Once computed, basin areas, stream lengths, and stream slopes are 
automatically stored for use in defining the HEC-1 input file.  The flow 
distances and basin slopes computed are used to compute lag times with the 
Tulsa equation. 

9.4 Entering Gages 
The gage method for rainfall will be used in each basin.  To do this you must 
define the gages with their associated precipitation accumulation and 
distribution values.  The table below will aid you in creating the rain gage 
network.  
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Table 7.1.  Gage Information. 
NAME X-Coordinate Y-Coordinate Precipitation 
gage1 10500 25000 1.38 
gage2 18000 12000 1.41 
gage3 35670 7530 1.36 
gage4 35900 23320 1.32 

These gages represent total storm stations, and therefore no temporal 
distributions are associated with them.  After entering these four gages, you 
will be instructed to enter one gage that defines the temporal distribution for 
all four gages.  All of the gages can be entered from within the Gages dialog as 
explained below: 

1. Change to the Hydrologic Modeling module . 

2. Select the Gages… command from the HEC-1 menu. 

3. Select the New button. 

4. Enter the name for the first gage in the name box. 

5. Enter the values of the first gage from the above table. 

6. Select the New button again and define the values for the second gage. 

Continue this process until all four gages have been entered. 

You must now enter one gage that defines the temporal distribution for all of 
the gages: 

1. Select the New button. 

2. Enter the name “gage5” in the name edit box. 

3. Enter the x-y coordinates x=29,000.0 and y=15,400.0. 

4. Click the Storm Total Station check box off. 

5. Click the Temporal Distribution Station check box on. 

6. Enter today's date in the appropriate edit boxes. 

7. Select the Define Series button. 

8. Click on the Import… button found in the lower right-hand corner of 
the dialog box. 

9. Locate and select the file called “scstabls.ser”.  By default it is located 
in the tutorials directory.  A list of six defined rainfall distributions 
will appear in the xy series window. 
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10. Click on the SCS-StandardEmergencySpillway series to make it the 
active xy series.  The plot window will show the distribution for this 
series. 

 The values corresponding to this standard distribution are 
automatically inserted into the text edit fields.  You are free to scroll 
through and examine the values.  You are also free to change the 
distribution according to a pattern of interest to you. 

11. Click on the OK button of both dialogs. 

The storm total stations will be displayed along with the Thiessen network 
made up of the four storm total stations.  The temporal distribution gage is 
displayed in a different color than the other gages, and is not included in the 
Thiessen network since it defines only a distribution and not a storm total.  
Later, as basin data are computed, weights corresponding to the Thiessen 
network will be assigned to each basin. 

9.5 Defining Job Control Parameters 
Each HEC-1 input file must have certain basic parameters defined.  Job control 
data is entered in the following manner: 

1. Select the Job Control… command from the HEC-1 menu.  A dialog 
will appear with several different job control options. 

2. Enter three text strings of your choice in the ID text edit fields.  These 
text fields correspond to the identification cards at the top of the HEC-
1 input file. 

3. Set the computational time interval to 10. 

4. Set the date fields to today's date. 

5. Set the number of hydrograph ordinates to 75. 

6. Click on the OK button to close the dialog. 

9.6 Defining Basin Parameters 
HEC-1 basin parameters that can be defined using WMS include precipitation, 
loss rates, unit hydrograph method, and base flow.  The first set of parameters 
to enter are the loss rates: 

1. Click on the Select Drainage Basin tool . 

2. Choose the Select All command from the Edit menu. 
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3. Select the Edit HEC-1 Parameters… command from the HEC-1 menu.  
You may wish to reposition your windows so that the HEC tree and 
the Edit HEC-1 Parameters can be seen. 

9.6.1 Loss Method 
HEC-1 provides several different methods for performing rainfall loss 
computations.  For this tutorial we will be using the SCS curve number 
method.  The actual curve numbers will not be entered at this time, but will be 
computed from land use and soil type coverages later.  However, you must be 
sure to specify that you want to use the SCS method. 

1. Select the Loss Method button. 

2. Select the SCS curve number (LS) method. 

3. Select OK. 

9.6.2 Unit Hydrograph Method 
Once the loss rate method has been set, you are ready to define the unit 
hydrograph method that will be used for computing the basin hydrographs.  To 
define the unit hydrograph parameters, do the following: 

1. Select the Unit Hydrograph Method button. 

 The dialog you will see provides you with the ability to choose from 
the different unit hydrograph methods available in HEC-1, and then 
define the appropriate value.  The method you will be defining is the 
SCS dimensionless unit hydrograph method. 

2. Click on the SCS dimensionless (UD) method option. 

3. Click on the Compute Parameters – Basin Data button. 

4. Set the computation method to the Tulsa Rural Method. 

 The lag time used in the SCS dimensionless method is a function of 
basin slope and lengths of flow within the watershed.  Since these 
parameters are computed by WMS when computing basin data, the lag 
times can also be computed.  Refer to the user’s manual to see a full 
description of the Tulsa district equation. 

5. Repeat step 4 by selecting each basin listed in the Basin text window 
and assigning the Tulsa Rural Method to it.  

6. Click on the OK button of both dialogs. 
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9.6.3 Precipitation 
The last basin parameter you will enter here is the precipitation.  To enter the 
precipitation parameters, do the following: 

1. Select the Precipitation button. 

2. Choose the Gage(PG) option. 

3. Select the OK button. 

4. Select Done in the Edit HEC-1 Parameters dialog. 

 Weights are assigned automatically using the Thiessen method when 
computing basin data.  In order to make this happen you must compute 
the basin data once again. 

5. Select the TINs module icon . 

6. Select the Compute Basin Data… command from the Drainage menu. 

7. Specify Feet for the Model units, Square miles for Basin Areas, and 
Feet for Distances and then select the OK button. 

9.7 Defining Routing Data 
Routing parameters are defined at outlet points, and they define the reach from 
a given outlet to the next downstream outlet.  Stream lengths and slopes are 
automatically computed and associated with the appropriate outlet when 
computing drainage data from the Drainage menu.  For the example model you 
are working with, you will be defining Muskingum routing for the three outlet 
points in the stream (no routing needs to be defined at the outlet representing 
the watershed outlet).  To define this routing method, do the following: 

1. Change back to the Hydrologic Modeling module . 

2. Select the Select Outlets tool . 

3. Select one of the “upstream” icons,  (not the bottom most outlet).  The 
three “upstream” outlets need to have routing data defined. 

4. Select the Edit HEC-1 Parameters command in the HEC-1 menu. 

5. Choose the Routing Data button. 

6. Select the Muskingum (RM) routing option (be sure it is the 
Muskingum -RM option and not the Muskingum Cunge - RD option). 
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7. Enter a value of .2 for X. 

8. Determine the routing time for this reach by doing the following: 

9. Find the length of the channel (you should be able to see a value for 
length in the Muskingum-Cunge edit field - it will be dimmed but you 
should be able to read it).  

10. Estimate the channel velocity (use 3.0 ft/sec).  

11. Divide the length by the estimated velocity (length/3 = travel time 
seconds)  

12. Divide by 3600 sec/hr to get travel time in hours.  Enter this value for 
AMSKK.  

13. Finally determine how many time steps it will take to route the flow 
through this channel segment and enter the value in the NSTPS field.  
This can be determined by dividing the travel time, in minutes by the 
computational time step entered in the Job Control dialog (10 
minutes). 

14. Select the OK button.  

15. Repeat steps 2-8 for the other two outlets where routing is to be 
defined. 

16. Select the Done button in the Edit HEC-1 Parameters dialog.  

9.8 Computing Composite Curve Numbers 
Besides computing geometric data, composite curve numbers can be 
determined using the land use and soil coverages read in with the model. 

1. Select the Compute GIS Attributes… command from the Calculators 
menu. 

2. Make sure SCS Curve Numbers is selected in the Computation list. 

3. Select Soil type coverage for determining soil type. 

4. Select Land use coverage for determining land use. 

5. Select OK to compute composite curve numbers. 

So that you can be satisfied that lag times and curve numbers (CN) have been 
computed, double click on any one of the basin icons in the Tree window.  
This brings up the Edit HEC-1 Parameters dialog.  You will see the composite 
curve number of the selected basin following the LS record (it is the second 
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number) shown in the HEC-1 cards window.  The lag time computed can be 
seen following the UD card.  Select the other basins and note the differences in 
these two parameters. 

1. Select the TINs module icon . 

2. Select the Display Options option from the Display menu. 

3. Turn on the soil group, soil group legend, land use legend, and land 
use options. 

4. Select OK. 

You should see the different combinations of land use/soil group combinations 
that have been assigned to the TIN. 

9.9 Running and Saving HEC-1 Files 
You have now completed the definition of the HEC-1 model and are ready to 
run the analysis.  HEC-1 is a stand-alone program, but can be launched from 
within WMS using the following steps: 

1. Change to the Hydrologic Modeling module . 

2. Select the Check Model… option from the HEC-1 menu. 

 This will perform a check on the data and try to determine problems 
that should be addressed before HEC-1 can be successfully run.  Just 
because the model checker does not find any errors does not insure 
that HEC-1 will compute the correct result, but it should help. 

3. Select Done. 

4. Select the Run HEC-1… option from the HEC-1 menu. 

 HEC-1 needs the names of three files: 1) the input file (which will be 
saved when running HEC-1).  2) an ASCII output file outlining the 
processes used and the final results.  3) a TAPE22 solution file 
containing hydrograph information that can be read back into WMS for 
display. 

5. Enter rocky in the prefix for all files edit field and click on the Update 
All Prefixes button. 

6. Click OK to start HEC-1. 

The View File command in the File menu can be used to examine the ASCII 
output file should problems occur.  On PC's the view file command brings the 
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file up within the Windows Notepad program, whereas on UNIX operating 
systems you can specify an editor (vi by default) to bring the file up in. 

9.10 Displaying Hydrograph Results 
The TAPE22 file generated by HEC-1, and stored in the third file specified 
when running HEC-1 from within WMS, contains hydrographs for each basin 
of the watershed, for the routed hydrographs from outlet points, and for the 
combination of basin and routed hydrographs at each outlet.  WMS 
automatically reads in the files.  To view the hydrographs: 

1. Select the Show Hydrograph Window from the Display menu. 

You should see several small hydrographs displayed in the upper right corner 
of each outlet and basin in the Hydrologic Modeling window.  You can 
examine the hydrographs in greater detail by selecting them for display in the 
hydrograph window.  Two hydrographs, representing the hydrograph before 
and after channel routing, will be displayed for some of the outlets.  To view 
the hydrographs in the hydrograph window, do the following: 

1. Select one of the hydrographs by clicking on the miniature. 

2. Hold the SHIFT key down while selecting more hydrographs.  All 
currently selected hydrographs should be displayed in the hydrograph 
window. 

3. Select the Display Options… command from the Display menu. 

4. Select the Plot Options… button. 

5. Turn on the Display X grid toggle. 

6. Turn on the Display Y grid toggle. 

7. Set any other parameters you wish to experiment with. 

8. Click on the OK button of both dialogs. 

9.11 Conclusion 
This concludes the tutorial on defining HEC-1 files and displaying 
hydrographs.  The concepts learned include the following: 

• Entering job control parameters. 

• Defining basin parameters such as loss rates, precipitation, and 
hydrograph methodology. 
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• Defining routing parameters. 

• Creating gages and their associated Thiessen networks. 

• Writing HEC-1 input files. 

• Reading hydrograph results and manipulating their display.  





 

10 Time of Concentration Calculations 

CHAPTER 10 
Time of Concentration Calculations 

Estimated Time: 30 minutes. 

Travel times (time of concentration, lag time, and travel time along a routing 
reach) are critical to performing analysis with any of the hydrologic models.  
In this tutorial you will learn about the two different ways WMS can be used 
to compute time of concentration for a TR-55 simulation (lag times are 
computed in the same way):  

• Runoff distances and slopes for each basin are automatically computed 
whenever you create watershed models from TINs or DEMS and compute 
basin data.  These values can then be used in one of several available 
equations in WMS to compute lag time or time of concentration.  

• If you want to have a little more control (and documentation) over the lag 
time or time of concentration, you will use a time computation coverage to 
define critical flow paths.  Time computation coverages contain flow path 
arc(s) for each sub-basin.  An equation to estimate travel time is assigned 
to each arc and the time of concentration (or lag time) is the sum of the 
travel times of all arcs within a basin.  Lengths are taken from the length of 
the arc and slopes derived if a TIN or DEM are present. 

In this tutorial you will compute the time of concentration for the two sub-
basins and the travel time between outlet points in the watershed shown below.  
You will use the TR-55 library of equations, but you could just as easily use 
one of the other pre-defined equations, or enter your own equation. 
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 A=0.10 mi^2 
 A=0.12 mi^2 

 
 Figure 10-1 American Fork Watershed  

10.1 Reading a TIN File 
You will first read in a TIN that has already been processed and used to 
delineate two sub-basins. 

1. Select the TINs module . 

2. Select the Open… command from the File menu. 

3. Find and Open the file named “aftr55.tin”.  By default it should be in 
the tutorial directory. 

4. Select the Compute Basin Data… command from the Drainage menu. 

5. Select Feet for Model units, Square miles for Basin Areas, and Feet 
for Distances. 

6. Select OK. 

7. If the display options for triangles and vertices are on turn them off by 
selecting the Display Options from the Display menu and toggling off 
the check box in front of the Vertices and Triangles display options. 

Your display should now show the basin boundaries and stream network. 

10.2 Defining Flow Path Arcs 
Flow paths can automatically be traced across a TIN (or DEM with flow 
directions computed) using the flowpath tool.  You can take advantage of this 
functionality in WMS to set up your flow path segments. 

1. Select the Map module . 
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2. Select the Coverages… command from the Feature Objects menu. 

3. Set the default coverage type to Time Computation in the Attribute Set 
drop down combo box. 

4. Confirm that you want to change coverage types by selecting OK. 

5. Select the Create Feature Points tool . 

6. Create feature points at the two locations marked by an X in the figure 
below.  Be sure that there is one point inside of each basin boundary. 

 A=0.10 mi^2  A=0.12 mi^2 

x

x

 
Figure 10-2 Starting Locations for Time of Concentration Arcs. 

These points represent the furthest point from the outlet for their respective 
basins.  Now feature arcs will be created from these points to the outlet by 
following the flow path. 

1. Select the Select Feature Point/Node tool . 

2. Select both feature points just created.  Use the SHIFT key to multi-
select (the last point you just created will likely already be selected). 

3. Select the Node->Flow Arcs command from the Feature Objects 
menu. 

4. Choose the Create multiple arcs command. 

5. Select OK. 

The Create multiple arcs option will cause WMS to break the flow path arcs 
once they enter the stream defined on the TIN.  The TR-55 method (others are 
similar as well) uses three different flow segments to compute time of 
concentration: sheet flow (up to 300 feet), shallow concentrated flow, and 
open channel flow.  Since WMS will automatically break the arcs between 
overland and channel flow, two of three segments will already be defined. You 



10-4 WMS Tutorials 

will need to separate the sheet flow from the shallow concentrated flow before 
setting up the equations. 

1. Select the Select Feature Vertex tool . 

2. The figure below identifies locations approximately 200-300 feet 
downstream from the beginning of the flow path arc.  Select one of 
these vertices. 

3. Select the Vertex<->Node command in the Feature Objects menu. 

4. Repeat for the other flow arc (alternatively you could multi-select the 
two vertices and convert them to nodes at the same time). 

 
Figure 10-3 Locations to Break Sheet Flow Segments. 

You should now have three arc segments for each basin.  These arcs will be 
used to compute a time of concentration for the TR-55 analysis.  However, we 
will also want to compute a travel time for the flow from the upper basin to the 
lower basin.  This will require a flow path segment between the upstream 
outlet and the lower outlet.  The flow path arcs from the lower basin already 
include flow for part of this distance, but there remains a segment for which no 
flow path arc exists. 

1. Select the Streams->Flow Arcs command from the Feature Objects 
menu. 

This will create an arc that joins the outlet of the upper basin with the flow 
path segment already created for the lower basin.  Where the flow path 
segments meet the arc from the lower basin is split into two. This will leave 
four arcs to define time of concentration for the lower basin (two will actually 
be in the stream).  The arc just created, while in the lower basin, will not be 
used when computing time of concentration. 
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You have used the Node->Flow Arcs and Streams->Flow Arcs commands to 
automatically generate the flow path segments from flow on a TIN.  Similarly, 
arcs could have been created from flow on a DEM with flow directions, or 

they could be created manually using the create arc tool .  When defining 
arcs manually you must keep in mind that just like stream arcs in the drainage 
coverage, direction is important.  Time computation arcs should be defined 
from downstream to upstream.  

10.3 Assigning Equations to Time Computation Arcs 
With the flow path segments defined you are now ready to assign equations 
that will be used to determine a travel time for the arc.  Use the following 
figure as a guide while defining the equations.  

87

6

5
4

3

2

1

 
Figure 10-4 Time Computation Arcs. 

1. Select the Select Arc tool . 

2. Select the arc labeled 1. 

3. Select the Attributes… command from the Feature Objects menu. 

By default the arc will be a TR-55 sheet flow equation arc, so all you need to 
do is define the overland manning’s roughness coefficient and the 2yr-24hr 
rainfall.  Length and slope will already be defaulted from the selected arc. 

1. Click on the “n Mannings” line in the Variables text window. 

2. Enter a value of 0.24 in the Variable value edit window. 

3. Click on the rainfall line in the Variables text window. 

4. Enter a value of 1.1. 
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You should notice in the Instructions/Results window that you are told what 
variables need to be defined before a travel time can be computed.  Once you 
have entered all the necessary values, this same window reports the travel time 
for this arc.  In this way, you can compute travel time for any arc segment no 
matter what the application is. 

1. Select OK. 

2. Repeat the previous steps for the arc labeled 4.  Use a Manning’s 
roughness of 0.15 and a rainfall value of 1.1. 

3. Select OK. 

You have now defined equations for the overland sheet flow segments in each 
basin and are ready to define the next two arc segments as shallow 
concentrated flow. 

1. Select the arc labeled 2. 

2. Select the Attributes… command in the Feature Objects menu (note 
you could have double-clicked on the arc labeled 2 to bring up this 
same dialog). 

3. Change the equation type to TR-55 shallow conc eqn. 

4. Click on the Paved line in the Variables text window. 

5. Enter “no” in the Variable value edit window. 

6. Select OK. 

7. Repeat for the arc labeled 5, using the same arc type.  In this case set 
the Paved value to yes. 

The remaining arcs will be defined as open channel flow arcs. 

1. Select the arc labeled 3. 

2. Select the Attributes… command in the Feature Objects menu. 

3. Change the arc type to TR-55 Open channel eqn. 

4. Click on the Manning’s n line. 

5. Enter a value 0.016 in the Variable value edit window. 

6. Select the hydraulic radius line in the Variables window. 

7. Select the Hydraulic Radius button to open up the channel calculator 
so that the hydraulic radius can be computed from rough estimates. 
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8. Change the Channel type to Rectangular. 

9. Enter a Longitudinal slope of 0.0015. 

10. Enter a Channel width of 3.0. 

11. Make sure the Enter depth option is chosen and enter a depth of 0.33 
(an approximated depth since we do not know what the flow is at this 
point). 

12. Select the Calculate button. 

13. Select OK for both dialogs. 

You have now defined the necessary parameters for computing travel time 
using the TR-55 open channel flow (Manning’s) equation.  Repeat for the arcs 
labeled 6, 7, and 8 using the following values: 

1. For arc 6 use a Manning’s n of 0.016, and a hydraulic radius of 0.35. 

2. For arc 7 use a Manning’s n of 0.016, and a hydraulic radius of 0.41. 

3. For arc 8 use a Manning’s n of 0.016, and a hydraulic radius of 0.38. 

If you wish you can continue to experiment with the channel calculator to 
compute the hydraulic radius rather than entering the given values. 

You now have defined equations and variable values for each flow path 
segment.  You can change these equations, variables, add new flow path 
segments, etc. in order to determine the best flow paths and most appropriate 
equations for each basin.  In other words, this process is subjective and it may 
take a few iterations to get the best value. 

10.4 Using the Time Computation Arcs to Compute Time of 
Concentration for a TR-55 Simulation 

Before assigning time of concentrations to each basin you need to decide 
which model you want to use.  For this tutorial you will be running TR-55, but 
but the same time computation tools you learn in this tutorial could be used for 
any of the supported WMS models (such as in the TR-20 basin data dialog, the 
HEC-1 Unit Hydrograph method dialog, and the Rational Method dialog). 

1. Select the Hydrologic Modeling module . 

2. Select the Run Simulation command from the TR-55 menu. 
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3. Select the Initialize TR-55 data button (memory to store TR-55 
variables is not allocated in WMS until you initialize a TR-55 
simulation). 

4. Select the Select Basin tool  while the TR-55 dialog is still open. 

5. Select the upper basin. 

6. Change the Curve Number to 70. 

7. Enter a Rainfall value of 1.5. 

8. Change the Rainfall distribution to Type II. 

9. Select the Compute Tc – Map Data button.  You will see the three time 
computation arcs that are in the basin.   

10. You can create a detailed report as a text file if you want by selecting 
the Export Data or Copy to Clipboard buttons. 

11. Select Done and the sum of the travel times for these arcs will be used 
as the time of concentration for this basin. 

Note that you could bring up the time computation attributes dialog and 
change the equation or any of the equation variables by selecting the Edit Arcs 
button.  Now you will set up the TR-55 basin data for the lower basin. 

As a comparison you will now compute the time of concentration using the 
pre-computed runoff distance and slope parameters and one of the equations 
defined in WMS.  To see the values that WMS has computed you will need to 
modify the display options. 

1. Select the Done button to close the TR-55 dialog. 

2. Select the Display Options… command from the Display menu. 

3. Select the Drainage tab. 

4. Toggle on Max flow distance and Max flow slope. 

5. Select OK. 

Notice that the longest flow path distance within a basin is displayed for each 
basin as well as the slope along that flow path.  These are the variables that 
will be used in a separate equation to determine the time of concentration. 

1. Once again select the upper basin. 

2. Select the Run Simulation… command from the TR-55 menu. 
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3. Note that the time of concentration is currently about .57 hours and 
then select the Compute TC - Basin Data button. 

In the Basin Time Computation dialog you can pick from one of several lag 
time or time of concentration equations that are pre-programmed in WMS (see 
the reference manual for a complete description of these equations).  You can 
also create your own equation from the computed variables, or parameters that 
you define yourself.  In this tutorial we will use the Kerby equation for time of 
concentration, but you may wish to experiment on your own with some of the 
other equations or by making your own. 

1. Select the Compute Time of Concentration option from the 
Computation type drop-down box. 

2. Choose the Kerby method for overland flow equation in the drop-down 
list of equations.  Notice that all variables needed for this equation are 
defined and so the time of concentration is reported in the text window 
at the top of the dialog. 

3. Select OK to close the Basin Time Computation dialog. 

You should notice that the time of concentration is very nearly the same as 
before (.57 hours).   

At this point you might be wondering why you would ever want to create a 
time computation coverage and go through the effort of defining travel time 
arcs and assign equations to each if the same value can be determined using 
the parameters already computed from a TIN or DEM? 

1. Select the Compute TC - Basin Data button again. 

2. Select the Kirpich method for overland flow on bare earth equation. 

3. Select OK. 

You should now see that the computed time of concentration is less than half 
of what it was previously.  You should now set the time of concentration back 
to the one originally computed by the flow arc method.  To do this: 

1. Select the Compute Tc – Map Data button. 

2. Select Done.  

The lesson here is the equations using Basin Data work great if you are 
confident the equation represents the same kind of land surface you are dealing 
with.  If not, you are likely better off to define equations along separate flow 
path segments using the Map Data.  Of course, in either case you can 
customize the equations to suit your own needs. 

1. Select the lower basin from the graphics window. 
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2. Change the Curve Number to 80. 

3. Enter a Rainfall value of 1.5. 

4. Change the Rainfall distribution to Type II. 

5. Select the Compute Tc – Map Data button. 

This time you will notice that there are more than three arcs.  This is because 
one of the flow path arcs (the one labeled 8 above) will be used to compute 
travel time between outlets but still is within the lower basin.  Notice that 
WMS defaults its status to inactive.  WMS will try to make the best choice of 
arcs that are used for time of concentration for a basin, but at times you may 
need to set the active/inactive status on your own. 

6. Select Done. 

10.5 Using the Time Computation Arcs to Compute the Travel 
Time Between Outlet Points 

Besides using time computation arcs for computing time of concentration or 
lag time for a basin, you can also use them to compute the routing travel time 
of a channel. 

1. Select the Select Outlet tool  with the TR-55 dialog still open. 

2. Select the upstream outlet (the outlet to the upper basin). 

3. Select the Compute travel time… button in the TR-55 dialog. 

4. Make sure that both of the downstream arcs are active (The active 
status in the dialog is turned on for both). 

5. Note the time of concentration for these arcs.  

6. Select Done 

The time of concentration from the arcs should now appear in the Travel 
time box. 

10.6 More TR-55 
While you were entering the data for each of the two basins you should have 
noticed that instructions are given in the TR-55 data window to let you know 
what must be entered before a peak Q can be determined.  Once you did enter 
all of the data the peak Q was computed and displayed in this same window.  
You can also get help for anything listed in this window. 
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1. Select the Select Basin tool  with the TR-55 dialog still open.  

2. Select the upper basin. 

3. Select the line in the TR-55 data window where the peak Q is 
displayed. 

Notice that the TR-55 equation for computing peak flow is displayed in the 
help window.  You can get help for missing data as well. 

1. Change the Time of concentration to 0.0. 

2. Select the line in the TR-55 data window that instructs you to define a 
time of concentration. 

Now you are told the units for time of concentration as well as the available 
options for determining it. 

1. Reenter the time of concentration by typing in the appropriate value, 
or if you can’t remember use the Compute Tc – Map Data button 
again. 

2. Select the Compute Hydrograph(s) button. 

3. Select Done to close the TR-55 dialog. 

4. Select the Show Hydrograph Window command from the Display 
menu. 

5. Click on the hydrograph icon that is displayed by the upper basin. 

10.7 Conclusions 
This completes the tutorial on using the time computation coverage to compute 
time of concentration and travel times.  In the process you have also learned 
about the TR-55 interface.  You are encouraged to continue experimenting 
with the time computation arcs and the TR-55 options. 
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CHAPTER 11 
National Flood Frequency Program 
(NFF) Interface 

Estimated Time: 20 minutes. 

The National Flood Frequency program developed by the USGS provides a 
quick and easy way of estimating peak flow values and hydrographs at 
ungaged sites.  This data can be used in the design of bridges and culverts, 
flood-control structures, and flood-plain management.  It utilizes regression 
equations that have been developed for each state.  Besides an interface to the 
NFF program, WMS can be used to calculate many of the variables used by 
the regression equations. 

In this tutorial you will use an existing TIN, “rockynff.tin”, and the regression 
equations for Texas.  The TIN allows you to compute basin area and slope, 
each used in the Texas regression equations.  A TIN is not necessary to use 
NFF and you may wish to construct only a tree if you already have values for 
your state's equation variables. 

If you have not licensed the digital terrain and map modules you will need to 
switch to Demo mode by selecting the Demo Version On command in order to 
complete this tutorial. 

If you are not licensed to run NFF, you can still run this tutorial to evaluate the 
interface, and determine of what value it can be for your work.  The demo 
tutorial is subject to the following restrictions: 

1. Texas is the only state available to test. 

2. Only the values specified in the tutorial may be used to do actual 
computations. 
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11.1 Reading a TIN File 
You will first read in a TIN that has already been processed and used to 
delineate a single basin. 

1. Select the TINs module . 

2. Select the Open… command from the File menu. 

3. Find and Open the file named “rockynff.tin”.  By default it should be 
in the tutorial directory. 

11.2 Prepare the TIN to Use With NFF 
The watershed in “rockynff.tin” has previously been prepared for basin 
delineation.  However, you must compute basin data in order to use the 
geometric parameters in conjunction with NFF. 

1. Select Compute Basin Data… from the Drainage menu. 

2. Set Model units to Feet (since the original TIN data is in feet). 

3. Set Basin Areas to Square miles. 

4. Set distances to Feet. 

5. Select OK. 

In order to see the parameters which will be used with the NFF program you 
can turn them on for display. 

1. Select the Display Options… from the Display menu. 

2. Select the Drainage tab. 

3. Turn on the following toggles: Show units, Basin areas, Basin slopes. 

4. Select OK. 

Basin attributes are displayed at the centroid of the basin. 

11.3 Running an NFF Simulation 
The geometric data computed from the TIN has automatically been stored with 
the NFF data.  You can now run a simulation, using the data derived from the 
TIN. 
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1. Select the Hydrologic Modeling module . 

2. Select the Select Basin tool . 

3. Select the basin icon or anywhere within the basin boundary. 

4. Select the Run Simulation… command from the NFF menu. 

Demo users will need to select NFF - Read Simulation…, and choose 
“rockynff.nff”, then select NFF - Run Simulation…, and Texas will be 
automatically loaded. 

The NFF dialog appears. The instruction window at the bottom of the dialog 
indicates the steps that remain to complete the set up of an NFF simulation. 

11.3.1 Choosing a State 
WMS is linked to a database of state-by-state regression variables that are used 
in the NFF program to compute peak flows.  This tutorial will focus on Texas, 
but if you are not running in demo mode you may wish to return at the end and 
test another state. 

1. Select the State button. 

2. Scroll through the states until you see Texas and then select it by 
clicking on it. 

3. Select OK. 

11.3.2 Defining Regions 
The regions with defined regression equations are shown. Scroll through them, 
and notice the available urban equations. For this tutorial, we will assume that 
70% of the study basin is located in Region 2 and 30% in Region 3.  (Refer to 
region maps for your state in the NFF manual to determine if your basin 
overlaps more than one hydrologic region). 

1. Select Region 2 by clicking on it in the regions list window. 

2. Select the button with a right arrow. 

3. Now repeat the last two steps for region 3. 

The variables required by each region's equations are displayed along with a 
defaulted U.S. Maximum Flood Region (the edit field in the upper right 
portion of the dialog), as shown on page 16 of the NFF manual. 
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11.3.3 Assigning Areas to Selected Regions 
The total basin area is supplied by the TIN, but you must assign the amount 
overlapping each hydrologic region.  

1. Select the Assign % Basin Which Overlaps Regions button. 

2. Enter 70 for the Percent area for Region 2. 

3. Enter 30 for the Percent area for Region 3. 

4. Select the Compute Areas From Percents button. 

5. Select the OK button. 

The area variables are updated with the computed values. 

Highlight each of the selected regions and move the mouse over each variable's 
edit field. Examine the help window (you may need to relocate the National 
Flood Frequency Regression Equations for Texas dialog) to see the range of 
values used for each variable in defining the regression equations.  

11.3.4 Defining Regression Variables 
All three of the required variables are now determined. You may overwrite any 
variable values supplied by a TIN if you would like to test your own values.  
Original TIN values may be restored using the Restore Computed Geometric 
Values button. 

11.3.5 Computing Peak Discharges 
You are now ready to compute flow data.  Check the instructions window for 
any items overlooked. 

1. Select the Compute Peak Discharges button.  

Rural peak flows are displayed for the 2 yr - 500 yr storms, along with a 
maximum flood envelope computed using the maximum flood region, as 
defined in the edit field in the upper right.  Predefined standard error is also 
shown, and is considered valid provided that variables were within specified 
range.  If the regions have any equivalent years of data known for the site, 
computed peaks can be weighted with the known values.  You will be 
prompted for weighting if this is possible. 

11.3.6 Exporting Flow Data 
Once flow data is computed it may be exported to a text file in the format 
shown in the window, along with pertinent information used in computing the 
peak flow values. 
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1. Select the Export Flow Data button. 

2. Locate the directory, and define a name for the file. 

3. Select the Save button. 

The exported file can be viewed using any word processor. 

11.3.7 Computing a Hydrograph 
A dimensionless unit hydrograph can be used to define a hydrograph for any 
interval, based on the peak flow.  This hydrograph will be based on the peak 
discharge and basin lag time. 

1. Select the Compute Peak Discharges button.  

2. Select a recurrence interval from the window where computed peak 
flows are reported (select the line of text containing the recurrence 
interval). 

3. With the recurrence interval highlighted, select the Compute 
Hydrograph button. 

4. Select the Compute – Basin Data button. 

5. Select the Espey Rural Method option from the drop down list for 
computing lag time. 

6. Select OK. 

The computed lag time is shown in the lag time edit field.  

1. Select OK. 

2. Select the Done button. 

A hydrograph icon will appear in the Graphics Window.  You can examine the 
hydrograph in more detail: 

1. Select the Show Hydrograph Window from the Display menu. 

2. Select the hydrograph icon in the Hydrologic Modeling Window. 

The hydrograph is displayed and may be manipulated using commands the 
Hydrograph menu. 

When the hydrograph became selected the basin became unselected.  Re-select 

the basin by clicking inside the basin using the Select Basin tool .  If you 
want to see the computed peak flows again you must select the Compute Peak 
Discharges button in the NFF simulation dialog. 
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11.3.8 Saving and Reading Simulations 
You may wish to save this NFF simulation containing a state, selected regions, 
and defined variables.  If you are running a demo version of WMS you should 
skip this step. 

1. Select the Save Simulation… command from the NFF menu. 

The simulation may then be restored at a later date using the Read Simulation 
command in the NFF menu. 

11.3.9 Using the National Urban Equations Defined in NFF 
A national urban regression equation has been defined for use by any state, in 
addition to several equations particular to specific urban areas.  Urban 
equations available for use are identified in the available equations window by 
the “$” symbol for local, and “#” symbol for national.  Local urban equations 
may not be used in conjunction with rural equations, consequentially rural 
equations disappear when a state urban region has been selected.  However, 
the national equation is dependent on computed flows from the corresponding 
rural region, and therefore must be used in conjunction with the appropriate 
rural region. 

To use the National Urban Equation based on the flows you have just 
computed: 

1. If the basin is not selected and the National Flood Frequency 
Regression Equations dialog is not up, select the basin using the Select 

Basin tool , and choose the Run Simulation… command from the 
NFF menu. 

2. Select the #National Urban Equation from the Regional regression 
equations text window. 

3. Click on the right arrow to move it to the Regions overlapped by 
watershed window. 

4. Enter the following values: 

• BDF = 8 

• IA = 45 

• SL =  20 

• RI2 = 1.8 

• ST = 7 

5. Select the Compute Peak Discharges button. 
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Computed urban peak flows are shown along with previously computed rural 
peak flows. You may wish to read pages 8-9 in the NFF manual for further 
information regarding the National Urban Equation. 

11.3.10 Using Individual State Urban Equations Defined in NFF 
The National Urban Equation is common to all states, but some states have 
local urban equations as well (Texas is one of those states).  To use urban 
equations defined for Texas you must unselect all of the regions defined in the 
Regions overlapped by watershed text window.  Available state urban 
equations will reappear, and you can select one for analysis.  NOTE: The 
watershed defined by the TIN is not an urban watershed, but we will 
demonstrate how state-wide urban equations are used with this same data. 

1. Highlight Region 2 in the Regions overlapped by watershed window. 

2. Unselect it by pressing the button with the left arrow. 

3. Repeat the last two steps for Region 3 and #National Urban Equation. 

Scroll down the Regional regression equations text window and notice that 
urban equations have been defined for Houston, Austin, and Dallas. 

1. Select $Dallas as the urban region for analysis by selecting it in the 
Regional regression equations text window and then selecting the 
right arrow. (Notice that all other regions disappear, since they cannot 
be used in conjunction with a statewide urban equation). 

2. Enter 24.60 for A. 

3. Enter 30.0 for UI. 

4. Select the Compute Peak Discharges button. 

Projected peak flows for the Dallas urban basin are shown. 

11.4 Conclusions 
This completes the NFF tutorial for computing rural discharges at ungaged 
sites.  You may select “Done”, or if you are not in demo mode you may choose 
another state for analysis. 
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CHAPTER 12 
Rational Method Interface 

The Rational Method is one of the simplest and best known methods routinely 
applied in urban hydrology.  Peak flows are computed from the simple 
equation:  

 Q kCiA=  

where:  

Q - Peak flow 

k - conversion factor 

C - Runoff coefficient 

i - Rainfall intensity 

A - Area 

In this tutorial you will learn how to solve problems using a digital terrain 
model and the Rational Method. 

12.1 Reading in Terrain Data 
The terrain model used in this tutorial is for a small portion of a city.  The 
elevation data was obtained by digitizing a contour map. 

1. Select the TINs module icon . 

2. Select Open… from the File menu. 
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3. Find and Open the TIN file named “afpts.tin”. 

4. Select the Triangulate command from the TINs menu. 

5. Select the Display Options… command from the Display menu. 

6. Turn off Vertices and Triangles. 

7. Select OK. 

12.2 Creating a TIN for Basin Delineation 
The TIN that has been read in and triangulated will be used as a background 
elevation map for the creation of a TIN that will be used for basin delineation. 

12.2.1 Opening a DXF file 

1. Select the Map module icon . 

2. Select the Import… command from the DXF menu. 

3. Find and Open the file named “af.dxf”. 

12.2.2 Converting DXF Data to Feature Objects 
The DXF data represents a small street network and a boundary for the study 
area.  In order to use the DXF data to help create a TIN it must be converted to 
feature objects. 

1. Select the DXF->Feature Objects command in the DXF menu. 

2. Turn off Feature points from DXF points. 

3. Select OK. 

4. Select the Delete command from the DXF menu. 

5. Confirm that you want to delete the DXF data by selecting OK. 

12.2.3 Preparing the Feature Objects to Create a TIN 
The way line segments are connected in DXF files is often random.  However, 
in order to create a network of stream feature arcs, line segments must be 
connected from downstream to upstream.  WMS can automatically reorder 
feature arcs: 

1. Select the Select Points/Nodes tool . 
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2. Select the point indicated in Figure 12-1. 

 
Figure 12-1 Location of Watershed Outlet Used for Stream Reordering. 

1. Select the Reorder Streams command from the Feature Objects menu. 

Now that the arc segments are properly ordered they can be converted to 
stream arcs.  First, you must make the coverage in which you are working a 
Drainage coverage (right now it is a General coverage). 

1. Select Coverages… from the Feature Objects menu. 

2. Make sure the coverage named “default coverage” is selected in the 
window in the upper left of the dialog. 

3. Select Drainage from the Attribute Set drop-down box in the lower 
right area of the dialog. 

4. Select OK. 

Now that the coverage is a drainage coverage, you are ready to convert the arcs 
to streams and basins. 

1. Select the Select Network tool . 

2. Select any arc that is part of the stream network. 

3. Select the Attributes… command from the Feature Objects menu. 

4. Select Stream. 

5. Select OK. 

6. Select Refresh from the Display menu. 
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12.2.4 Redistributing Arc Vertices 
The vertices along the arcs need to be redistributed in order to create a TIN 
more suitable for basin delineation. 

1. Select the Select Arc tool . 

2. Select the Select All command from the Edit menu. 

3. Select the Redistribute… command from the Feature Objects menu. 

4. Specify the Subdivide each end uniformly option. 

5. Use a specified spacing of 100 (feet in this case). 

6. Select OK. 

12.2.5 Creating the TIN 
1. Select Build Polygon from the Feature Objects menu. 

2. Select OK to use all feature arcs. 

3. Select the Select Polygon tool . 

4. Click anywhere inside the boundary polygon so that it becomes 
selected. 

5. Select the Create TIN… command from the Feature Objects menu. 

6. Select No when asked if you want to save your data. 

7. Make sure the option to Interpolate from existing TIN is selected. 

8. Select OK. 

12.3 Defining Catchment Areas 
Catchment areas need to be defined in order to determine areas.  The computed 
areas will later be used in the Rational Method equation. 

12.3.1 Adding Outlets and Assigning Triangles to Basins 

1. Select the TINs module icon . 

2. Select the Smooth Pits command from the TINs menu. 
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3. Using the Select Vertices tool , and while holding the SHIFT key 
down select the four TIN vertices at the stream branching points 
indicated in Figure 12-2. 

 
Figure 12-2 Location of Outlet Vertices. 

1. Select the Add Outlets command from the Streams menu. 

2. Select the Define Basins command from the Drainage menu. 

Because of the way vertices are connected by triangle edges, there are 
locations where flow splits may occur.  If you receive a message about 
triangles belonging to more than one basin you need to do the following two 
commands. 

1. Select the Correct Split Flow command from the Drainage menu. 

2. Repeat the Define Basins command from the Drainage menu. 

Since basins are defined based on flow from triangle centroids you will need to 
split triangles that straddle basin boundaries.   After refining boundaries you 
will also want to eliminate triangles that do not belong to any of the catchment 
areas. 

1. Select the Refine Boundaries command from the Drainage menu. 

2. Select the Delete Null Basin Triangles command from the Drainage 
menu. 

3. Select OK to verify deletion. 
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12.3.2 Merging Catchment Areas 
By default WMS creates a separate catchment area (basin) for each upstream 
branch of the stream.  However, we only want to consider a single basin 
upstream from the outlet points so we must merge the pairs of adjacent basins 
together. 

1. Select the Display Options… command from the Display menu. 

2. Select the tab labeled Drainage. 

3. Turn off the Stream networks. 

4. Select OK. 

5. Select the Select Basin tool . 

6. Select both basins labeled A in Figure 12-3 while holding down the 
SHIFT key. 

7. Select the Merge Basins command in the Drainage menu. 

 
Figure 12-3 Delineated Catchment Areas Before Merging. 

1. Repeat the last two steps for basins labeled B, C, and D. 

2. Select the Display Options… command from the Display menu. 

3. Select the Drainage tab. 

4. Turn Stream networks back on. 
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5. Turn on Fill drainage basins. 

6. Select OK. 

12.3.3 Defining Basin Data 
Now that the delineation of catchment areas is complete you can compute the 
contributing area (as well as many other parameters) for each. 

1. Select the Compute Basin Data… command in the Drainage menu. 

2. Set the Basin Areas option to be acres. 

3. Select OK. 

12.4 Running a Rational Method Simulation 
The areas computed from the TIN can now be used in setting up a Rational 
Method simulation of the urban development.  Each of the outlet points 
represents an inlet to a storm drain. 

1. Select the Hydrologic Modeling module icon . 

2. Select basin “Basin 5” as labeled in Figure 12-4 by clicking on the 
basin icon inside the basin. 

3. Select the Run Simulation… command from the Rational menu. 

The Rational Method dialog should appear.  While this dialog is up you can 
continue to interact with the menus, tools, and windows of WMS.  As you 
select different basins, the current parameters will be updated in the dialog. 
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Figure 12-4 Final Delineated Basins. 

12.4.1 Defining the Runoff Coefficients and Time of Concentration 
The runoff coefficient, C, is used to account for losses between rainfall and 
runoff.  The more developed a catchment is, the higher the C value it will 
have.  The WMS reference manual contains a table of typical C values for 
different land use conditions. 

1. Enter a value of .60 for C. 

2. Enter a value of 35 for Time of Concentration. 

3. Select the basin labeled “Basin 4” in Figure 12-4 by clicking on its 
basin icon or anywhere inside the basin. 

4. Enter a value of .75 for C. 

5. Enter a value of 14 for Time of Concentration. 

6. Repeat this process for the other three basins, using the table below to 
fill in values for C and tc. 

 
Basin Name Runoff Coefficient C Time of Concentration tc 

Basin 1 .85 22 
Basin 2 .85 20 
Basin 3 .8 18 
Basin 4 .75 14 
Basin 5 .6 35 
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12.4.2 Defining the Rainfall Intensity (i) 
As part of the WMS interface to the Rational Method you can compute IDF 
curves using either HYDRO-35, NOAA, or user defined data.  For this tutorial 
we will use HYDRO-35 data and a recurrence interval of 10 years. 

1. Select “Basin 5” once again. 

2. Select the IDF Curves button from the basin section of the Rational 
Method dialog. 

3. Make sure the HYRO-35 Data (Eastern US) radio group button is 
selected and select the Define Data button. 

4. Enter the following values to define IDF curves using HYDRO-35 
Time (min) Depth (in) 

2 yr. 5 min. .47 
2 yr. 15 min. .97 
2 yr. 60 min 1.72 
100 yr. 5 min. .81 
100 yr. 15 min. 1.75 
100 yr. 60 min. 3.60 

 

1. Select the OK button after correctly entering the rainfall values. 

The IDF curves for the 2, 5, 10, 25, 50, and 100 year recurrence intervals will 
be drawn, and values listed for selected times given in the windows on the 
right of the IDF Computation dialog. 

1. From the text window in the upper right hand part of the dialog click 
on the line of data for the 10-yr recurrence interval as shown in Figure 
12-5. 

2. Select the Refresh icon on the lower right. 
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Figure 12-5 IDF Computation Dialog with the 10-yr Recurrence Interval 

Selected. 

The rainfall intensity is determined from the selected interval by using the 
previously defined value for time of concentration. 

1. Compute i by selecting the Intensity button. 

2. Select the Done button.  The value of i computed using the IDF-
Computation dialog will be placed in the edit field for this basin. 

3. Note also that the input for this basin is complete and a value for 
runoff Q has been computed.  A summary of the rational equation and 
results is in the upper right window of the dialog. 

The HYDRO-35 data only needs to be entered once (unless different data is to 
be used for different basins), so the rainfall intensity for the remaining basins 
can be defined using the following steps. 

1. Select the icon for “Basin 4”. 

2. Select the IDF Curves button. 
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3. Select the line of text for the 10-yr recurrence interval. 

4. Select the Intensity button. 

5. Select Done. 

6. Repeat these steps for Basins 3, 2, and 1. 

12.4.3 Defining Hydrographs 
As the data entry for each basin is completed, a peak flow (Q) is computed and 
listed in the text display window.  The Rational Method equation does not 
produce a hydrograph.  However, several different unit-dimensionless 
hydrographs can be used to distribute the peak flow through time to create a 
runoff hydrograph. 

1. Select the Show Hydrograph Window command from the Display 
menu (unless the hydrograph window is already visible). 

2. Select the basin labeled “Basin 5” in Figure 12-4. 

3. Select the Define Hydrographs… button. 

4. Select the Universal hydrograph method from the drop down list. 

5. Select Done. 

6. Click on the small hydrograph box of Basin 5 in the Graphics window. 

You should see the hydrograph displayed in the Hydrograph Window.  You 
may want resize this window to inspect the chart. 

12.4.4 Combining Runoff from Multiple Basins 
WMS allows you to define lag times (time of travel) in order to compute 
runoff from multiple upstream basins and account for the time of travel 
between sub-basin outlets. Once the lag times have been defined, a single 
runoff hydrograph for the entire watershed can be computed using one of two 
different methods. 

1. Select the Select Outlet tool  . 

2. Select the outlet icon of Basin 5 as shown in Figure 12-4 (be sure to 
select the outlet and not the basin icon). 

3. Enter a value of 5 minutes for the Routing lag time. 

4. Select the outlet icon of Basin 4. 
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5. Enter a value of 5 minutes for the Routing lag time. 

6. Select the next downstream outlet (the outlet icon of Basin 3). 

7. Enter a value of 7 minutes for the Routing lag time. 

8. Select the next downstream outlet. 

9. Enter a value of 6 minutes for the Routing lag time. 

The last or downstream-most outlet does not need to have a Routing lag time 
defined since the hydrograph accumulations will occur at this point. 

1. Select the downstream-most outlet point.  Note the results for this 
outlet and all upstream outlets and basins are displayed in the window 
in the upper right of the dialog. 

2. Select the Define Hydrographs… button. 

3. Choose the Route by summing method. 

4. Choose the Universal hydrograph method. 

5. Select Done. 

6. Select the hydrograph box for the bottom-most outlet. 

7. Inspect the hydrograph displayed in the Hydrograph Window. 

12.4.5 Defining Rainfall Intensities at the Outlet to Compute Runoff 
Hydrographs 
Besides the method of summing hydrographs at an outlet and then lagging to 
the next outlet by the lag time, WMS can also be used to determine composite 
rational method parameters at the outlet for computing hydrographs.  With this 
method, the time of concentration is defined as the longest flow time from 
upstream basins (times of concentration) combined with any lag times from 
channels.  The area is the cumulative upstream area, and the runoff coefficient 
is determined as an area weighted value from the upstream basins.  With the 
time of concentration at the outlet defined you will need to determine the 
appropriate rainfall intensity.  Then instead of summing the upstream 
hydrographs to develop the hydrograph at the outlet, WMS will use the 
rational method equation to compute a peak flow and multiply this peak flow 
by the selected hydrograph method (the same as is done for basins) to 
determine the hydrograph at the outlet.  To do this: 

1. Select one of the upper-most outlet icons in the Hydrologic Modeling 
Tree window. 

2. Select the IDF Curves… button (for outlets). 
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3. Select the line of text for the 10-yr-recurrence interval. 

4. Select the Intensity button. 

5. Select Done. 

6. Repeat these steps for the remaining outlets. 

The last or bottom-most outlet does not need to have a Routing lag time 
defined since the hydrograph accumulations will occur at this point. 

1. Select the bottom-most outlet point. 

2. Select the Define Hydrographs… button. 

3. Choose the Traditional method. 

4. Choose the Universal hydrograph method. 

5. Select Done. 

6. Select Done in the Rational Method dialog also. 

7. Select the hydrograph box for the bottom-most outlet. 

You should get some kind of an idea about the difference in the resulting 
hydrographs from the two methods.  You may want to inspect other 
hydrographs at different locations.  Just click on the box in the Graphics 
Window to do so. 

12.5 Adding a Detention Basin 
If you compute runoff using the route by summing method then you can route 
hydrographs through detention basin structures defined at any of the outlet 
locations. 

1. Select the outlet that defines Basin 5 in Figure 12-4. 

2. Select the Run Simulation command from the Rational menu. 

3. Select the Define Reservoir button. 

You will now define a hypothetical detention basin facility from approximate 
geometric parameters.  WMS can compute a storage capacity curve for a 
rectangular basin.  You could also use a TIN to develop a storage capacity 
curve if the TIN had sufficient resolution to accurately define the storage-
depth relationship.  Further, you could enter a pre-computed storage capacity 
curve. 
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4. Select the Define… button in the Storage Capacity box. 

5. Select the Known Geometry option. 

6. Enter 500 feet for Length. 

7. Enter 500 feet for Width 

8. Enter a Depth of 30 feet. 

9. Enter a Side slope of 2 

10. Leave the Base elevation at 0.0 (It will be assumed on-grade at the 
outlet location). 

11. Select OK. 

You will now define a standpipe and spillway (weir) for outlet structures and 
WMS will compute the elevation-discharge relationship automatically.  In 
addition to standpipes and weirs you can define low-level outlets, or you can 
enter a pre-computed elevation-discharge relationship. 

1. Select the Define… button in the Elevation Discharge box. 

2. Select the Discharge Structures option. 

3. Select the Add Standpipe button. 

4. Set the Pipe diameter to 4 feet. 

5. Set the Standpipe elevation to 15 feet. 

6. Select the Add Weir button. 

7. Set the Weir width to 20 feet. 

8. Set the Weir elevation to 25 feet. 

9. Select OK. 

10. Select OK. 

You have now defined a detention facility that has a standpipe and a spillway 
for control structures.  The incoming hydrograph to this outlet point will be 
routed through the detention facility before being routed downstream and 
combined with the hydrographs of other basins. 

1. Select the bottom-most outlet point. 

2. Select the Define Hydrographs… button. 
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3. Choose the Route by summing method. 

4. Choose the Universal hydrograph method. 

5. Select Done. 

6. Select the hydrograph box for the bottom-most outlet. 

12.6 Conclusions 
In this tutorial you have learned some of the options available for using the 
rational method in WMS.  You will want to continue experimenting with the 
different options so that you can become familiar with all the capabilities in 
WMS for doing Rational Method simulations. 





 

13 Drainage Calculation Tools 

CHAPTER 13 
Drainage Calculation Tools 

Estimated Time: 30 minutes 

Several drainage calculation tools are included in WMS to aid in analysis and 
design of hydraulic structures.  These tools include a Channel Calculator, a 
Weir Calculator, a Detention Basin Calculator, a Curb and Gutter Calculator, 
and an interface to HY-8, a culvert analysis program. 

13.1 Channel Calculator 
The channel calculator can use information (hydrographs) determined from a 
hydrologic model to design a channel capable of supporting a given flow.  It 
may also be used to find stage depth in an existing channel or in a natural 
cross-section.  An example of both of these scenarios will be given in this 
section.  

13.1.1 Using the Channel Calculator with Hydrologic Model Results 
In this section of the tutorial, we will use the results from a HEC-1 simulation 
to demonstrate the functionality of the channel calculator. 

1. Select the Hydrologic Modeling module icon . 

2. Select Open HEC-1 File… from the HEC-1 menu. 

3. Find and Open the file named “redri.hc1”. 

4. Select Open… from the Hydrographs menu. 
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5. Find and Open the file named “redri.sol”. 

6. Select Show Hydrograph Window from the Display menu. 

7. Select the hydrograph corresponding to the outlet “RED30” in the 
Hydrologic Modeling window. 

The hydrograph for the outlet point RED30 is now displayed in the 
Hydrograph window. 

1. Bring up the Channel Calculations dialog by going to the Calculators 
menu and selecting Channels…. 

Note the channel geometry options on the left side of the dialog.  You may 
want to click through them and note the different parameters required for each.  
The trapezoidal channel option will be used for this tutorial.  To set up the 
channel calculator follow these steps: 

1. Select the Trapezoidal channel type. 

2. Enter 1.5 in the edit fields for Side slope 1 and Side slope 2. 

3. Enter 5.0 in the Channel width box. 

4. Enter 0.001 for Longitudinal slope and 0.02 for Manning's roughness. 

5. Make sure Enter flow is selected above the channel diagram; note that 
the maximum flow from the hydrograph selected above appears in the 
edit field. 

6. Select Calculate. 

The calculated values for several channel parameters will appear on the left 
side of the dialog.  It may be useful to experiment with different channel 
shapes to determine the channel that would best fit the given circumstances.  
For example, you may want to try calculating the flow using a rectangular 
channel with a depth of 12 feet.  When done experimenting, select OK to close 
the calculator. 

13.1.2 Using the Channel Calculator with Cross-Section Data 
In this section, you will learn how to use WMS to create a cross section of a 
natural channel, then use the Channel Calculator to find stage (depth) in that 
channel. 

The cross section you will create is located immediately downstream from 
Deer Creek Dam, Utah.  To create this cross section: 

1. Select New from the File menu. 
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2. Confirm that you want to delete everything. 

3. Select the Map module icon . 

4. Select Open… from the File menu. 

5. Find and Open the “deercrk.sup” from the tutorial directory. 

This will read in and display a contoured DEM.  You will note a red line in the 
lower right of the DEM representing the location of Deer Creek Dam.  By 
tracing that line with a cross-section arc, you will be able to create a natural 
channel cross-section. 

1. Select Coverages… from the Feature Objects menu. 

2. In the Coverages dialog, click on the New button to create a new 
coverage (data layer). 

3. Enter “Cross Sections” in the Name box to rename the coverage. 

4. Select Cross-Section from the Attribute Set field. 

5. Click on OK. 

You now have an active cross-section coverage.  Any arcs created in this 
coverage will represent cross sections and will derive station and elevation 
information from the DEM or TIN in WMS.  To create the cross section at the 
dam: 

1. Select the Create Arc tool . 

2. Create an arc parallel to the red line representing Deer Creek Dam on 
the DEM.  Click to start at one end, click several times (9-10 times) as 
you proceed to the other end, double-click to end.  Your arc should 
look similar to Figure 13-1. 
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Figure 13-1 Cross section at Deer Creek. 

Upon creating a cross section arc, WMS interpolates station and elevation data 
to the cross section.  To view and/or change this information: 

1. Select the Select Arc tool . 

2. Double-click on the cross section arc to bring up the Cross Section 
Editor dialog. 

In this dialog, you will see a profile plot of the cross section arc.  You will also 
see the station and elevation for each point (vertex) along the arc.  Note also 
that a Manning’s roughness value may be set for each section of the arc. 

You need not change any values in this dialog, but you may want to 
experiment with the Z-scale option to view the cross section at a different Z-
scale. 

3. Enter “Deer Creek” in the Cross section name box. 

4. Click OK. 

You are now ready to use the Channel Calculator to analyze the Deer Creek 
cross section. 

1. Select the Hydrologic Modeling module icon . 
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2. Select Channels… from the Calculators menu. 

3. In the Channel Calculations dialog, select Cross Section from the 
Channel type drop-down box. 

4. Make sure that “Deer Creek” is the cross section selected in the Cross 
section drop-down box. 

Note that the cross section is plotted in the window in the lower right of the 
dialog.  This plot may be exaggerated in the Z direction for better visualization 
if desired. 

You will now determine the stage in the channel given the maximum spillway 
and outlet capacity (12,000 cfs) of Deer Creek Dam. 

1. Select the Enter flow option in the upper right of the dialog.  Enter 
12000 in the corresponding box. 

2. Ensure that English is selected in the Units box. 

3. Enter 0.001 in the Longitudinal slope box. 

4. Click Calculate. 

Note in the window on the left of the dialog, the results of the calculation are 
shown.  The depth in the channel should be around 6 feet, which is acceptable 
for this channel.  Note that a blue line representing the water surface elevation 
is plotted in the window in the lower right of the dialog.  You may want to 
change the Z scale to view the plot better. 

This concludes the section on using the Channel Calculator.  However, you 
may continue to experiment with different flows, depth, or channel types.  

13.2 Weir Calculator 
The weir calculator can be used to find the head over a weir at a given flow or 
the flow over a weir given a head value.  The following section will 
demonstrate how to set up such a calculation.  Following on the last example 
of Deer Creek Dam, you will find out how much head is on the spillway at 
peak capacity. 

13.2.1 Using the Weir Calculator 
1. Select Weirs... from the Calculators menu. 

2. On the left side of the dialog, look at the options available and select 
the Broad-crested weir.  Note that in the lower left corner, a default 
weir coefficient for this weir type appears in the Weir Coefficient edit 



13-6 WMS Tutorials 

field.  This value is a generally accepted coefficient for this weir type, 
but may be edited. 

3. Select Calculate head in the lower right of the dialog. 

4. Enter 12000 in the Weir Flow box. 

5. Enter 42.0 for the Weir length. 

6. Select Calculate. 

Note the answer for the head is located in the lower right corner of the dialog 
box (about 20 feet).  It may be useful to experiment with different weir types 
to see how they affect the head passing over the weir.  For example, try a 
Cipolletti with the same flow.  It may also be of interest to calculate a flow 
using a given head.  Using the same weir type, select Calculate Flow and enter 
head of 10.0.  Select Calculate again to see the flow that would cause a 10.0 ft 
head over the weir.  Select OK to close calculator. 

13.3 Detention Basin Calculator 
The detention basin calculator may be used as purely a design tool or it may be 
used to determine the effects of a reservoir in a drainage unit.  Storage capacity 
curves and/or outflow hydrographs may be calculated using this tool.  In this 
example, the detention basin calculator will be used to find the effects of a 
reservoir created in a drainage unit. 

13.3.1 Opening a TIN file 
1. Select New from the File menu. 

2. Confirm that you want to delete everything. 

3. Select the TINs module icon . 

4. Select Open… from the File menu. 

5. Find and Open the file named “aspencal.tin”. 

13.3.2 Creating a Reservoir 
We will create a reservoir to define detention basin geometry. 

1. Select the Select TIN Vertices tool . 

2. Select the downstream most outlet of the TIN. 
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3. Select Create Reservoir… from the Streams menu.  The Reservoir 
dialog will appear. 

4. Enter 6190.0 in the Water surface elevation edit field, then click on the 
feet radio button. 

Note that at the top of the dialog, the Current model units are shown to be 
meters; by clicking on the feet radio button, you have indicated that the 
value you have entered is in feet and that WMS will need to convert this 
value to be consistent with the model units when doing computations.  The 
option to select which units you are entering allows you to work with 
whichever units you desire. 

5. Make sure the Create Reservoir toggle is on, and then select the 
Create Storage Capacity toggle. 

6. Enter 10 for the number of divisions.  

7. Select the English units (acre-ft) radio button.  This will instruct WMS 
to create a storage capacity curve of acre-ft versus feet.  The storage 
capacity units options are meant to allow you to work with units that 
you are most familiar. 

8. Select OK. 

You will see the Detention Basin Hydrograph Routing dialog come up with a 
plot of your storage capacity curve.  You will now need to open a hydrograph 
file to get the inflow to the reservoir. 

9. Select OK in the Detention Basin Hydrograph Routing dialog. 

10. Select Yes to recompute basin data. 

11. Select OK to accept the defaults in the Units dialog. 

13.3.3 Opening the Hydrograph File 
An inflow hydrograph, to be used in conjunction with the detention basin 
geometry, must also be imported for detention basin calculations.  

1. Select the Tree module icon . 

2. Select Open… from the Hydrographs menu. 

3. Find and Open the file named “aspencal.sol”. 

4. Select Show Hydrograph Window from the Display menu. 
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Hydrographs will appear on the TIN.  Select the hydrograph corresponding to 
the lowest outlet on the tree, where the reservoir was created.  It will appear in 
the Hydrograph window. 

13.3.4 Using the Detention Basin Calculator 
Now that a reservoir has been created and the hydrograph has been selected, 
the Detention Basin calculator may be opened again.  

1. Select Detention Basins… from the Calculators menu. 

The storage capacity curve should now be plotted in the dialog.  To change the 
format of the plot, you can click on the Plot Options button.  You may then 
format the plot as desired.  If a hard copy of the curve is needed, the Print 
button will allow you to print to a file or to a printer. 

The next step is to define a discharge relationship for the reservoir: 

2. Select the Define… button from the Elevation Discharge area on the 
right side of the Detention Basin Hydrograph Routing dialog. 

3. Select the Discharge structures option. 

4. Select the Add Weir button; this will add a spillway-type discharge 
component. 

5. Enter 10.0 in the Weir width box. (This represents the width of the 
spillway). 

6. Enter 3.367 in the Weir coefficient box (typical for a Cipolletti weir). 

7. Enter 6185.0 in the Weir elevation box. 

8. Select the Add Outlet button; this will add a low-level outlet discharge. 

9. Make sure the outlet is selected in the Discharge structures window. 

10. Enter 50.0 in the Outlet area box. 

11. Enter 6100.0 in the Outlet elevation box. 

12. Click OK. 

You should now see an elevation-discharge curve plotted in the Detention 
Basin calculator. You are now ready to perform the hydrograph routing 
through the reservoir. 

1. Click on the Compute Outflow Hydrograph button. 
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You should now see the routing hydrograph plotted on top of the original 
hydrograph in the Hydrograph Window.  Note that the reservoir has cut the 
peak off the hydrograph and lengthened it.  You may want to experiment with 
different initial storage values (between 0.0 and 200.0) to see how that might 
affect the outflow hydrograph. 

13.4 Culvert (HY-8) Calculator 
In this section you will learn how to design a culvert using the Federal 
Highway Administration Culvert Analysis computer program HY8. The 
following example will guide you through the interface that permits easy data 
entry, editing and computation.  

Problem Statement  

Given the following site conditions, find a reinforced concrete box culvert that 
will pass the 50-year flow rate of 400 cfs with a design headwater elevation of 
195 ft and with a maximum discharge of 500 cfs. 

The natural stream channel consists of a main channel in rock having a 
Manning’s roughness of 0.03 and overbanks having a roughness of 0.08. The 
channel is on a 5% slope. A typical cross-section is shown below: 

Left Overbank Right OverbankMain  Channel

n = 0.08 n = 0.08n = 0.03

1

2 3

4 5

6 7

8

 
Figure 13-2 Sample cross section. 

The cross-section can be described by the following coordinates: 

Horizontal Station (ft) Elevation (ft) 

12 180 
22 175 
32 174.5 
34 172.5 
39 172.5 
41 174.5 
51 175 
61 180 

The roadway profile near the culvert is a sag vertical curve. The road is paved, 
with an embankment width of 50 ft. The following is a list of coordinates that 
describe the vertical curve: 
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Horizontal Station (ft) Elevation (ft) 

0 199.2 
100 197.5 
200 196.5 
300 196.0 
360 196.0 
400 196.2 
500 197.0 
600 198.5 
720 201.0 

A profile of the culvert with the culvert invert data is shown below: 

Sta: 100 Sta: 400

Elev: 172.5

Elev: 187.5

Elev: 195.0

Elev: 196.0

U

D
So = 0.05 ft/ft

 
Figure 13-3  Culvert profile. 

As an initial size, estimate a 5’x5’ box concrete culvert, assuming a 
conventional inlet with 1:1 bevels and 45 degree wingwalls. 

13.4.1 Entering Culvert Information 
1. Select the HY8 Culvert Analysis… command from the Calculators 

menu. This will bring up the HY8 Culvert Analysis dialog. 

2. Change the Discharge data, minimum to 0.0, maximum to 500 and 
design to 400. 

3. Click on the Create/Edit culvert data… button. This will bring up the 
HY8 Culvert Data dialog. 

4. Make sure that the Culvert invert data option is selected. 

5. Enter culvert data for upstream. Change Station to 100 and Elevation 
to 187.5. 

6. Enter culvert data for downstream. Change Station to 400 and 
Elevation to 172.5. 

7. Choose Box-Concrete from Culvert Shape selection list. 
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8. Change Span to 5 and Rise to 5. 

9. Accept the default Number of barrels i.e. 1. 

10. Accept the default Manning’s n, which would be 0.012. 

11. Click on the Inlet data… button. This will bring up the HY8 Culvert 
Inlet dialog. 

12. Choose Conventional inlet type. 

13. Choose 1:1 Bevel (45 deg. flare):Wingwall from the Inlet Condition / 
Edge selection list. 

14. Click on the OK button to close the HY8 Culvert Inlet dialog. 

15. Click on the OK button to close the HY8 Culvert Data dialog. 

13.4.2 Entering the Tailwater Channel Information 
1. Click on the Create/Edit tailwater data… button. This will bring up 

the HY8 Tailwater Data dialog. 

2.  Select the Irregular channel rating curve option. 

3. Click on the Irregular channel… button to specify the irregular 
channel properties. This will bring up the HY8 Irregular Channel 
dialog. 

4. Change Channel slope to 0.05. 

5. Change Number of cross-section coordinates to 8. 

6. Choose Lt_Rt over banks and main channel as the Subchannel option. 

7. Change Left overbank coordinate to 3. 

8. Change Right overbank coordinate to 6. 

9. Change Manning’s roughness for Left section to 0.08. 

10. Change Manning’s roughness for Main section to 0.03. 

11. Change Manning’s roughness for Right section to 0.08. 

12. Click on the Define/Edit Cross-Section… button to specify the 
irregular channel geometry. This will bring up the Cross Section 
Editor dialog. 
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13. Enter 8 pairs of station-elevation values. The values are (12, 180), 
(22, 175), (32, 174.5), (34, 172.5), (39, 172.5), (41, 174.5), (51, 175), 
and (61, 180). 

14. Click on the OK button to close the Cross Section Editor dialog. 

15. Click the View rating curve data… button to compute the rating curve 
and display the information. 

16. Select Done. 

17. Click the Save tailwater file button to bring up the file manager. 
Specify “hy801.tw” as the file name and save the file. 

18. Click on the OK button to close the HY8 Irregular Channel dialog. 

19. Click on the OK button to close the HY8 Tailwater Data dialog. 

13.4.3 Entering the Roadway Information 
1. Click on the Create/Edit roadway data button. This will bring up the 

HY8 Roadway Data dialog. 

2. Choose Irregular profile option. 

3. Change the Number of coordinates to 9. 

4. Change the Roadway top width to 50. 

5. Click on the Profile… button to specify the irregular roadway profile. 
This will bring up the Cross Section Editor dialog. 

6. Enter 9 pairs of station-elevation values. The values are (0, 199.2), 
(100, 197.5), (200, 196.5), (300, 196.0), (360, 196.0), (400, 196.2), 
(500, 197), (600, 198.5) and (720, 201.0). 

7. Click on the OK button to close the Cross Section Editor dialog. 

8. Choose Paved roadway surface. 

9. Click on the OK button to close the HY8 Roadway Data dialog. 

13.4.4 Performing Culvert Analysis 
The data already entered in the previous sections must be saved in order to 
perform any computation. 

1. Click on the Save input file button. This will bring up the file manager. 
Specify “hy801.inp” as the file name and save. 
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2. Choose Full Flow option for Outlet control. 

3. Choose Single culvert output table for computation. 

4. Click on the Compute button. 

5. Click on the View button to display the result. 

In the result, find the headwater elevation at 400 cfs and compare with the 
design value of 195 feet. It may turn out that the 5’x5’ culvert is inadequate for 
the site conditions. You are encouraged to test with different sizes, suppose a 
6’x6’ culvert or larger in order to determine the required culvert size. 

13.5 Conclusions 
This tutorial has demonstrated the basic functionality of the drainage 
calculators in WMS.  Design and/or modeling of channels, weirs, detention 
basins, and culverts are possible using these calculators. 
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CHAPTER 14 
Flood Plain Delineation 

Estimated Time: 25 minutes. 

In addition to drainage basin analysis, WMS also contains flood plain 
delineation features that can be used to define flood plain boundaries on any 
TIN.  Flood plains are delineated from stage values that are entered at various 
locations on a TIN.  Stage values are defined as the difference between the 
flood water surface elevation and the normal TIN elevation. 

This tutorial will guide you through the steps for entering, saving, and reading 
stage values from a file.  It will also show how to delineate flood plains from 
stage values, adjust the flood plain delineation parameters, and save or read 
stage values from a file 

14.1 Delineating Flood Plains 
In this tutorial you will learn the steps for entering stage values at points on a 
TIN and then how to delineate the flood plain boundary represented by these 
stage values.  The topics covered include the following: 

• Editing the stage value at TIN vertices. 

• Reading stage values from a file. 

• Using the Interpolate Stage command. 

• Delineating a flood plain from TIN stage values. 

• Comparing stream-based and flat flood plain delineation. 
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• Changing the flood plain delineation parameters. 

• Saving and reading stage values to and from files. 

14.2 Editing Stage Values 
To begin editing stage values, do the following: 

1. Select the TINs module icon . 

2. Select Open… from the File menu. 

3. Locate and select the file called “ding.tin”.  It is located in the tutorial 
directory by default. 

4. Select the Display Options… command from the Display menu. 

5. Be sure that Triangles, Vertices, and Boundaries are toggled on, and 
everything else is off. 

6. Select the Drainage tab. 

7. Make sure that the display of Outlets and Stream networks are on. 

8. Select OK. 

With the TIN file read in and the display of vertices and stream networks on, 
you are ready to define stage values on the TIN.  Stage values can be defined 
by selecting vertices on the TIN and entering a stage value, as shown by the 
following example: 

1. Click on the Select Vertices  tool. 

2. Click on the outlet of the stream network.  By default, outlets are 
displayed as a black circle with a yellow center. 

3. Select the Edit stage… command from the Flood menu. 

4. Enter the value 4.0 in the Enter new vertex stage field. 

5. Select OK. 

6. While holding the SHIFT key down, select four or five additional 
vertices on the stream. 

7. Select the Edit stage… command from the Flood menu. 

8. Enter the value 3.5 in the Enter new vertex stage field. 
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9. Select OK. 

For each stream node that was given a stage value, a vertical red bar will be 
drawn with a length proportional to the stage value at that node. 

14.3 Interpolating Stage Values 
When stage values are defined at locations on a stream, stage values for other 
locations on the stream can be linearly interpolated.  By editing the stage 
values at the outlet and branching nodes, we have entered stage values for 
points that are on the stream network. 

1. Select the Interpolate Stage command from the Flood menu. 

The interpolated stage values for stream nodes that lie between stream nodes 
where stage was defined will now be displayed with a pink bar.  Note that this 
interpolation can only be applied to stream nodes that lie along a stream 
between two stream nodes where stage has been defined. 

14.4 Flood Display Options 
A display option can be set to view both fixed and interpolated stage values by 
following these steps: 

1. Select the Display Options… command from the Display menu. 

2. Select the Flood tab. 

3. Turn on the display of Fixed stage, Fixed stage values, Interpolated 
stage, and Interpolated stage values and make sure everything else is 
off. 

4. Click on the OK button. 

This allows you to check the values that will be used in the delineation of the 
flood plain.  If any value is incorrect, that node can be selected and the stage 
value edited as described above. 

With display of both fixed and interpolated values, it is often hard to read all 
of the stage values since the values overlap each other.  The zoom tool can be 
used to inspect the values on the stream a portion at a time.  Additionally, 
viewing the display of fixed and interpolated values separately may eliminate 
the overlapping problem. 

The flood display options dialog box allows many additional changes to be 
made in the display of the stage values, including line thickness, style, and 
color.  This can be done by clicking on the color box next to each display 
option.  The relative height of the stage bars in terms of # of pixels/unit of 
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stage value can also be changed.  You are encouraged to experiment with these 
parameters until you feel comfortable with the different display options that 
are available to you. 

14.5 Delineating Flood Plains 
Once stage values have been defined on a TIN, you are ready to delineate the 
flood plain.  To delineate the flood plain, do the following: 

1. Select the Display Options… command from the Display menu. 

2. Select the Flood tab. 

3. Turn off the display of Fixed and Interpolated stage values. 

4. Select OK. 

5. Select the Delineate Flood command from the Flood menu. 

The flood plain was delineated using the stage values found at the stream 
nodes where stage values were input, or stages that were interpolated along the 
stream.  Using streams to help define the flood plain gives the best results.  In 
order to be able to perform stream-based flood plain delineation, WMS must 
have at least two stream nodes with defined stage values.  If there are vertices 
on a stream without stage values defined and no downstream stream vertex has 
a defined stage value, no stage values for these stream nodes can be 
interpolated.  The closest upstream stage value is assumed to represent the 
water surface elevation for the downstream remainder of the TIN.  To see an 
example of this effect, do the following:  

1. Select on the Select Vertices  tool. 

2. Click on the outlet of the TIN (black circle with yellow center). 

3. Select the Remove Stage command from the Flood menu. 

4. Select the Delineate Flood command from the Flood menu. 

The flood plain will look similar to the previous flood plain, except for the 
plain for the portion of the stream near the outlet is omitted. 

14.6 Reading and Saving Stage Files 
Stage values can be saved to and read from files. 

1. Select the Remove Stage command from the Flood menu.  Confirm 
that all stage values will be removed. 
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2. Select the Read Stage… command from the Flood menu.  Locate and 
Open the file called “ding.stg”. 

Stage values that you define can be saved to a file using the Save Stage 
command in the Flood menu. 

14.7 Reading a Super File with Pre-Defined Flood Files 
The “blackriv.sup” file is a WMS super file that contains a TIN file, a stage 
file, and a map file.  The TIN is a portion of a watershed in the western 
Adirondack Mountains.  The stage file contains several key locations along the 
Black River for which stage is known during a flood event.  This file can be 
read in by doing the following: 

1. Select the New command from the File menu. 

2. Confirm that you want all data deleted. 

3. Select the Open… command from the File menu. 

4. Using the file browser find and Open the “blackriv.sup” file. 

5. Select OK to confirm that the drainage coverage will be read in as a 
generic coverage.   

This model shows a basin delineation of the Black River in northwestern New 
York on the western slopes of the Adirondacks.  The polygon identified as the 
flats is subject to flooding during spring runoff.  A separate, more detailed TIN 
of the flats was created and used for flood plain delineation.  To see this TIN: 

1. Select the New command from the File menu. 

2. Confirm that you want all data deleted. 

3. Select the Open… command from the File menu. 

4. Using the file browser find and Open in the “flood.sup” file. 

5. Select OK to confirm that the drainage coverage will be read in as a 
generic coverage. 

In addition to the TIN, a map file is read in which shows the main channel as 
well as major roads and railroads in the flood plain.  Once the flood plain has 
been delineated you will be able to see the portions of the road and railroad 
endangered by the high waters. 

1. Select the Delineate Flood command from the Flood menu. 
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14.8 Display Options 
So far, only an outline of the flood plain has been shown.  Besides drawing the 
boundary you can also have the flood plain filled with a solid color or 
contoured according to depth. 

1. Select the Display Options… command from the Display menu. 

2. Select the Flood tab. 

3. Turn on the Flood plain color filled option. 

4. Select OK. 

Besides showing the extents of the flood plain, you can also display it using 
contours. 

1. Select the Display Options… command from Display menu. 

2. Select the Flood tab. 

3. Turn off the Flood plain color filled option. 

4. Turn off the Fixed stage and Interpolated stage options. 

5. Turn on the display option for Flood plain contours. 

6. Select the Contours… button to access the Contour Options dialog. 

7. Make sure the Color fill between contours is turned on. 

8. Select OK. 

9. Select OK. 

14.9 Conclusions 
This concludes the flood plain delineation tutorial.  You are encouraged to 
experiment with all of the commands explained in this section until you feel 
comfortable with the tools available to you for delineating flood plains. 
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CHAPTER 15 
Computing Curve Numbers 

Estimated Time: 45 minutes. 

One of the most important parameters to compute when running a hydrologic 
simulation is the curve number or runoff coefficient for a basin.  Besides being 
one of the most sensitive parameters, the curve number is also one of the most 
difficult parameters to compute.  Fortunately, WMS has tools that make 
computing curve numbers for a basin a simple task. 

This tutorial will outline the different methods that can be used to compute 
composite curve numbers for delineated drainage basins and sub-basins.  First, 
curve numbers will be computed for a drainage coverage using a land use grid 
and a soil type grid.  Next, curve numbers will be computed for a drainage 
coverage using a land use polygon coverage and a soil type grid.  Finally, 
curve numbers will be generated for a TIN using a land use polygon coverage 
and a soil type polygon coverage. 

In addition to computing composite curve numbers, WMS also computes 
composite runoff coefficients for delineated basins and sub-basins.  The final 
section of this tutorial will show how composite runoff coefficients can be 
computed for a drainage coverage using gridded soil data. 

15.1 Computing Composite Curve Numbers 
In this tutorial, you will learn how to compute composite curve numbers using 
several different methods.  The topics covered include the following: 

• Reading in a land use grid. 
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• Reading in a soil type grid. 

• Reading in and defining sub-basins in a drainage coverage. 

• Importing a land use table. 

• Computing curve numbers for a drainage coverage. 

• Reading in a land use polygon shapefile. 

• Computing curve numbers for a drainage coverage using a land use 
polygon coverage and a soil type grid. 

• Reading in a soil type polygon shapefile. 

• Reading in a TIN with defined sub-basins. 

• Computing curve numbers for a TIN using a land use polygon 
coverage and a soil type polygon coverage. 

15.2 Reading a Land Use Grid 
Arc/Info and GRASS ASCII grids can be read into WMS.  These grids can 
either represent land use or soil type.  The first step in computing composite 
curve numbers for a drainage coverage is to read in a land use grid: 

1. Select New from the File menu. 

2. Confirm that you want to delete everything. 

3. Select the Import… command from the File menu. 

4. Select DEM Attribute (*.*) from the Files of type field. 

5. Find and Open “asplugrd.asc”. 

This will open the DEM Attributes dialog, which allows you to assign 
attributes to the data that you import. 

1. Select the Land use option for the Attribute. 

2. Select Arc/Info for the File type, and select the OK button. 

3. Wait a few seconds while the land use grid is being displayed on your 
screen. 
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15.3 Reading in a Soil Type Grid 
The next step is to read in a soil type grid.  Soil type grids in Arc/Info or 
GRASS ASCII format can be read into WMS.  In this section, you will read in 
an Arc/Info ASCII soil type grid prepared from polygon data for the Aspen 
Grove watershed. 

1. Select the Import… command from the File menu. 

2. Select DEM Attribute (*.*) from the Files of type field. 

3. Find and Open “aspsogrd.asc”. 

4. Select Soil type for the Attribute. 

5. Select Arc/Info for the File type, and select the OK button. 

6. Wait a few seconds while the soil type grid is being displayed on your 
screen. 

15.4 Reading in and Defining Sub-basins in a Drainage Coverage 
The next step is to define your model or read in an existing model. 

1. Select the Open… command from the File menu. 

2. Select Super Files (*.sup) from the Files of type field. 

3. Select and Open “aspencn.sup”. 

15.5 Importing a Land Use Table 
Next, you will import a land use table.  This land use table relates land use and 
soil type to curve number values.  You have already read in a land use grid, a 
soil type grid, and a drainage basin model.  This table, relating land use and 
soil type to actual curve number values, is the final piece of the puzzle to 
compute curve numbers for each basin. 

1. Select the Hydrologic Modeling module icon . 

2. Select the Compute GIS Attributes… command from the Calculators 
menu. 

3. Make sure SCS Curve Numbers is selected in the Computation field. 

4. Select the Import button. 
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5. Find and Open “scstut.tbl”.  Notice that the table appears in the 
Mapping text window after it is imported. 

15.6 Computing Curve Numbers for a Drainage Coverage 
The final step is to compute the curve numbers for the drainage coverage.  This 
step is simple since WMS does this automatically.  As an overview, the 
following data are required to compute composite curve numbers for a 
drainage coverage: 

• A drainage coverage with outlet points and sub-basins defined. 

• A land use grid or a land use polygon coverage. 

• A soil type grid or a soil type polygon coverage. 

• A land use table relating land use and soil type to curve number. 

Now do the following: 

1. Insure that SCS Curve numbers is selected for the computation type. 
For both soil type and land use the default option of using a grid for 
computation should be selected. 

2. Select the OK button. 

Curve numbers will be computed and displayed for each of the basins. 

15.7 Reading in a Land Use Polygon Shapefile 
Now that you have computed curve numbers for the Aspen Grove sub-basins 
using a land use and soil type grid, you will compute curve numbers using a 
land use coverage and a soil type grid.  To do this, you must first create a new 
land use coverage and read in a land use shapefile: 

1. Select the Map module icon . 

2. Select the Coverages… command from the Feature Objects menu. 

3. Select the New button in the Coverages window. 

4. Change the name of the coverage to Land Use and change the 
coverage’s Attribute set to Land Use. 

5. Select the OK button in the Coverages window. 

6. Select the Import… command from the File menu. 
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7. Select Feature object polygons Shapefile (*.shp) from the Files of type 
field. 

8. Find and Open “aspenlu.shp”. 

In the polygon attribute text window of the Import Shapefile Data dialog, 
notice that the LU_CODE database field is automatically mapped to the 
Land use attribute in WMS.  This occurred only because the attribute name 
in the land use file was LU_CODE.  If the attribute name is anything other 
than LU_CODE it can still be assigned to the WMS Land Use variable 
manually using the Attribute mapping…dialog. 

9. Select OK and wait a few seconds while the land use shapefile for the 
Aspen Grove watershed is read in and displayed. 

15.8 Computing Curve Numbers for a Drainage Coverage Using 
a Land Use Polygon Coverage and a Soil Type Grid 

Now that you have imported a land use polygon coverage, you are ready to 
compute composite curve numbers for your drainage coverage using the land 
use polygon coverage you just imported and the soil type grid. 

1. Again select the Coverages… command from the Feature Objects 
menu. 

2. Select the Drainage coverage in the window displaying all the 
coverages and make it the active coverage by selecting the Active 
button.  Select OK in the coverages window. 

3. Select the Hydrologic Modeling module icon . 

4. Select the Compute GIS Attributes… command from the Calculators 
menu. 

5. Select the option to compute SCS Curve 

6. Specify that you want to Use a Soil type grid for determining soil type. 

7. Specify that you want to Use a Land use coverage for determining 
land use. 

8. Enter a Drainage coverage computation step of 50.0 (Meters in this 
case). 

9. Select the OK button in the Compute GIS Attributes window.  The 
computation may take anywhere from a minute to several minutes, 
depending on the speed of your computer.  The computed curve 
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numbers using this method should match the previously computed 
curve numbers. 

When the curve number is computed for the drainage coverage, each polygon 
in the drainage coverage is visited.  For each polygon, a temporary grid is 
created around the polygon with a cell width equal to the user-specified 
computation step.  Each cell in this temporary grid is visited.  For each 
temporary grid cell that is inside a basin, the curve number is computed (if it 
can be).  Thus, the smaller the computation step, the longer WMS will take to 
compute the curve numbers for the basins.  This computation step should be 
about equal to the smallest soil type or land use grid cell size (depending on 
whether you are using a soil type or land use grid to compute the composite 
curve number). 

15.9 Reading in a Soil Type Polygon Shapefile 
Besides being able to compute curve numbers for drainage coverages, WMS 
also computes curve numbers for TINs in much the same way.  In this section, 
you will compute curve numbers for the same basins in a TIN-based model of 
the Aspen Grove watershed.  Also, instead of using grids to compute the 
composite curve numbers for this model, you will import a soil type polygon 
shapefile and use a soil type polygon coverage and a land use polygon 
coverage. 

1. Select the Map module icon . 

2. Select the Coverages… command from the Feature Objects menu. 

3. Select the New button in the Coverages window. 

4. Change the name of the coverage to Soil Type and change the Attribute 
set to Soil Type. 

5. Select the “Drainage coverage” and select the Delete button. 

6. Select OK when prompted for confirmation. 

7. Select the OK button in the Coverages window. 

8. Select the Import… command from the File menu. 

9. Select Feature object polygons Shapefile (*.shp). 

10. Select and Open  “aspenso.shp”. 

In the polygon attributes text window, notice that the HYDGRP database 
field is automatically mapped to the SCS soil type attribute in WMS.  
Since we want to map HYDGRP to WMS SCS soil type and there is 
nothing else to map, select the OK button.  If your database field for 
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hydrologic soil group is named something other than HYDGRP then you 
can manually map it to the WMS parameter by selecting the Attribute 
mapping button and defining which database field represents hydrologic 
soil group. 

11. Select OK and wait a few seconds while the soil type shapefile for the 
Aspen Grove watershed is read in and displayed. 

15.10 Reading in a TIN with Defined Sub-basins 
Now that you have a land use polygon coverage defined and a soil type 
polygon coverage defined, you can import a TIN containing defined sub-
basins.  Then, you can compute the composite curve numbers for your TIN 
using the land use and soil type polygon coverages. 

1. Select the TIN module icon . 

2. Select the Open… command from the File menu. 

3. Select and Open “aspentin.sup”. 

15.11 Computing Curve Numbers for a TIN Using a Land Use 
Polygon Coverage and a Soil Type Polygon Coverage 

In this section, you will compute composite curve numbers for your TIN file 
using a land use polygon coverage and a soil type polygon coverage. 

1. Select the Display Options… command from the Display menu. 

2. Select the Drainage tab. 

3. Turn on the display of Basin CN’s (curve numbers). 

4. Select OK. 

5. Select the Tree module icon . 

6. Select the Compute GIS Attributes… command from the Calculators 
menu. 

7. Select the option to compute SCS Curve numbers using a soil type 
coverage and a land use coverage (You will have to select the Use a 
soil type coverage for determining soil type and the Use a land use 
coverage for determining land use options). 

8. You do not need to enter a computation step when computing the 
curve number for a TIN.  Just leave this value alone. 
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9. Select the Import button and select OK to overwrite any existing data. 

10. Find and Open “scstut.tbl”. 

11. Select the OK button in the Compute GIS Attributes window.  The 
computation may take anywhere from a few seconds to several 
minutes, depending on the speed of your computer. The computed 
curve numbers using this method are slightly different than the curve 
numbers computed for the drainage coverage.  This is because the 
shape of the basins are also slightly different. 

15.12 Computing Composite Runoff Coefficients for a Drainage 
Coverage Using a Soil Type Grid 

Besides being able to compute composite curve numbers, you can also 
compute composite runoff coefficients in WMS.  These runoff coefficients can 
be computed from a soil type grid and can be used in a Rational method 
simulation. 

1. Select the New command from the File menu.  Select OK when 
prompted if you want to delete everything. 

2. Select the Map module icon . 

3. Select the Open… command from the File menu. 

4. Find and Open “aspencn.sup”. 

5. Select the Import… command from the File menu. 

6. Select DEM Attributes (*.*) from the Files of type field. 

7. Select and Open “aspsogrd.asc”. 

8. Select the Soil type option for the mask. 

9. Select Arc/Info for the file type, and select the OK button. 

10. Select the Tree module icon . 

11. Select the Compute GIS Attributes… command from the Calculators 
menu. 

12. Select the Runoff coefficients computation option. 

13. Select the Import button in the Compute GIS Attributes dialog. 
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14. Find and Open “soiltype.tbl”.  Notice that the table appears in the 
Compute GIS Attributes dialog after it is imported. 

15. For soil type, make sure the option to Use a soil type grid for 
determining soil type is selected. 

16. Select the OK button. 

You have now computed the runoff coefficients for your watershed.  The 
computed runoff coefficient values can be used in the Rational Method to 
determine watershed runoff.  You can view these values by doing the 
following: 

1. Select any of the square basin icons in the Hydrologic Modeling Tree 
Window. 

2.   Select the Run Simulation… command from the Rational menu. 

You should see the composite runoff coefficient for this basin.  You can view 
the values of the other basins by selecting their respective basin icons. 

15.13 Conclusions 
This concludes the curve number computation tutorial.  You are encouraged to 
experiment with all of the commands explained in this section until you feel 
comfortable with the tools available to you for computing curve numbers. 

In this section, you have learned how to compute curve numbers (or runoff 
coefficients) for drainage coverages and TINs using: 

• soil coverages or soil grids 

• land use coverages or land use grids 

• tables relating land use to CN or soil type to runoff coefficient. 
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CHAPTER 16 
Scattered Data and 2D Grids 

Estimated Time: 20 minutes 

The Scattered Data module and Grid module can be used in combination to 
visualize any set of scalar values that can be assigned to unique x-y positions.  
The scalar value used in this tutorial is rainfall intensity generated from 
NEXRAD radar files, but they could just as easily represent rain gages or other 
locations for which rainfall intensities or accumulations are known. 

 

16.1 Objectives 
In this tutorial you will learn how to import scattered data with an 
accompanying data set and interpolate from the scattered data to a grid for 
visualization by: 

• Reading a scattered data file. 

• Creating a bounding grid around the scattered points. 

• Interpolating from scattered data. 

• Contouring a grid. 

• Mapping scalar values to elevations. 

• Using virtual gages to examine the time variance of the data. 
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• Animating the transient rainfall data. 

16.2 Reading the Data File 
The scattered data file and data points used in this tutorial were derived from a 
portion of a NEXRAD radar scan.  After reading the scattered points, a data 
set representing rainfall intensities will be imported.  To read the file, do the 
following: 

1. Select the Scattered Data module icon . 

2. Select Open… from the File menu. 

3. Use the file browser to find and Open the file “rainfall.xy”.  This file 
should be found in the tutorial directory. 

4. Select the Data Browser… command in the Data menu. 

5. Select the Import… button, and accept the default of Generic scalar 
file. 

6. Use the file browser to find and Open the file “rainfall.scl”.  This file 
should be found in the tutorial directory. 

 This file contains a transient (values for multiple times) data set of 
rainfall intensities. 

7. Select the data associated with time step 15.00.  You may need to use 
the scroll bar to locate this time step in the data browser dialog. 

8. Select the Done button. 

16.3 Interpolation from Scattered Data to a Grid 
In order to contour or animate the rainfall data set, the values must be 
interpolated to a grid.  To interpolate to a grid do the following: 

1. Select the Bounding Grid… command in the Data menu. 

2. Specify 25 cells in both the x and y directions, and a mesh centered 
grid type.  All other fields can be left as defaults. 

3. Select the OK button. 

4. Select OK for the default z value. 

 A grid will be created which just bounds the scattered data points. 
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5. Select Interpolation Options… from the Interpolation menu. 

6. Select the Data Set… button. 

7. Turn the All time steps toggle on. 

8. Select the Select button. 

9. Turn on the Truncate values toggle. 

 This will keep the interpolation functions from assigning values 
outside the absolute minimum and maximum of the data set. 

10. Select the OK button. 

11. Select Interpolate to Grid… from the Interpolation menu. 

12. Accept the default name for the data set being created for the grid. 

 WMS will now interpolate the values for each time step from the 
scatter points to the grid nodes.  The progress dialog box informs you 
of the progress for interpolation. 

16.4 Contouring the Grid 
The interpolation process created a new transient data set for the grid.  In this 
section options for contouring individual time steps will be explored. 

1. Select the Display Options… command from the Display menu. 

2. Turn off the Scatter point symbols and select OK. 

3. Change to the 2D Grid module . 

4. Select the Display Options… command from the Display menu.  

5. Turn off Nodes and Cells and turn on 2D Grid Contours. 

6. Select the OK button. 

 Linear contours of rainfall intensity are drawn for the grid for time 
step 15.00.  Since time value 15.00 was selected as the active time step 
in the data browser for scattered data, it is also the active time step for 
the data set of the grid. 

7. Select the Contour Options… command from the Display menu. 

8. Select the Color fill between contours option. 
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9. Turn on the Display Legend option. 

10. Select the OK button 

 The contours are now drawn using a ramp of color intensities.  A 
legend is drawn in the upper left hand portion of the screen, displaying 
the correlation between color and rainfall intensity. 

11. Select the Contour Options… command from the Display menu. 

12. Select the Color Options tab. 

13. Select the Reverse button. 

14. Select the OK button. 

16.5 Virtual Gages 
A virtual gage can be used to show a two dimensional plot of a transient data 
set for any point in the grid domain. 

1. Select Show Hydrograph Window from the Display menu. 

2. Select the Create Gage tool . 

3. Click on any point within the boundary of the grid (the gage plot will 
be more interesting if the gage is in a region of the grid where the 
rainfall intensity is high). 

4. Click on another point to create a second gage. 

 By default a gage is selected immediately after being created (and all 
other gages are unselected).  Therefore the plot currently being 
displayed corresponds to the second gage.  Both gages can be 
displayed simultaneously using multi-selection. 

5. Select the Select Gage tool . 

6. Select both gages, holding the SHIFT key down as the second gage is 
selected. 

 The hydrograph window shows a plot of the selected gages.  Several 
options can be changed to control how gages are displayed.  These 
options are accessible by selecting the Gages command or Gage Plot 
Manager command in the Data menu.  You are encouraged to 
experiment with these options as much as you want.  When you are 
finished delete the gages: 
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7. Select the Select Gage tool  if it is not already selected. 

8. Select both gages. 

9. Choose the DELETE or BACKSPACE key. 

16.6 Animations 
Animation sequences can be generated from transient data sets.  Animations 
are comprised of a series of images of the current grid where all display 
options remain the same while the time step is moved ahead. 

1. Select the Film Loop command from the Data menu. 

 The Film Loop dialog comes up over the edit window and stays up 
while you create and play your film loop animations.  Icons are similar 
to a VCR and can be used to run, stop, or step through an animation 
sequence. 

2. Select the Setup button. 

3. Change the Size (% Screen) to 30%. 

4. There are several other options that you may experiment with, but for 
now select OK. 

 WMS will draw a contoured image of each time step in the data set, 
saving the image after each one.  Once an image for each time step is 
created, the video buttons and other controls will undim and the 
animation sequence can be replayed at a much higher refresh speed. 

5. Select the play button (the VCR-like right arrow button). 

6. Experiment with the speed setting. 

7. Stop the animation by selecting the stop button (the VCR-like box). 

8. Use the Frame scroll bar to move the animation forward/backward in 
time. 

9. If you wish to save the series of images to a file so that they can be 
replayed later without having to load data files or run through setup, 
you can use the Save button to save an animation loop file.  In a 
subsequent session of WMS the Read dialog in the Film Loop dialog 
can be used to reload and run the animation.  In this case you would 
not have to read in the grid, data set or run through the time consuming 
process of setup. 

10. Select the Done button. 
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16.7 Mapping Elevations 
Any function from a data set can be mapped to the elevations of the grid cells 
so that the function can be represented as a 3-dimensional surface.  This can be 
done for the current grid and data set by doing the following: 

1. Select the Display Options… from the Display menu. 

2. Turn on the display of Cells. 

3. Select OK. 

4. Select the Map Elevations… command from the Data menu. 

5. Select the data set created when interpolating from the scattered data 
(rainfall_all would have been the default) and once again choose time 
step 15.0. 

6. Select the Select button. 

7. Select the Oblique View macro . 

8. Select the Z Magnification… command from the View menu. 

9. Set the value to 250 (in order to better visualize the variations in 
elevations) and select OK. 

You may wish to rotate  or experiment with other display commands. 

16.8 Conclusions 
In this tutorial you have learned how scatter points and data sets can be used to 
interpolate sparse data to a grid for visualization purposes.  You should know 
how grids can be contoured, and how virtual gages, animations, and mapped z 
values can be used to display transient data. 
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CHAPTER 17 
TIN Editing 

Estimated Time: 25 minutes. 

In order to define a stream network and delineate basins, you must first have 
flow defined everywhere on the TIN.  Triangulating a set of raw data points 
rarely produces such a TIN.  Often, flat triangles and edges, artificial pits, and 
discontinuities in channel segments exist.  For this reason, a set of tools is 
provided in WMS which allows you to alter the initial triangulation, using your 
own knowledge about the site being modeled, so that drainage is properly 
defined and channel edges are accurately represented.  A certain amount of 
TIN editing was required for all of the TINs used in the previous tutorial.  In 
this and the next tutorial, you will learn the different methods available for 
pre-processing TINs before using them for drainage analysis. 

Data points used for the initial triangulation generally come from one of two 
different sources: digitized data from an existing contour map or gridded data 
such as is provided by the USGS.  Different types of problems arise with each 
of these types of data, and therefore the editing approach is generally different.  
This tutorial covers editing techniques appropriate for digitized data, while 
techniques for gridded data is the topic of the next tutorial. 

Stream network creation in the previous tutorials was done automatically.  
However, having a continuous set of well defined channel segments is a 
prerequisite to creating streams in this fashion.  While having a continuous set 
of channel segments is ideal, it is not always practical, and therefore an 
alternate method of stream network creation is presented in this tutorial.  This 
method allows you to interactively select points which make up a stream or 
input a digitized set of stream points from a file. 
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17.1 Objectives 
In this tutorial you will learn basic editing techniques and automated 
techniques which apply specifically to data which has been generated by 
digitizing a contour map.  The steps covered include the following: 

• Reading the TIN data file. 

• Triangulating the data points. 

• Removing boundary triangles. 

• Swapping edges to remove flat triangles and define channel segments. 

• Adding breaklines so that triangle edges honor important features. 

• Inserting additional points. 

• Interactively moving points. 

• Automatically removing flat triangles. 

• Creating streams by interactively selecting a network of vertices. 

• Using the display options to guide the editing process. 

17.2 Reading the Data File 
The TIN you will be reading for this tutorial only contains the vertices, as 
triangles have not yet been created (you can use this file as an example format 
for data you may already have and wish to read into WMS).  To read the file, 
do the following: 

1. If you are continuing from a previous WMS session, select New from 
the File menu. 

2. Confirm that you want to delete everything. 

3. Select the TINs module icon . 

4. Select Open… from the File menu. 

5. Use the file browser to find and Open the file “digitize.tin”.  This file 
should be found in the tutorial directory. 

6. Select the Display Options… command from the Display menu. 
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7. Make sure that Vertices and Triangles are turned on. 

8. Select OK. 

 After opening the file, you should see several data points drawn in the 
main graphics window. 

17.3 Triangulating the Data Points 
Triangulation is the first process that must be done any time a new set of data 
points is read into WMS.  You can watch the triangulation process proceed as 
will be shown, however displaying the triangulation process is more time 
consuming, and therefore you typically won't want to do this.  To triangulate 
the points, do the following: 

1. Select Triangulation Options… from the TINs menu. 

2. Turn on the Display triangulation process option. 

3. Click on the OK button. 

4. Select Triangulate from the TINs menu. 

5. Select the Lock/Unlock Vertices command from the TINs menu. 

 Locking the original set of data points is a good idea since location and 
elevation of these points are more certain, and you do not want to 
move them accidentally.  Any additional points created will by default 
be unlocked. 

6. Select Display Options… from the Display menu. 

7. Turn on Tin Contours, Channel edges, and Flat triangles. 

8. Turn off Boundaries. 

9. Click on the OK button. 

 The display should show the triangulated TIN.  Notice the flat 
triangles displayed in red, and channel edges in yellow. 

17.4 Removing Thin Triangles on the Boundary 
Several long thin triangles around the perimeter of the TIN exist.  Often these 
triangles are outside of the area of interest and, as seen along the bottom, can 
create several flat triangles, since all perimeter points were digitized from the 
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same contour.  These triangles can be selected for deletion in the following 
manner: 

1. Select the Select Boundary Triangles command from the TINs menu.  
Several of the thin boundary triangles will automatically be selected. 

2. Make sure that the Select thin boundary triangles only option is 
chosen and select OK. 

3. Select the Delete command from the Edit menu. 

4. Confirm that you want the triangles deleted by selecting OK. 

 The boundary triangles selected will be deleted and the display 
updated appropriately.  This process could have been done manually 

by using the select triangles tool  and the techniques for selection 
described in the reference manual. 

17.5 Swapping Edges 
It appears as if there is some type of channel on the right side of the TIN.  
However, because of the flat triangles and the current TIN topology, the 
channels are not all present nor continuous.  Edge swapping can often be used 
to remove flat triangles and force triangle edges where channel segments 
should be.  The figure below shows four edges that need to be swapped in the 
following manner.  To swap edges, do the following: 

1. Select the Swap Edge tool . 

2. Click on the edges labeled 1-4 (in that order).  Notice how the contour, 
flat triangle, and channel edge display is immediately updated. 
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Figure 17-1 Before Swapping 

 
Figure 17-2 After Swapping  

17.6 Adding Breaklines 
Another method which can be used to force triangle edges along important 
terrain features such as ridges and streams is breaklines.  The remaining flat 
triangles will be removed using a breakline.  The figure above acts as a guide 
for placing the breakline.  To add a breakline, do the following: 

1. Click on the Select Vertex String tool . 

2. Click on the vertices marked 1-4 (in that order) in 

Figure 17-3.  
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3. Select the Add Breaklines command from the TINs menu. 

 

Figure 17-3. Before Adding Breakline 

 
Figure 17-4 After Adding Breakline 

17.7 Removing False Dams 
False dams occur when a triangle edge is created perpendicular to a stream 
channel (from one bank to the other), as opposed to along the channel.  The 
figure shown below shows two different cases where false dams are present.   
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Figure 17-5 Before Removing False Dams. 

It may not be obvious from the contours that a channel edge should exist at 1; 
however, the discontinuity in the channel segment provides a clue that the edge 
should be swapped.  It should be more obvious that edge 2 forms a false dam.  
False dams can always be removed by swapping edges.  To remove false dams, 
do the following: 

1. Select the Swap Edge tool . 

2. Click on edges 1 and 2 as shown in Figure 17-5. 

 
Figure 17-6 After Removing False Dams. 
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17.8 Inserting Additional Points 
You may have noticed that there are several small channel edges connected to 
the main stream network.  Often, no such channels exist and for clarity you 
wish to remove them.  Typically these types of problems can be corrected by 
inserting additional points into the triangulation.  Figure 17-7 shows how the 
two small channels segments near the upper middle portion of the TIN can be 
removed by placing a new point at A in the following manner: 

1. Select the Create Vertex tool . 

2. Click on the TIN at or about point A. 

3. Accept the default z value by selecting OK. 

4. A new point will be inserted into the triangulation, and both adjacent 
stream edges should disappear. 

 
Figure 17-7 Before Adding the Point 

 
Figure 17-8 After Adding the Point. 
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1. Click on the Select Vertices tool . 

2. Click on the new vertex and, while holding the mouse button down, 
drag it around.  You should see the contours, stream edges and any 
other TIN display option which is turned on update immediately.  This 
function of WMS is particularly useful when editing. 

3. With the vertex selected, the z value is displayed in the Z: edit field in 
the Edit Window. You can edit the z value by changing it in this edit 
field. 

4. Restore the z value of the new vertex to a logical position (make the 
contours look similar to the contours shown in Figure 17-8). 

17.9 Automated Editing Techniques 
The TIN you have been working with so far in this tutorial is only a small part 
of a much larger TIN created using a digitizer.  The editing techniques you 
have learned thus far could be used repeatedly to correct flat triangles, flat 
edges, false dams, etc., for the entire TIN.  However, removal of flat objects 
can often be done automatically, greatly increasing the speed and efficiency at 
which TINs can be prepared for doing drainage analysis.  To perform these 
editing techniques, do the following: 

1. Select the New command from the File menu. 

2. Confirm that you want to delete everything. 

3. Select the Open… command from the File menu. 

4. Find and open the file “auto.tin”.  

5. Select the Triangulate Options… command from the TINs menu. 

6. Turn off the Display triangulation process command. 

7. Click on the OK button. 

 Displaying the triangulation for larger data sets can take significantly 
more time. 

8. Select the Triangulate command from the TINs menu. 

9. Select the Select Boundary Triangles command from the TINs menu. 

10. Select the Select thin boundary triangles only option. 
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11. Select OK. 

12. Select the Delete command from the Edit menu. 

13. Select the Lock/Unlock Vertices command from the TINs menu. 

 In order to automatically remove flat objects, the vertices should be 
locked. 

14. Select the Interpolate Flat Triangles command from the TINs menu. 

 This operation could take several seconds to a few minutes depending 
on your hardware.  After a few seconds you should start to see the flat 
triangles and edges being modified.  When complete you should see 
that channel edges run through the entire region of flat triangles. 

15. Select the Display Options command from the Display menu. 

16. Turn on Pits. 

17. Click on the OK button. 

 As the display is updated, notice that there are several pits in the 
stream.  These pits occur as a result of removing flat triangles and 
edges, and not necessarily because of actual pits in the stream. 

17.10   Creating Streams Manually 
Recall from earlier tutorials that streams could be automatically delineated 
from outlet points if a continuous set of channel edges existed.  Even though a 
continuous set of channel edges exists in the current TIN, it is still interrupted 
by several pits.  In order to automatically delineate the streams, TIN editing 
would have to be done to remove the pits and ensure that each successive 
stream vertex from upstream to downstream had a lower elevation.  This 
process often takes a considerable amount of time, and therefore an alternative 
to automatically delineating stream networks is provided in WMS. 

Stream networks can be created by manually selecting a set of vertices, from 
downstream to upstream, regardless of whether the next upstream vertex is 
higher or lower in elevation.  This allows you to run a stream right through the 
set of pits in the channel above without having to do any additional editing.  
This type of stream creation is possible because once flow reaches a stream, it 
is routed downstream strictly by the connectivity of the stream.  This type of 
stream creation has several important uses: 

1. Pits in natural streams don't have to be removed using TIN editing 
techniques. 
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2. Streets, canals, storm drains, etc., which are not necessarily 
represented as stream edges in a TIN can be modeled. 

3. A set of stream vertices can be imported and stamped into the TIN. 

Along with the advantages there are a couple of pitfalls which you must be 
aware of: 

1. Calculated stream slopes may not be accurate.  However, overall 
averages still give reasonable results. 

2. Improper placement of a stream, street, storm drain, etc., can cause 
significant error in computed basin areas and drainage characteristics. 

In general, creating streams in this fashion is a powerful tool, but it must be 
used with common sense and a good understanding of the terrain being 
modeled.  Streams can be manually entered by following the steps outlined 
below: 

1. Click on the Select Vertex String tool . 

2. Starting at the outlet point, select the vertices corresponding to the 
stream (the lower right corner of the TIN).  Figure 17-9 can be used as 
a guide to start entering the stream.  You don't have to select vertices 
along triangle edges since a breakline will be inserted where 
necessary, but be sure to pass through the pits. 

3. After selecting several vertices, select the Create Stream command 
from the Streams menu. 

4. Click on the OK button if asked if you would like to process a 
breakline before the stream is created. 

You can stop entering points with the Select Vertex String tool  at any time 
and use the Create Stream command.  Begin the next segment from where you 
left off, or come back to a branching point and begin entering that branch.  A 
couple of important rules should be remembered when entering manually 
created streams. 

1. Streams should always be entered from downstream to upstream. 

2. Streams can not cross existing streams. 

3. The first vertex entered for a new stream becomes an outlet, unless 
you are branching off from an already existing stream. 

4. If stream edges created manually are swapped, or the triangulation of 
any of these edges are changed, the streams will no longer be valid. 
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5. The Pan  and Zoom  tools can be very useful when entering 
streams. 

 
Figure 17-9 Stream Creation 

17.11 Conclusions 
In this tutorial you have learned many important TIN editing techniques, as 
well as an alternate method of creating stream networks.  The important topics 
covered include the following: 

• Triangulating a raw set of data points. 

• Removing flat triangles and edges by swapping edges, inserting 
breaklines, and adding additional points. 

• Recognizing the power of the instantaneous feedback of the display of 
flat triangles, channel edges, contours, etc., when editing a TIN. 

• Automatically removing flat triangles and edges. 

• Creating streams by manually selecting the network of vertices. 
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CHAPTER 18 
Creating Topologic Models For HEC-1 

Estimated Time: 40 minutes. 

This chapter, if you are familiar with HEC-1, will help you understand how 
WMS compares to and how it differs from traditional HEC-1 modeling.  It is 
useful for new users of HEC-1 as well, since it will help you become familiar 
with what types of structures can be modeled with HEC-1, and how they are 
set up in WMS. 

The example problem illustrated here is the Red River watershed.  It is chosen 
since it illustrates many of the basic capabilities available in HEC-1.  
Furthermore, since it is the first example given in the HEC-1 User's Manual, it 
is a good source for illustrating how traditional HEC-1 models are created in 
WMS.  This tutorial will not lead you through every step to completely set up 
the model.  Instead you will be shown how to create and enter data for each 
type of object (i.e. basins, outlets, reservoirs, diversions) and then data for 
other similar objects will be provided so that you can repeat the steps.  A 
completed model of the Red River watershed is provided in the tutorial 
directory.  If you don't wish to enter all of the necessary data, or if you want to 
skim through this section and look at the results, you can read this file in using 
the Open HEC-1 File… command in the HEC-1 menu. 

The Red River watershed demonstrates the following capabilities available in 
HEC-1: 

• Rainfall data using gages. 

• Calculating hydrographs using base flow, losses, and unit hydrograph 
methods. 

• Flood hydrograph routing by the channel storage method. 
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• Reservoir routing using both spillway and low-level outlet options. 

• Diversions. 

• Input of time series data using time increments different than the 
computational time step. 

18.1 The Topologic Tree Representation 
The schematic shown in Figure 18-1 illustrates how different components in 
the Red River watershed are modeled using HEC-1.  Figure 18-2 shows a 
completed tree diagram for the same watershed created using WMS.  A few 
important differences need to be noted. 

• Names for all hydrograph computation units (outlets, basins, etc.) 
must be unique.  In the traditional HEC-1 diagram the name LOSTBR, 
EAST10, and RED30 are all used twice.  In WMS the names must be 
unique so that resulting hydrographs read from a TAPE22 file can be 
associated with the proper hydrograph station.  For this reason the 
basins LOSTBR and RED30 were changed to LOSTBS and RED30B. 

• Diversions may exist from basins to outlets or from outlets to outlets.  
In the traditional HEC-1 schematic the EAST10 outlet point exists 
solely to provide a point from which a diversion can be defined.  In 
WMS the diversion is defined directly from the EAST10 basin so there 
is no need to have the extra EAST10 outlet point.  Diverted flow will 
be taken from the EAST10 basin before being combined with the 
REDRI basin at the RED10 outlet point. 

• Reservoirs are defined with separate icons (triangles) in the traditional 
HEC-1 schematic, whereas in WMS they are defined at outlet points.  
There are actually a couple different ways the same problem can be set 
up using reservoirs in WMS.  Figure 18-3 and Figure 18-4 illustrate 
these alternatives.  
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Figure 18-1 Traditional HEC-1 Tree Diagram For Red River Watershed. 

 
Figure 18-2 HEC-1 Tree Diagram of Red River Watershed Created by WMS. 

Figure 18-3 shows an alternate tree created using WMS.  The difference 
between this diagram and the one in Figure 18-2 is that E.DAM has been 
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created as a reservoir rather than routing from LOSTBR to RED20 using the 
reservoir storage routing option. 

Figure 18-4 puts the E.DAM reservoir at RED20, since there is no need to 
have the outlet at LOSTBR.  The reservoir can be placed at the RED20 outlet.  
The diversion is routed from EAST10 to RED20, and the basin LOSTBS is 
connected directly to RED20. 

 
Figure 18-3 Reservoir Used in Place of Reservoir Storage Routing. 

 
Figure 18-4 LOSTBR Outlet Eliminated with E.DAM Reservoir at RED20. 
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The HEC-1 input file generated from all three trees will be identical.  They 
simply illustrate different ways in which reservoirs and reservoir routing from 
outlets can be done.  The tree defined in the remaining sections of this tutorial 
will correspond to the one in Figure 18-2. 

18.2 Creating the Tree 

If you are running the professional version, switch to the Tree Module .  If 
you are running the basic version you will be in the Tree Module already, 
unless you have turned the Demo on.  If you are running the Demo turn it off 
now.  The following commands can be used to create the topological tree for 
the Red River watershed as shown in Figure 18-2.  All commands are in the 
Tree menu. 

1. Select the Add Outlet command.  The bottom outlet will be created and 
then selected.  Each time you create a new outlet it becomes the 
selected outlet. 

2. Select the Add Basin command.  Don't worry that the names don't 
match those in Figure 18-2; you can change them later. 

3. Select the Add Outlet command. 

4. Select the Add Basin command. 

5. Select the Add Outlet command. 

6. Select the Add Basin command. 

7. Click on the Outlet point named 2C to select it. 

8. Select the Add Outlet command. 

9. Select the Add Basin command. 

10. Select the Add Basin command. 

Except for the names, your tree should now look like the one in Figure 18-2.  If 
it does not you can start over by selecting the New command in the File menu, 
or you can use a combination of the Delete and Add commands in the Tree 
menu to correct your tree. 

18.3 Changing Hydrograph Station Names 
WMS requires that all hydrograph stations have a unique six-character 
identification name.  In order to help avoid this problem default names are 
provided whenever an outlet, basin, diversion, or reservoir is created (i.e. 1C, 
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2C, 1B, 2B, etc.).  You can change the name of these stations to make them 
more identifiable; however, you must remember these two limitations: 

• Names cannot be longer than 6 characters. 

• Names must be unique. 

To change the outlet names do the following: 

1. Click on the outlet point 1C 

2. Select the Edit HEC-1 Parameters… command from the HEC-1 menu, 
or double-click on the outlet point (this automatically brings up the 
Edit HEC-1 Parameters dialog). 

The Edit HEC-1 Parameters dialog contains several buttons that can be used to 
define/edit data for hydrograph stations.  Only the buttons that pertain to the 
selected hydrograph station are active, all others are dimmed.  The text 
window below the group of buttons shows the actual HEC-1 cards as they are 
currently defined for the selected object(s).  You can define/edit data by either: 
1) Clicking on the appropriate button, or 2) Clicking on the appropriate HEC-1 
card in the text-window. 

1. Select the Routing Data button. 

2. Change the combining name from 1C to RED30 and click on the OK 
button.  There is no routing from this outlet so you don't need to worry 
about changing the routing name. 

3. Select the next upstream outlet 2C.  You may wish to reposition your 
Hydrologic Modeling Window and/or the Edit HEC-1 Parameters 
dialog so that you can see both the tree and the dialog.  You don't need 
to quit the Edit HEC-1 Parameters dialog; data for the next selected 
outlet point will now be displayed. 

4. Select the Routing Data button. 

5. Change the combining name from 2C to RED20. 

6. Change the routing name from 2R to 20TO30. 

7. Repeat the last three steps, changing 3C to LOSTBR, 3R to E.DAM, 
4C to RED10, and 4R to 10TO20. 

To change Basin names do the following: 

1. Click on the basin 1B.  If you accidentally closed the Edit HEC-1 
Parameters dialog then double-click on 1B to bring it back up. 

2. Select the Basin Data button. 
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3. Change the basin name from 1B to RED30B and click on the OK 
button. 

4. Click on basin 2B. 

5. Select the Basin Data button. 

6. Change the basin name from 2B to WEST20 and click on the OK 
button. 

7. Repeat the last three steps, changing 3B to LOSTBS, 4B to EAST10, 
and 5B to REDRI. 

1. Select the Done button. 

18.4 Creating the Tree with Feature Objects 
In more recent versions of WMS, the hydrologic modeling tree can be created 
directly from feature arcs (streams) and polygons (basins) (see chapter 4).  
This means that a tree can be created even without a map from which actual 
stream networks and watershed boundaries are digitized.  In such cases the 
feature objects represent a "picture" or "drawing" of the watershed and are not 
used to calculate areas and lengths.  However, the drawing itself may be much 
more instructive to clients and reviewers than just the modeling tree.  If you 
want you can read in a map file that contains the same watershed definition 
you have just created by following these three steps: 

1. Select the New command from the File menu and confirm that you 
want delete all data. 

2. Select the Open… command from the File menu. 

3. Find and Open the file named redri.map. 

If you choose to do this, your model will replace (but be equivalent to) the one 
you have just defined and should look like Figure 18-5. 
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Figure 18-5  Red River Watershed Tree Defined from Feature Objects. 

Diversions cannot be saved with feature objects (TINs or DEMs either), so 
after creating a watershed using feature objects, diversions still need to be 
entered using the commands in the Tree menu of the Hydrologic Modeling 
Module. 

1. Select the Hydrologic Modeling module icon . 

2. Select the Select Basin icon tool . 

3. Click on the basin named EAST10 to select it. 

4. Select the Add Diversion command from the Tree menu. 

5. Click on the Outlet point named E.DAM to select it. 

6. Select the Retrieve Diversion command from the Tree menu. 

To change the diversion name do the following: 

1. Click on the diversion D1. 
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2. Select the Edit HEC-1 Parameters… command from the HEC-1 menu. 

3. Select the Diversion Data button. 

4. Change the name from D1 to DIVERT. 

5. While in this dialog change the outflow hydrograph name to EASTDV 
and the inflow hydrograph name to LOSTDV.  These are the names 
used on the KK records where the diversion is created (DT record) and 
retrieved (DR record). 

6. Click on the OK button. 

7. Click Done. 

18.5 Job Control Data 
Job control data includes the starting time, time step interval, general output 
specification and other custom features of HEC-1.  To modify these data do 
the following: 

1. Select the Job Control… command from the HEC-1 menu. 

2. Change the day to 12. 

3. Change the month to 6. 

4. Change the year to 68. 

5. Change the computational time interval to 15. 

6. Change the beginning time to 715. 

7. Change the number of hydrograph ordinates to 58.  The total length of 
the simulation will be 58*15min or 14 hours and 30 minutes. 

8. If you wish, you can change the ID cards. 

9. Select the OK button. 

18.6 Defining Gages 
The Red River watershed model uses 5 total storm stations and one recording 
station to define the precipitation for the simulation.  This is done in WMS 
with the following steps: 

1. Select the Gages command from the HEC-1 menu. 
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2. Select the New button. 

3. Turn the Define rain gage location toggle off. 

4. Change the Name to 60. 

5. Define the precipitation to be 4.68 (inches). 

6. Repeat the last four steps defining gages 61,62,63, and 64 using the 
data in Table 2.1 to define the precipitation. 

 

Table 2.1. Total Storm Gaging Stations. 
Name Precipitation 

60 4.68 
61 4.65 
62 4.85 
63 4.90 
64 5.10 

At least one recording station must be defined to set up the temporal 
distribution data for the gages.  For the Red River watershed a single recording 
station is defined and then used for all storm total stations.  Set this gage up 
with the following steps: 

1. Select the New button. 

2. Change the Name to 400. 

3. Toggle off the Storm Total Station button, and toggle on the Temporal 
distribution station button. 

4. Click on the Define Series button. 

This will bring up the XY Series Editor dialog.  WMS uses this dialog to define 
several different series of data.  Rainfall distributions are one type of series 
data.  For additional information see the chapter in the reference manual on 
using the XY series editor. 

By default the rainfall distribution values are considered to be cumulative.  
The Red River model, however, uses incremental.  This model also uses a time 
step of 60 minutes rather than the default of 15.  To change these two defaults 
to match the Red River model use the following steps. 

1. Select the XY Opts button. 

2. Toggle on the Unit Time box. 
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3. Change the beginning time to 435 minutes (This corresponds to 7 
hours and 15 minutes and will be converted appropriately when exiting 
the dialog). 

4. Change the increment to 60. 

5. Select the Delta button in the Distribution box. 

6. Select the OK button. 

7. Enter the following ten incremental values, starting with time 7:15 in 
edit field 1: .04, .35, .01, .03, .73, .21, .02, .01, .03, .01 

8. Change the name of the Current XY series to "Rainfall Distribution". 

9. Select the OK button of both dialogs. 

18.7 Defining Basin Parameters 
HEC-1 requires that all basins have an appropriate area, precipitation, loss 
method, and unit hydrograph method defined.  Just about any combination of 
these methods will work.  This tutorial will describe how these parameters can 
be defined for one basin and then a table of values will be provided so that the 
parameters can be defined for the remaining basins. 

Since the base flow parameters are identical for all basins this will be defined 
first. 

1. Click on the basin named RED30B. 

2. Select the Edit HEC-1 Parameters… command from the HEC-1 menu.  
Once again you may wish to reposition windows. 

3. Select the Select All command from the Edit menu.  All basins will be 
selected and their data displayed in the text window. 

4. Select the Basin Data button.  Notice that the name and area fields are 
dimmed since you wouldn't want to change these values with all basins 
selected. 

5. Change the STRTQ value to be 10. 

6. Change the QRCSN value to be -.25. 

7. Change the RTIOR value to be 1.2. 

8. Select the OK button. 



18-12 WMS Tutorials 

9. Click on the RED30B basin once again so that it is the only one 
selected. 

10. Select the Basin Data button or click on the BA card in the text 
window. 

11. Change the Area to .19 and select the OK button. 

12. Select the Precipitation button. 

13. Select the Gage button. 

14. Select the PT Gage Weights (These are weights for total storm 
stations). 

15. In the first two Gage Name fields enter 64 and 63, and in the first two 
Weight fields enter .65 and .35. 

16. Select the OK button. 

17. Select the PR Gage Weights (These are weights for distribution 
station). 

18. In the first Gage Name field enter 400, and in the first Weight field 
enter 1.0. 

19. Select the OK buttons for both the Weight and Precipitation dialogs. 

20. Select the Loss Method button or click on the LS card in the text 
window. 

21. The SCS method is on by default (for some of the other basins you 
may need to change the method), but change the curve number 
(CRVNBR) field to 79. 

22. Select the OK button. 

23. Select the Unit Hydrograph Method button or click on the UD card. 

24. Once again the SCS method is on by default, but you need to change 
the lag time (TLAG) to 1.04. 

25. Select the OK button. 

Basin parameters for RED30B should now be defined.  You can now select the 
other basins one at a time and repeat the above steps for defining area, 
precipitation and weights, loss method, and unit hydrograph method using the 
data given in Table 2.2.  For some basins you will need to change the Loss and 
Unit Hydrograph Methods before the appropriate parameters can be defined.  
The HEC-1 card identification (LS, LE, etc. is always part of the method 
button so you can identify which method to choose from the HEC-1 cards in 
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Table 2.2.  Where there may be some confusion, parameter names are given in 
the table.  If only one parameter exists, no name is given and if a parameter is 
left out of the table just leave its value at zero.  

 

Table 2.2.  Basin Parameters for the Red River Watershed. 
Name Area Gage Weights Loss Parameters Unit Params 

RED30B .19 63 .35 LS CRVNBR=79 UD 1.04 
  64 .65     
  400 1.0     

WEST20 .80 63 .60 LH FC=.04 UD .94 
  64 .40  GIA=.4   
  400 1.0  SAI=.3   
     BEXP=1.4   

LOSTBS .36 62 .5 LU STRTL=.3 UC TC=.8 
  63 .5  CNSTL=.04  R=1.2 
  400 1.0     

EAST10 .66 61 .6 LE STRKR=.6 US TP=1.3 
  62 .3  DLTKR=1.0  CP=.8 
  63 .1  RTIOL=1.0   
  400 1.0  ERAIN=0.0   

REDRI .82 60 .75 LS CRVNBR=80 UD 1.47 
  61 .25     
  400 1.0     

18.8 Defining Routing Parameters 
Routing parameters are defined in a similar fashion as basins.  For the Red 
River model channel, routing needs to be defined from RED10 to RED20 
(10TO20) and from RED20 to RED30 (20TO30).  This can be done with the 
following steps: 

1. Select the outlet E.DAM if the Edit HEC-1 Parameters is still active.  
If you have closed it already, select E.DAM and then select the Edit 
HEC-1 Parameters… command from the HEC-1 menu. 

2. Select the Routing Data button or click on the RN card in the text 
window. 

3. Select the Storage (RS) routing option. 

4. Set the NSTEPS to 1, the type to FLOW and RSVIC to -1.0. 

5. Leave the channel button selected and click on the Define button. 

6. Select the Modified Puls option and click on the Define Volume 
button.  The XY Series editor can now be used to define the volume 
table. 

7. Change the Current XY Series Name to "RED20 Volume". 
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8. Enter the following values, starting with the first table field: 0, 17, 42, 
67, 100, 184, 274, 386, 620. 

9. Click on the OK button. 

10. Click on the Define Outflow button. 

11. Select the New button. 

12. Change the Current XY Series Name to "RED20 Outflow". 

13. Enter the following values, starting with the first table field: 0, 500, 
1000, 1500, 2000, 3000, 4000, 5000, 7000 

14. Click on the OK button of all three dialogs. 

15. Select the outlet RED10. 

16. Select the Routing Data button or click on the RN card in the text 
window. 

17. Select the Storage (RS) routing option. 

18. Set the steps to 1, the type to FLOW and RSVIC to -1.0. 

19. Leave the channel button selected and click on the Define button. 

20. Select the Modified Puls option and click on the Define Volume 
button.  The XY Series editor can now be used to define the volume 
table. 

21. Select the New button. 

22. Change the Current XY Series Name to "RED10 Volume". 

23. Enter the following values, starting with the first table field: 0, 18, 36, 
54, 84, 110, 138, 174, 228, 444. 

24. Click on the OK button. 

25. Click on the Define Outflow button. 

26. Select the New button. 

27. Change the Current XY Series Name to "RED10 Outflow". 

28. Enter the following values, starting with the first table field: 0, 500, 
1000, 1500, 2150, 2600, 3000, 3450, 4000, 6000. 

29. Click on the OK button of all three dialogs. 
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18.9 Defining Diversion Data 
Both an inflow and outflow table must be defined to set up the diversion data.  
This is done by following the steps below: 

1. Select the diversion arrow named DIVERT if the Edit HEC-1 
Parameters is still active.  If you have closed it already, select 
DIVERT and then select the Edit HEC-1 Parameters… command from 
the HEC-1 menu. 

2. Select the Diversion Data button or click on the DR card in the text 
window. 

3. Click on the Define DI button.  The XY Series editor can now be used 
to define the inflow table. 

4. Change the Current XY Series Name to "Divert DI". 

5. Enter the following values, starting with the first table field: 0, 100, 
300, 600, 900. 

6. Click on the OK button. 

7. Select the Define DQ button.  The XY Series editor can now be used to 
define the outflow table. 

8. Select the New button. 

9. Change the Current XY Series Name to "Divert DQ". 

10. Enter the following values, starting with the first table field: 0, 25, 
100, 180, 270. 

11. Click on the OK button of both dialogs. 

18.10   Defining a Reservoir 
As seen in Figure 18-2 to Figure 18-4 a reservoir can be defined in a couple of 
different ways: 1) by using the storage-reservoir routing method, or 2) by 
explicitly creating a reservoir and defining the storage parameters.  For the 
model in this tutorial we have chosen to represent it using the second 
alternative. 

1. Select the outlet E.DAM if the Edit HEC-1 Parameters is still active.  
If you have closed it already select E.DAM and then select the Edit 
HEC-1 Parameters… command from the HEC-1 menu. 

2. Select the Routing Data button. 
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3. Select the Storage (RS) routing option. 

4. Set the nsteps to 1, the Initial condition type to ELEV and RSVRIC to 
851.2. 

5. Select the Reservoir option and click on the Define button. 

6. Select the Known volume option. 

7. Select the SV toggle to turn it on and click on the Define button.  The 
XY Series editor can now be used to define the volume table. 

8. Select the New button. 

9. Change the Current XY Series Name to "E.DAM Volume". 

10. Enter the following values, starting with the first table field: 21, 100, 
205, 325, 955. 

11. Click on the OK button. 

12. Select the SE toggle to turn it on and click on the Define button.  The 
XY Series editor can now be used to define the volume table. 

13. Select the New button. 

14. Change the Current XY Series Name to "E.DAM Elevation". 

15. Enter the following values, starting with the first table field: 850, 
851.5, 853.3, 856.5, 858. 

16. Click on the OK button. 

17. Select the Compute Weir Spillway button. 

18. Select the SL toggle and define the parameters as follows: 
ELEVL=851.2, CAREA=12, COQL=.6, EXPL=.5. 

19. Select the SS toggle and define the parameters as follows: CREL=856, 
SPWID=60, COQW=2.7, EXPW=1.5. 

20. Click on the OK button for both dialogs. 

21. Click on the Done button of the Edit HEC-1 Parameters dialog. 

18.11 Running and Saving HEC-1 Files 
You have now completed the definition of the Red River watershed model and 
are ready to run the analysis (If you haven't done all the work outlined in the 
previous section you can read in the already defined model redri.hc1).  HEC-1 
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is a stand-alone program, but can be launched from within WMS using the 
following steps: 

1. Select the Check Model… option from the HEC-1 menu. 

 This will perform a check on the data and try to determine problems 
that should be addressed before HEC-1 can be successfully run.  If you 
followed the steps in the preceding sections correctly there should be 
no problems.  If you discover some potential problems you should 
correct them before moving on. 

 Just because the model checker does not find any errors, does not 
insure that HEC-1 will compute the correct result, but it should help. 

2. Select Done. 

3. Select the Run HEC-1… option from the HEC-1 menu. 

 HEC-1 needs the names of three files: 1) the input file. 2) an ASCII 
output file outlining the processes used and the final results.  3) a 
TAPE22 solution file containing hydrograph information which can be 
read back into WMS for display. 

4. Enter redriv in the prefix for all files edit field and select the Update 
all prefixes button. 

5. Select OK. 

 When running HEC-1 the input file is automatically saved before 
HEC-1 is launched. 

The View File command in the File menu can be used to examine the ASCII 
output file should problems occur.  On PC's the view file command brings up a 
simple view only program, whereas on UNIX operating systems you can 
specify an editor (vi by default) to bring the file up in. 

18.12  Displaying Hydrograph Results 
The TAPE22 file generated by HEC-1 and stored in the third file specified 
when running HEC-1 from within WMS contains hydrographs for each basin of 
the watershed, for the routed hydrographs from outlet points, and for the 
combination of basin and routed hydrographs at each outlet.  You can read this 
file and display the hydrographs in the hydrograph window.  To read the 
hydrograph file, do the following: 

1. Select the Show Hydrograph Window from the Display menu (If the 
hydrograph window is already mapped you won’t need to use this 
command). 
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2. Select the Open command from the Hydrographs menu. 

3. Find and Open the TAPE22 file (it should be named “redriv.sol” if 
you actually ran HEC-1 as outlined above).  If you did not actually run 
HEC-1, or are having difficulties you can read in “redri.sol”. 

After you have successfully read the hydrograph file, you should see several 
small hydrographs displayed in the upper right corner of each outlet and basin 
in the HEC-1 Tree Window.  You can examine the hydrographs in greater 
detail by selecting them for display in the hydrograph window.  Two 
hydrographs for some of the outlets will be displayed representing the 
hydrograph before and after channel routing.  To view the hydrographs in the 
hydrograph window, do the following: 

1. Select one of the hydrographs by clicking on the miniature. 

2. Hold the SHIFT key down while selecting more hydrographs.  All 
currently selected hydrographs should be displayed in the hydrograph 
window. 

3. Select the Display Options… command from the Display menu. 

4. Select the Plot Options button. 

5. Turn on the Display X grid option. 

6. Turn on the Display Y grid option. 

7. Set any other parameters you wish to experiment with. 

8. Click on the OK button for both dialogs. 
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CHAPTER 19 
Creating Topologic Models For TR-20 

This chapter, if you are familiar with TR-20, will help you understand how 
WMS compares to and how it differs from traditional TR-20 modeling.  It is 
useful for new users of TR-20 as well, since it will help you become familiar 
with what types of structures can be modeled with TR-20, and how they are set 
up in WMS. 

The example problem illustrated here is the Red River watershed.  It is chosen 
since it illustrates many of the basic capabilities available in TR-20.  This 
tutorial will not lead you through every step to completely set up the model.  
Instead you will be shown how to create and enter data for each type of object 
(i.e. basins, outlets, reservoirs, diversions) and then data for other similar 
objects will be provided so that you can repeat the steps.  A completed model 
of the Red River watershed is provided in the tutorial directory.  If you don't 
wish to enter all of the necessary data, or if you want to skim through this 
section and look at the results, you can read this file in using the Open TR-20 
File… command in the TR-20 menu. 

The Red River watershed demonstrates the following capabilities available in 
TR-20: 

• Calculating hydrographs using base flow, losses, and unit hydrograph 
methods. 

• Flood hydrograph routing. 

• Reservoir routing. 

• Diversions. 
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19.1 The Topologic Tree Representation 
The schematic shown in Figure 19-1 illustrates how different components in 
the Red River watershed are modeled using TR-20.  Figure 19-1 shows a 
completed tree diagram for the same watershed created using WMS.  A few 
important differences need to be noted. 

• Names for all hydrograph computation units (outlets, basins, etc.) 
must be unique.  

• Reservoirs are defined with separate icons (triangles) in the traditional 
TR-20 schematic, whereas in WMS they are defined at outlet points. 

 
Figure 19-1 Traditional TR-20 Topological Tree Diagram For Red River 

Watershed. 
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Figure 19-2 puts the E.DAM reservoir at RED20, since there is no need to 
have the outlet at LOSTBR.  The reservoir can be placed at the RED20 outlet.   

 
Figure 19-2 LOSTBR Outlet Eliminated with E.DAM Reservoir at RED20. 

The tree defined in the remaining sections of this tutorial will correspond to 
the one in Figure 19-2. 

19.2 Creating the Tree 

Switch to the Hydrologic Modeling Module .  If you are running the Demo 
version turn it off now.  The following commands can be used to create the 
topological tree for the Red River watershed as shown in Figure 19-2.  All 
commands are in the Tree menu. 

1. Select the Default Model… command and change the current model to 
TR-20.  Select the OK button. 

2. Select the Add Outlet command.  The base outlet will be created and 
highlighted meaning that it is currently selected.  Each time you create 
a new outlet it becomes the selected outlet. 

3. Select the Add Basin command.  Don't worry that the names don't 
match those in Figure 19-2; you can change them later. 

4. Select the Add Outlet command. 

5. Select the Add Reservoir command. 
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6. Select the Add Basin command. 

7. Select the Add Basin command. 

8. Select the Add Outlet command. 

9. Select the Add Basin command. 

10. Select the Add Basin command. 

11. Click on the Outlet named 3C to select it. 

12. Select the Add Diversion command. 

Except for the names, your tree should now look like the one in Figure 19-2.  If 
it does not you can start over by selecting the New command in the File menu, 
or you can use a combination of the Delete and Add commands in the Tree 
menu to correct your tree. 

19.3 Changing Hydrograph Station Names 
WMS requires that all hydrograph stations have a unique six-character 
maximum identification name.  In order to help avoid this problem, default 
names are provided whenever an outlet, basin, diversion, or reservoir is created 
(i.e. 1C, 2C, 1B, 2B, etc.).  You can change the name of these stations to make 
them more identifiable; however, you must remember these two limitations: 

• Names cannot be longer than 6 characters. 

• Names must be unique. 

To change the outlet names do the following: 

1. Click on the outlet point 1C and select the Edit TR-20 Parameters… 
command from the TR-20 menu, or double-click on the outlet point 
(this automatically brings up the Edit TR-20 Parameters dialog). 

The Edit TR-20 Parameters dialog contains several buttons that can be used to 
define/edit data for hydrograph stations.  Only the buttons that pertain to the 
selected hydrograph station are active; all others are dimmed.  You can 
define/edit data by clicking on the appropriate button. 

1. Select the Routing Data button. 

2. Change the Routing combine name from 1C to RED30 and click on the 
OK button. 

3. Select the next upstream outlet 2C.  You may wish to reposition your 
Hydrologic Modeling Window and/or the Edit TR-20 Parameters 
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dialog so that you can see both the tree and the dialog.  You don't need 
to close the Edit TR-20 Parameters dialog.  Data for the next selected 
outlet point will now be displayed. 

4. Select the Routing Data button. 

5. Change the Routing combine name from 2C to E.DAM. 

6. Toggle the Define reach routing toggle box because there is routing 
from this outlet. 

7. Change the routing name from 2R to 20TO30. 

8. Click on the OK button. 

9. Repeat the last four steps, changing 3C to RED10 and 3R to 10TO20.  
Be sure to turn reach routing on for outlet 3C so that the resulting 
hydrograph may be routed downstream from this point. 

To change Basin names do the following: 

1. Click on the basin 1B.  If you accidentally closed the Edit TR-20 
Parameters dialog then double-click on 1B to bring it back up. 

2. Select the Basin Data button. 

3. Change the basin name from 1B to RED30B and click on the OK 
button. 

4. Click on basin 2B. 

5. Select the Basin Data button. 

6. Change the basin name from 2B to WEST20 and click on the OK 
button. 

7. Repeat the last three steps, changing 3B to LOSTBS, 4B to EAST10, 
and 5B to REDRI. 

To change the diversion name do the following: 

1. Click on the diversion arrow D1. 

2. Select the Diversion Data button. 

3. Change the Diversion Name from D1 to DIVERT and click on the OK 
button. 

4. Select the Done button. 
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19.4 Creating the Tree with Feature Objects 
In more recent versions of WMS, the hydrologic modeling tree can be created 
directly from feature arcs (streams) and polygons (basins) (see chapter 4).  
This means that a tree can be created even without a map from which actual 
stream networks and watershed boundaries are digitized.  In such cases the 
feature objects represent a "picture" or "drawing" of the watershed and are not 
used to calculate areas and lengths.  However, the drawing itself may be much 
more instructive to clients and reviewers than just the modeling tree. If you 
want you can read in a map file that contains the same watershed definition 
you have just created by following these three steps: 

1. Select the New command from the File menu and confirm that you 
want delete all data. 

2. Select the Open… command from the File menu. 

3. Find and open the file named “redritr.map”. 

If you choose to do this your model will replace (but be equivalent to) the one 
you have just defined and should look like Figure 19-3.  

 
Figure 19-3  Red River Watershed Defined from Feature Objects. 
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19.5 Job Control Data 
Job control data includes the starting time, time step interval and general 
output specification and other custom features of TR-20.  To modify these data 
do the following: 

1. Select the Job Control… command from the TR-20 menu. 

2. Change the Main time increment to 0.25. 

3. Select the Define Precipitation button. 

4. Select Use standard SCS rainfall distribution for the precipitation 
distribution and Emergency Spillway and Freeboard Design for the 
SCS rainfall table type. 

5. Toggle the options to define rainfall depth and rainfall duration on. 

6. Enter 5.0 inches for the rainfall depth. 

7. Enter 4.0 hours for the rainfall duration. 

8. Select the OK button on both dialogs. 

19.6 Defining Basin Parameters 
TR-20 requires that all basins have an appropriate area, curve number, and 
time of concentration defined.  This tutorial will describe how these 
parameters can be defined for one basin and then a table of values will be 
provided so that the parameters can be defined for the remaining basins. 

1. Click on the basin named RED30B. 

2. Select the Edit TR-20 Parameters… command from the TR-20 menu.  
Once again you may wish to reposition windows. 

3. Select the Basin Data button. 

4. Change the area to .19. 

5. Input 79 for the SCS Curve number. 

6. Input 1.73 for the time of concentration. 

7. Select the OK button. 

Basin parameters for RED30B should now be defined.  You can now select the 
other basins one at a time and repeat the above steps for defining area, curve 
number, and time of concentration using the data given in Table 3.1 
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Table 19.1.  Basin Parameters for the Red River Watershed.
Name Area Curve Number Time of Concentration 

RED30B .19 79 1.73 
WEST20 .80 75 1.57 
LOSTBS .36 75 0.80 
EAST10 .66 75 1.96 
REDRI .82 80 2.45 

19.7 Defining Routing Parameters 
Routing parameters are defined in a similar fashion as basins.  For the Red 
River model channel, routing needs to be defined from RED10 to E.DAM 
(10TO20) and from E.DAM to RED30 (20TO30).  This can be done with the 
following steps: 

1. Select the outlet RED10 if the Edit TR-20 Parameters is still active.  If 
you have closed it already select RED10 and then select the Edit  
TR-20 Parameters… command from the TR-20 menu. 

2. Select the Routing Data button. 

3. Select the option to Define reach routing. 

4. Enter 3000 feet for the reach length. 

5. Notice that there are two methods for defining reach routing.  We will 
use the second (x and m) method.  Keep the default x and m values. 

6. Click on the OK Button. 

7. Select the outlet E.DAM. 

8. Select the Routing Data button. 

9. Select the option to Define reach routing. 

10. Enter 2000 feet for the reach length. 

11. Click on the OK Button. 

19.8 Defining Diversion Data 
Diversion data can be defined by following the steps below: 

Diversions cannot be saved with feature objects (TINs or DEMs either), so 
after creating a watershed using feature objects, diversions still need to be 
entered using the commands in the Tree menu of the Hydrologic Modeling 
Module. 
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1. Select the Hydrologic Modeling module icon . 

2. Select the Select Basin icon tool . 

3. Click on the basin named EAST10 to select it. 

4. Select the Add Diversion command from the Tree menu. 

5. Click on the Outlet point named E.DAM to select it. 

6. Select the Retrieve Diversion command from the Tree menu. 

To change the diversion name do the following: 

1. Select the diversion icon named D1 if the Edit TR-20 Parameters is 
still active.  If you have closed it already, select D1 and then select the 
Edit TR-20 Parameters… command from the TR-20 menu. 

2. Select the Diversion Data button. 

3. Change the name from D1 to DIVERT. 

4. Enter 860 for the constant discharge above which the flow will be 
diverted. 

5. Click on the OK Button. 

19.9 Defining a Reservoir 
In WMS, a reservoir is defined in TR-20 by adding a reservoir at an outlet.  In 
this section, we will define the reservoir data at the E.DAM outlet. 

1. Select the outlet E.DAM if the Edit TR-20 Parameters is still active.  
If you have closed it already select E.DAM and then select the Edit 
TR-20 Parameters… command from the TR-20 menu. 

2. Select the Reservoir Routing button. 

3. Toggle Define reservoir routing to “on”. 

4. Select the Define Reservoir Data button. 

5. Select the New button. 

6. Enter the following values for elevation, discharge, and storage: 

Table 19.2 Reservoir Data 
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Elevation Discharge Storage 
850.00 0.00 21.00 
851.50 15.00 100.00 
853.30 54.00 205.00 
856.50 200.00 325.00 
858.00 496.00 955.00 

• Click on the OK button for both dialogs. 

• Click on the Done button of the Edit TR-20 Parameters dialog. 

19.10 Running and Saving TR-20 Files 
You have now completed the definition of the Red River watershed model and 
are ready to run the analysis (If you haven't done all the work outlined in the 
previous section you can read in the already defined model “redri.dat”).   
TR-20 is a stand-alone program, but can be launched from within WMS using 
the following steps: 

1. Select the Check Model… option from the TR-20 menu. 

 This will perform a check on the data and try to determine problems 
that should be addressed before TR-20 can be successfully run.  If you 
followed the steps in the preceding sections correctly there should be 
no problems.  If you discover some potential problems you should 
correct them before moving on. 

 If the model checker does not find any errors, it does not ensure that 
TR-20 will compute the correct result, but it should help. 

2. Select Done. 

3. Select the Run TR-20… option from the TR-20 menu. 

 TR-20 needs the names of the TR-20 input file, the ASCII output file, 
and the solution file containing hydrograph information that can be 
read back into WMS for display. 

4. Enter redriv in the prefix for all files edit field and select the Update 
button.  If necessary select a directory to save the TR-20 files in by 
clicking on the file browser button.  When running TR-20 the input 
file is automatically saved before TR-20 is launched. 

5. Click on the OK button.  TR-20 will run and the hydrographs will be 
read in at the hydrograph stations. 

The View File command in the File menu can be used to examine the ASCII 
output file should problems occur.  On PC's the view file command brings up a 
simple view only program, whereas on UNIX operating systems you can 
specify an editor (vi by default) to bring the file up in. 
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19.11 Displaying Hydrograph Results 
The “.THY” file generated by TR-20 and stored in the third file specified when 
running TR-20 from within WMS contains hydrographs for each basin of the 
watershed, for the routed hydrographs from outlet points, and for the 
combination of basin and routed hydrographs at each outlet.  You can read this 
file and display the hydrographs in the hydrograph window.  To read the 
hydrograph file, do the following: 

1. Select the Show Hydrograph Window command from the Display 
menu (if the hydrograph window is already mapped you will not need 
to do this). 

2. Select the Open… command from the Hydrographs menu. 

3. Find and Open the “.THY” file (it should be named “redriv.thy” if you 
actually ran TR-20 as outlined above).  If you did not actually run TR-
20, or are having difficulties you can read in “redri.thy”. 

After you have successfully read the hydrograph file, you should see several 
small hydrographs displayed in the upper right corner of each outlet and basin 
in the TR-20 Tree Window.  You can examine the hydrographs in greater detail 
by selecting them for display in the hydrograph window.  Two hydrographs for 
some of the outlets will be displayed, representing the hydrograph before and 
after channel routing.  To view the hydrographs in the hydrograph window, do 
the following: 

1. Select one of the hydrographs by clicking on the miniature. 

2. Hold the SHIFT key down while selecting more hydrographs.  All 
currently selected hydrographs should be displayed in the hydrograph 
window. 

3. Select the Display Options… command from the Display menu. 

4. Select the Hydrologic Modeling tab. 

5. Select the Plot Options… button. 

6. Turn on the Display X grid option. 

7. Turn on the Display Y grid option. 

8. Set any other parameters you wish to experiment with. 

9. Click on the OK button for both dialogs. 
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CHAPTER 20 
HSPF Interface 

This chapter demonstrates how WMS can be used to process digital elevation 
and land use data to develop an HSPF input (.uci) file.  The graphical user 
interface used to define input parameters is demonstrated for a basic hydrology 
simulation that includes doing the following: 

• Delineating watershed segment boundaries from a digital terrain model 
and USGS land use file. 

• Defining segment parameters for a hydrologic analysis. 

• Developing reach segment parameters. 

• Defining precipitation time series data from standard .wdm database 
files. 

• Entering mass links to define transformations from basin to reach. 

20.1 Opening the Watershed and Initializing the HSPF Model 
You will open a watershed that has been delineated from a USGS 7.5’ DEM 
and converted to a TIN. 

1. Select the Open command from the File menu. 

2. Locate and choose the file named: littlecotton.wpr 

3. Select OK. 
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The watershed will appear on your screen with the area displayed in the center 
of the basin.  This indicates that the Basin Data has been computed and you are 
ready to set up the HSPF model.  To initialize the model: 

1. Change to the Hydrologic Modeling module . 

2. Go to the HSPF menu and choose HSPF Global Options. 

3. Click the Initialize HSPF Data button – all fields will become active, 
indicating that the HSPF model is ready for input data. 

You will now enter the parameters to indicate that the model will simulate 
about 3 years of time with a time step of 1 day.  You will also name the model, 
choose the units to use, specify output levels, and name the input/output files: 

 

1. Enter Little Cottonwood Canyon Model in the Title field. 

2. Click on the Start Time button; enter Year: 1996, Month: 1, Day: 1, 
Hour: 0, Minute: 0. 

3. Click OK; the start date will appear to the right of the Start Time 
button. 

4. Click on the End Time button; enter Year: 1999, Month: 7, Day: 31, 
Hour: 0, Minute: 0. 

5. Click OK; the end date will appear to the right of the End Time button. 

6. Enter 24 in the hours field under the Time step heading (leave minutes 
at 0). 

7. Ensure that the Units flag is set to English. 

8. Change the Run Flag to 1; this indicates that HSPF will interpret the 
data and run the simulation (0 indicates that HSPF will only interpret – 
error check- the data). 

9. Set the OUTLEV to 10 (under Output Levels); this indicates maximum 
output to the Error and Warning files. Leave the SPOUT flag at 0 (this 
is only for Special Actions). 

10. In the Files section, enter littlecotton in the Prefix field, then click the 
Update Filenames button.  This names all the HSPF input/output files 
associated with this model to the same name.  Note:  you have just 
indicated that you will be using a file named “littlecotton.wdm” for 
time series input and output – this file must be created and named 
appropriately outside of WMS (this has been done for you in this 
case). 



 Creating Topologic Models for HEC-1 20-3

11. Select OK. 

The Global Options are now set for you model.  You are now ready to proceed 
to segmenting the watershed and entering parameters for the segments. 

20.2 Importing Land Use and Segmenting the Watershed 
To divide this watershed into hydrologically similar segments, you will 
overlay a land-use data layer.  You will read this data from an ArcView 
Shapefile: 

1. Go to the File menu and choose Import. 

2. Select the file named littleclanduse.shp and click Open. 

3. Click OK on the Import File dialog to indicate that you want to import 
a Feature Object Polygon Shape File. 

4. When the Import Shapefile Data dialog appears, click on the Coverage 
Options button.  This will allow you to create a new coverage for the 
land-use data. 

5. Click New in the Coverages dialog, enter Land Use Data in the Name 
field, and choose Land Use in the Attribute Set box. 

6. Click OK to return to the Import Shapefile Data dialog; note that the 
new coverage you just created is now active and listed by the 
Coverage Options button. 

7. Click on the Attribute Mapping button under Polygons.  This will 
allow you to choose the database fields that correspond to WMS 
attributes. 

8. Choose LUCODE in the Database fields window and Land Use in the 
Coverage attributes window, then click on the Map button.  You will 
see a new line appear in the lower window. 

9. Choose PERIMETER=> Basin perimeter line in the lower window 
and click Unmap.  This attribute recognized automatically by WMS, 
but is not needed in this case. 

10. Choose Done. 

11. Choose OK in the Import Shapefile Data dialog to read the file. 

You will see the land use data polygons overlaid on the watershed.  You are 
now ready to compute HSPF segments based on the land use polygons that fall 
inside the watershed. 
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1. Go to the Calculators menu and choose Compute GIS Attributes. 

2. Choose HSPF Segments from the Computation drop-down list. 

3. In the central section of the dialog, ensure that Land use coverage 
appears in the data type box and that Land Use Data appears as the 
name of the coverage to be used for the computation. 

4. A text file that correlates the land use id to land use attributes (name, 
perviousness, etc.) must be read in.  Click the Import button to browse 
for this file. 

5. Choose the file named littleclanduse.tbl; Click Open to read it into 
WMS. 

6. Choose OK in the Compute GIS Attributes dialog to compute the 
HSPF segments. 

7. Click OK when warned that Continuing will delete all HSPF segment 
data. 

You should now see the segments computed for the watershed displayed.  
Each colored area represents a segment to be modeled by HSPF.  To better 
view the segments, you will need to change some display options. 

1. Switch to the Map module . 

2. Go to the Feature Objects menu and choose Coverages. 

3. Make sure that the Land Use Data coverage is selected, then toggle 
OFF the Visible checkbox. 

4. Click OK; the land-use coverage is no longer visible.  

5. Go to the Display menu and choose Display Options. 

6. Choose the tab entitled TIN 

7. Toggle ON the Land use legend. 

8. Click OK. 

You should now see the land use legend which shows the color and title of 
each segment in the watershed.  You may want to Pan an/or Zoom to avoid 
having the legend appear over the watershed. 
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20.3 Aggregating Segments 
You will note from the display that there are several land segments in the 
watershed.  Some are quite large, such as the Evergreen Forest Land segment, 
while others are rather insignificant, like Bare Exposed Rock.  To make this 
simulation more simple, you will aggregate some of these segments and delete 
some others. 

1. Switch to the Hydrologic Modeling module . 

2. Select the basin icon by clicking on it. 

3. Go to the HSPF menu and choose Edit HSPF Attributes. 

4. Note in the Edit HSPF Attributes dialog the list of segments in the 
Basin Data window.  There are 8 separate segments (or land use 
classifications) in this watershed.. 

There are two ways to reduce the number of segments computed by WMS.  
The first is to delete one segment, then add the area of the deleted segment to 
another similar segment (aggregate segments).  The second is to just delete the 
segment, then let WMS redistribute the deleted area to the remaining segments 
(an area-weighted distribution is used). 

1. Choose segment entitled Other Urban Or Build Up from the Basin 
Data window.  Note that the area is about 35 acres – insignificant in 
this watershed. 

2. Click the Delete Button. 

3. Repeat steps 1 and 2 for the segment entitled Bare Ground. 

4. Click Done. 

5. Switch to the TIN module . 

6. Go to the Drainage menu and Choose Compute Basin Data; click OK 
on the Compute Basin Data dialog to proceed.  This will recompute 
basin data and distribute the deleted segments’ areas to the remaining 
segments. 

7. Now you will aggregate some segments.  Switch back to the 

Hydrologic Modeling module . 

8. Select the basin icon by clicking on it. 

9. Go to the HSPF menu and choose Edit HSPF Attributes.  Note that 
there are only 6 segments listed now. 
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10. Choose the segment entitled Mixed Forest.  Note the area of 445.775 
acres; this is the area that you will add to the Evergreen Forest 
segment to aggregate the two segments. 

11. Click the Delete Button to delete segment 6. 

12. Choose Evergreen Forest segment.  Note the area is 12207.985 acres. 

13. Enter the new Area = 12653. 76 acres (12207.985 + 445.775).  You 
have successfully aggregated two segments. 

14. Aggregate segments by deleting the Bare Exposed Rock segment and 
adding its area to the segment Mixed Tundra.  The new total area will 
be 1385.752 acres. 

15. Choose Done to exit the Edit HSPF Attributes dialog. 

You are now left with 4 land segments.  These are the segments for which you 
will now input parameters and simulate with HSPF. 

20.4 Defining Land Segment Parameters 
You are ready to begin defining parameters for the land segments of the HSPF 
model.  This model will be set up for purely hydrologic analysis; thus, you will 
be activating and inputting parameters only to the SNOW and WATER 
modules of HSPF.  Further, to decrease the time needed to complete the 
tutorial, you will fully set up one segment then copy those parameters to the 
other 3 in the model.  Do the following to complete these tasks: 

1. Select the basin icon by clicking on it. 

2. Go to the HSPF menu and choose Edit HSPF Attributes. 

3. Choose the Evergreen Forest segment from the Basin Data window. 

4. Click the Define Activities button. 

5. Click the boxes next to Snow (SNOW) and Water (PWAT) to 
checkmark them.  Note that the buttons become active upon checking 
the corresponding box. 

You have just activated the Snow and Water modules for this pervious land 
segment.  You must now enter the parameters for each active module to allow 
HPSF to simulate the segment correctly. 

1. Click on the SNOW button in the Pervious Land Activity dialog. 
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2. In the SNOW dialog that appears, enter the following values in the 
appropriate fields (leave other fields at the default values; these values 
are either generally recommended values or HSPF defaults): 

SNOW-PARM1 SNOW-PARM2 SNOW-INIT1 SNOW-INIT2 
LAT = 40.5 degrees 
MELEV = 8410.8 ft 
SHADE = 0.40 

TSNOW = 35.0 degrees 
MWATER = 0.2 

Pack-snow = 4.0 in 
Pack-ice = 2.0 in 
Pack-watr = 2.0 in 

SKYCLR = 1.0 

Note: these values were extracted from meteorological datasets. 

1. Now that all values are entered for this segment, click the Apply 
Parameters to Segments button.  This will allow you to assign these 
same parameters to other segments in the model. 

2. Choose Shrub & Brush Rangeland in the Available Segments window; 
move it to the Selected Segments window by clicking the  button. 

3. Repeat step 2 for Residential and Mixed Tundra. 

4. Click OK.  The selected segments will be assigned the same 
parameters input here. 

The final step in entering parameters for a module in HSPF is to define time 
series input (External Sources) and time series output (External Targets).  For 
the land segments in this model, you will define External Sources for input 
data, but no External Targets will be specified – you will choose output to be 
given at the outlet of the watershed, not at each land segment. 

1. Click on the External Sources button in the SNOW dialog.  The Assign 
External Sources dialog will appear with a list of the datasets available 
in the WDM file specified for this model (littlecotton.wdm). 

2. Assign the following datasets as sources by setting the fields to the 
appropriate values, then clicking the Assign button for each line.  If 
you make a mistake, choose the incorrect line in the lower window and 
click Delete. 

Member 
Name 

Member 
subscript 

Units Missing 
Data 

Transformation Quality 
flag 

Multiplicatio
n Factor 

Dataset 

PREC  ENGL UNDF SAME 0 0.25 3 
PREC  ENGL UNDF SAME 0 0.75 7 
DTMPG  ENGL UNDF AVER 0 1.0 14 
WINMOV  ENGL UNDF AVER 0 1.0 15 
SOLRAD  ENGL UNDF SAME 0 1.0 16 
AIRTMP  ENGL UNDF AVER 0 0.4 17 
AIRTMP  ENGL UNDF AVER 0 0.6 18 

 

1. Since you will add other External Sources to this segment with the 
PWAT module input, you will not assign the External Sources to other 
segments yet.  Click Done to return to the SNOW dialog. 

2. Click OK to return to the Pervious Land Activities dialog. 
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You have completed the set up of the SNOW module.  You will now repeat the 
same basic steps to set up the PWAT module for the land segments of the 
model. 

1. Click on the PWAT button in the Pervious Land Activity dialog. 

2. In the PWATER dialog that appears, enter the following values in the 
appropriate fields (leave other fields at the default values): 

PWAT-PARM1 PWAT-PARM2 PWAT-PARM3 PWAT-
PARM4 

PWAT-
PARM5 

PWAT-
STATE1 

CSNOFG = On 
RTOPFG = On 
UZFG = On 

LZSN = 5.0 
INFILT = 0.48 
LSUR = 2258.0 
SLSUR = 0.25 
KVARY = 0.7 
AGWRC = 0.997 

DEEPFR = 0.1 
PETMAX = 
35.0 
PETMIN = 30.0 

CEPSC = 0.1 
UZSN = 1.0 
NSUR = 0.25 
INTFW = 3.0 
IRC = 0.7 
LZETP = 0.8 

 CEPS = 0.2 
UZS = 1.0 
LZS = 6.0 
AGWS = 1.6 
GWVS = 1.9 

 

1. Now that all values are entered for this segment, click the Apply 
Parameters to Segments button.  This will allow you to assign these 
same parameters to other segments in the model. 

2. Choose Shrub & Brush Rangeland in the Available Segments window; 
move it to the Selected Segments window by clicking the  button. 

3. Repeat step 2 for Residential and Mixed Tundra. 

4. Click OK.  The selected segments will be assigned the same 
parameters input here. 

Now you must define the additional External Sources needed for the PWATER 
simulation.  Most of the External Sources entered for the SNOW module are 
also used for the PWATER module, but there is one input series is not yet 
entered. 

1. Click on the External Sources button in the PWATER dialog.  The 
Assign External Sources dialog will appear with the sources that you 
created for this segment in the SNOW module listed in the lower 
window.   

2. Assign the following dataset (evapotranspiration) as a source by 
setting the fields to the appropriate values, then clicking the Assign 
button.  If you make a mistake, choose the incorrect line in the lower 
window and click Delete. 

 
Member 

Name 
Member 

subscript 
Units Missing 

Data 
Transformation Quality 

flag 
Multiplication 

Factor 
Dataset 

PETINP  ENGL UNDF SAME 0 1.0 23 

 



 Creating Topologic Models for HEC-1 20-9

All the External Sources needed for the simulation are now assigned to this 
segment.  You will now copy these same External Sources to all other land 
segments in the model. 

1. Click the Apply Sources to Segments button.  This will allow you to 
assign these same External Sources to other segments in the model. 

2. Choose Shrub & Brush Rangeland in the Available Segments window; 
move it to the Selected Segments window by clicking the  button. 

3. Repeat step 2 for Residential and Mixed Tundra. 

4. Click OK. 

5. Click Done in the Assign External Sources dialog. 

6. Click OK in the PWATER dialog. 

7. Click OK in the Pervious Land Activities dialog. 

The Edit HSPF Attributes dialog should now be active.  You have successfully 
set up the SNOW and PWATER modules for all land segments in the model 
(remember that you set up the modules explicitly for the Evergreen Forest 
segment and then copied the parameters to all other segments).  You may want 
to ensure/review the set up for the other segments by choosing the segment in 
the Basin Data window, then clicking the Define Activities button and 
reviewing the SNOW and PWATER input. 

Now that the land segment data is complete, you will enter data for the reach 
(stream) segment of the model. 

20.5 Defining Reach Segment Parameters 
To simulate runoff in-stream, you will need to activate the HYDR module for 
the reach segment of the model.  You will also need to specify the output 
dataset needed (a hydrograph in this case) to view the results of the simulation. 

1. Click on the watershed outlet in the Graphics Window (this can be 
done while the Edit HSPF Attributes dialog is still present; double-
click the outlet if you have already closed the Edit HSPF Attributes 
dialog).  The Reach/Reservoir Data section of the Edit HSPF 
Attributes dialog will be come active and display the name of the 
outlet chosen (Little). 

2. Click on the Define Activities button. 

3. Check the box to activate the Hydraulics (HYDR) module of HSPF for 
this reach. 
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4. Click the HYDR button in the Reach/Reservoir Activities dialog. 

5. In the HYDR dialog that appears, enter the following values in the 
appropriate fields (leave other fields at the default values): 

HYDR-
PARM1 

HYDR-PARM2 HYDR-INIT 

ODFVFG = 4 Length = 13.82 
DeltaH = 2200.0 

 

 

The next input you must enter is the FTABLE for the reach.  The FTABLE is a 
spreadsheet-like table that contain the conveyance parameters of the reach 
(depth, area, volume, and outflow).  This table may be calculated manually or 
with the help of the Channel Calculator in WMS. 

1. Click on the Define FTABLE button the HYDR dialog. 

2. In the FTABLE dialog that appears, enter the following values (it is 
possible to change the number of rows and columns in the FTABLE, 
but the default values will be sufficient in this case): 

Depth (ft) Area (ac) Volume (ac-ft) Outflow (cfs) 
0.0 0.0 0.0 0.0 
0.25 25.99 6.393 13.876 
0.5 26.828 12.995 43.954 
0.75 27.666 19.807 86.269 
1.0 25.50 26.828 139.241 
1.25 29.340 34.059 201.950 
1.5 30.181 41.499 273.794 
1.75 31.019 49.150 354.355 
2.0 31.858 57.009 443.334 
2.25 35.211 90.540 879.902 

 

1. Click OK to save the FTABLE. 

The final task in defining the reach parameters is to specify the output you 
want to see from the reach and where HSPF will write the output.  This is done 
by defining an External Target.  You will specify that you want a hydrograph 
to be output to a dataset in the WDM (littlecotton.wdm) for this reach. 

1. Click on the External Targets button in the HYDR dialog. 

2. Set the following fields to the specified values: 
Member 

Name 
Member 

subscript 
Units Access Aggregation Multiplication 

Factor 
Quality 

flag 
Transformation 

Function 
RO  ENGL REPL Aggregate 1.0 0 AVER 

 

1. Select the Use existing dataset button. 

2. Click on the Select Dataset button 
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3. In the Select Dataset dialog, scroll down and select dataset 20 (Flow), 
then click the OK button. 

4. The Dataset name, type, and number should appear in the Assign 
External Targets dialog. 

5. Click Assign to add the External Target line to the lower window. 

6. Click Done. 

You have now completed the input for the HYDR module in this reach.  This 
will be the only module active for this simulation; thus, you can exit the 
parameter editing dialogs. 

1. Click OK in the HYDR dialog. 

2. Click OK in the Reach/Reservoir Activity dialog. 

3. Click Done in the Edit HSPF Attributes dialog. 

The input for all land and reach segments is now complete in the model.  The 
last task before saving and running the HSPF model is to assign Mass Links. 

20.6 Creating Mass Links 
Mass Links control how materials (water, sediment, constituents) are 
transferred from land segments to reaches, and from one reach to the next.  
Conversions in units, such as inches/acre per day of runoff  cubic feet per 
second, are defined in the Mass Links also.  You will enter Mass Links to 
transfer water from land to reach and from reach to reach for this model. 

1. Go to the HSPF menu and choose Mass Link Editor. 

2. When you enter the Mass Link Editor, it is set to begin adding/deleting 
mass links for PERLND segments.  Set the fields to the values below: 

 
Volume 
Name 

Volume 
Group 

Volume Member 
Name 

Multiplication 
Factor 

Target 
Name 

Target 
Group 

Target Member 
Name 

PERLND PWATER PERO 0.083333333 RCHRES INFLOW IVOL 

Note: 0.0833333 is the conversion for inches/acre per day  cfs. 

1. Click Add Link (if you make a mistake, select the link in the window 
and click the Delete Link button). 

2. Change the Segment Type (upper left) to IMPLND. 

3. Set the fields to the values below: 
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Volume 
Name 

Volume 
Group 

Volume Member 
Name 

Multiplication 
Factor 

Target 
Name 

Target 
Group 

Target Member 
Name 

IMPLND IWATER SURO 0.083333333 RCHRES INFLOW IVOL 

   

1. Click Add Link. 

2. Change the Segment Type (upper left) to RCHRES. 

3. Set the fields to the values below: 
Volume 
Name 

Volume 
Group 

Volume Member 
Name 

Multiplication 
Factor 

Target 
Name 

Target 
Group 

Target Member 
Name 

RCHRES HYDR ROVOL 1.00 RCHRES INFLOW IVOL 

  

1. Click Add Link. 

The Mass Links needed for PERLND, IMPLND, and RCHRES segments are 
now set up.  You are ready to save and run the model. 

1. Click OK to exit the Mass Link Editor. 

20.7 Saving and Running HSPF Simulation 
The last step is to save and run the HSPF simulation.  To do this, select the 
Run HSPF command from the HSPF menu.  HSPF should run to completion.  
You will then be able to view the solution. 



 

21 Coordinate Conversions 

CHAPTER 21 
Coordinate Conversions 

Making sure that your data is in the right coordinate system, and specifying the 
appropriate units is an important part of any modeling project.  In this brief 
tutorial you will learn how you can define the current coordinate system of 
your input data (DEMs, TINs, feature objects, images, etc.), and how you can 
transform individual data files so that units among data sources will be 
consistent.  You will also learn how you can transform the coordinate system 
and/or units of all of the data into another coordinate system. 

There are three occasions when transforming coordinates becomes important: 

1. You may have a watershed that spans zones within a given coordinate 
system. 

2. You may have data for your watershed model, but the data is in 
different coordinate systems.  For example, you may have elevation 
data in one coordinate system and land use data in another coordinate 
system. 

3. Your data may be in one coordinate system, but perhaps you want to 
work in another coordinate system.  For example, all the data in your 
county’s GIS database may be in one coordinate system, but your data 
is in another coordinate system. 

21.1 Background Information on Coordinate Systems 
Most data (in the U.S.) comes in either the Universal Transverse Mercator 
(UTM) or State Plane Coordinate Systems.  Because the UTM system provides 
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a more uniform definition, much of the data distributed on a National or 
international level comes in this format.  However, many of the state and local 
regulating agencies (for which hydrologic projects are done) require the use of 
State Plane coordinates.  Because of this it is quite often that you will want to 
convert your data from UTM (or some other coordinate system) to State Plane.  
An example of doing this is included as part of this tutorial. 

21.1.1 UTM Coordinate System 
A UTM (Universal Transverse Mercator) system is a world-wide system 
defined in meters. The world is divided into 60 zones, 6 degrees of longitude, 
running from 84°N to 80°S latitude. While Northings (y coordinates) are 
generally the same from zone to zone, Eastings (x coordinates) start over 
within each zone. This means that if you have a watershed or other data that 
happens to straddle a UTM zone boundary, the coordinates from the two data 
sets (for example two adjacent DEMs) will not be adjacent!  Fixing this 
particular problem is the topic of one of the tutorial sections.  The zones that 
cover the conterminous US are shown in the figure below. 

 

21.1.2 State Plane Coordinate System 
The definition used for State Plane coordinates vary from state to state and 
within states.  The figure below illustrates how states in the west (this is 
similar for eastern states, although many smaller states may have only a single 
coordinate zone) are divided into separate zones within a state.  As with UTM 
coordinates, XY values (eastings and northings) are defined uniquely only 
within a given zone and therefore you may be required to convert data from 
one zone to another to have a consistent coordinate definition within a project 
area. 
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21.1.3 Typical Problems Requiring Coordinate Transformation 
There are three primary reasons why you might need to transform coordinates 
from one system to another in a WMS project: 

1. If you have a watershed that spans zones within a given coordinate 
system.  For example if you have two DEMs that are needed and one is 
in UTM zone 12 and the other UTM zone 13 then you will need to 
transform one of the DEMs into the others coordinate system. 

2. You have some data in one coordinate system and other data in 
another.  For example, you may have your DEM data in UTM 
coordinates and your land use and soils data in State Plane.  If you 
want to calculate a CN value then you will need to have all your data 
in the same coordinate system or the data will not overlay properly.  
As with the first case, you can either convert the DEM data to State 
Plane or you could convert the land use and soil data to UTM. 

3. You may just want to convert all of your data from one coordinate 
system to another.  For example, you may have all of the data you need 
in the UTM coordinate system, but you may be required to provide 
results in State Plane coordinates.  You may also just want to convert 
data from metric to English, or English to metric units. 

There are obviously a lot of different scenarios for which data might need to be 
transformed from one coordinate system to another, but the three examples 
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above should give you an idea of the issues that might encounter, and should 
help you plan your projects accordingly.  The examples in this tutorial 
demonstrate how to convert data from one coordinate system to another in 
WMS. 

21.1.4 The Current Coordinate System 
When you read data into WMS it is a good idea to immediately set the current 
coordinate system using the option from the Edit menu.  If you don’t then the 
default of a local coordinate system using feet units is assumed.  As long as 
your data are in English units (feet) calculations by WMS will be displayed 
correctly.  If your are data are in meters then as a minimum you need to change 
the units to reflect this, particularly at the point where you compute basin data.  
It is not required to know the actual coordinate system your data is in (i.e. 
UTM or State Plane, Datum, Zone number, etc.), but it is essential to have the 
correct units.  If you do want to transform coordinate systems then you do need 
to know the full specifications of the current coordinate system and the one 
you want to transform to.  Because of the way WMS manages coordinate 
systems there is a certain order that you should follow for properly converting 
data.  The examples in this tutorial illustrate the following three scenarios.  
These scenarios should give you an understanding of how to approach 
transformations in WMS: 

1. You have data in one coordinate system and want to convert to 
another. 

2. You have data in the same coordinate system, but different zones. 

3. You have data in three different coordinate systems and want to get 
them all into a consistent coordinate system. 

21.1.5 Proper Order of Reading Data 
Because the coordinate conversion tools operate on all data simultaneously 
(DEMs, TINs, Imaged, Feature Objects, etc.) it is not possible to read in data 
that are in two or more coordinate systems and convert one dataset or the other 
only, or to convert both to the same coordinate system.  For this reason, you 
will often want to read each data set in separately, convert to the proper 
coordinate system, and save again.  Once all data have been converted and 
saved, all the data may be read into together and the current coordinate system 
may be defined.  One exception to this rule is if you have data in only two 
coordinate systems, of which one is the desired coordinate system for your 
project.  In this case you would first read in the data you want to convert.  You 
would then convert the data to the desired coordinate system.  Finally, you 
would read in the remaining data that is already in the proper coordinate 
system. 
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21.2 Converting Data From one Coordinate System to Another 
In this first example, you have data in UTM Coordinates.  But you want to 
work in State Plane coordinates. 

1. Select the Open command from the File menu. 

2. Find and Open the file named utm.map. 

3. Select the Import command from the File menu. 

4. Find and Open the file named aspen.dem. 

5. Set the Import file type to USGS DEM and select OK. 

6. Select OK to import the DEM. 

7. Select the DEM module . 

8. Select the Contour Options from the Display menu. 

9. Toggle on the option for the Display Legend. 

10. Select OK. 

21.2.1 Setting the Current Coordinate System 
If you move your cursor over the data you should notice that the coordinates 
correspond to the limits as shown in the following figure.  Also note the range 
of elevation values from the contour legend. 



21-6 WMS Tutorials 

 

1. Select the Current Coordinates option from the Edit menu. 

2. Set the Horizontal System to UTM NAD 27 (US). 

3. Set the UTM Zone to 12 114W to 108W. 

4. Set the horizontal Units to Meters. 

5. Leave the Vertical System as Local. 

6. Set the vertical Units to Meters. 

7. Select OK. 

21.2.2 Converting from UTM to State Plane 
In this case all of our data are in UTM.  We could continue to work on our 
project in this coordinate system.  However, perhaps we want to be able to 
overlay our results with data in another coordinate system (such as State 
Plane).  Or maybe a state or local agency for which we are doing the project 
requires the data in a different coordinate system—then we would need to 
convert. 

1. Select the Map module . 
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2. Delete the drawing objects on the screen by selecting the Delete 
command from the Drawing Objects menu. 

3. Select OK to delete all the drawing objects. 

4. Select the Coordinate Conversion command from the Edit menu. 

 You will note that current coordinate system defined in the previous 
section is already set, but you could (and would have to) define from 
this dialog if you wanted to. 

5. Set the Horizontal System to State Plane NAD 27 (US). 

6. Set the St. Plane Zone to Utah Central – 4302. 

7. Set the Horizontal Units to U.S. Survey Feet. 

8. Leave the Vertical System as Local. 

9. Set the Vertical Units to U.S. Survey Feet. 

10. Select the Convert button. 

At first glance it will not appear that anything has changed.  However, notice 
the range of elevations in the legend now correspond to feet or English units 
rather than metric.  Also, if you move your cursor over the model, you will see 
that the limits now correspond to the limits shown in figure below.  Compare 
this to the previous figure. 
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21.3 Converting Data to Consistent UTM Zones 
In this part of the tutorial you will learn how to convert sets of data straddling 
a coordinate zone boundary to a consistent coordinate zone so the data can be 
used together for a project. 

The figure below identifies two 7.5-minute quadrangles in Colorado that 
straddle UTM Zones.  Longitude 108 West is divisible by 6—making it a 
boundary between coordinate zones (zones 12 and 13 in this case – see the 
UTM zones figure at the beginning of this chapter).  This means that even 
though the Parachute and Rulison quadrangles should be adjacent to each other 
when we read them into WMS, the X values of Parachute will be much larger 
than those of Rulison because they “start over” again as we move from zone 12 
(west of 108) to Zone 13 (east of 108). So…to use these together in a project 
we have to either convert Rulison to equivalent coordinates for Zone 12 or 
Parachute to 13. You should know that “starting over” again doesn’t mean 
starting with 0 in this case since UTM X coordinates have a “false” easting.  
This “false” easting is a good thing too…otherwise, converting Parachute to 
Zone 13 would mean giving it negative X coordinates.  This could prove 
problematic for some calculations. 



 Creating Topologic Models for TR20 21-9 

 

1. Select the New command from the File menu and confirm that you 
wish to delete all data. 

2. Select the Import command from the File menu. 

3. Find and Open the file named 1143CEL0.DDF. (actually you could 
pick any of the 1143***.DDF files since this is an SDTS formatted 
USGS DEM). 

4. Specify the Import File option as USGS DEM. 

5. Select the Add button. 

6. Find and Open the file named 1144CEL0.DDF. 

At this point you should notice the problem that occurs when two DEMs 
straddle a UTM boundary – the Rulison quadrangle appears to be to the west 
(in fact, far to the west) since the X coordinates are starting over as we move 
into Zone 13.  Therefore, you do not want to import these DEMs together.  To 
be able to merge them we will need to do the following: 

• Import Rulison (1143***.DDF) and export this file as an Arc/Info ASCII 
Grid file.  After converting Parachute, we will have to export the 
Parachute DEM to an Arc/Info ASCII Grid file (since to merge two 
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DEMs they must have the same format).  For this reason, we have to 
convert the Rulison quadrangle to the Arc/Info ASCII grid format. 

• Import Parachute, convert the Parachute DEM to Zone 13, and export 
the Parachute DEM as an Arc/Info ASCII Grid file. 

• Import both quadrangles together. 

1. Select the Parachute, Co – 2400 quadrangle from the Files text list 
box. 

2. Select the Delete Button. 

3. Select OK. 

4. Select the Export command from the File menu. 

5. For the Save as type: select Arc/Info Grid (*.asc). 

6. Change the filename to rulison.asc. 

7. Select the Save button. 

We have now converted the Rulison DEM to the Arc/Info ASCII grid format.  
Than, when we are finished converting the other DEM, we can import the two 
DEMs together.  We must convert the format of the Rulison DEM since it is 
not possible in WMS to save a DEM in the USGS SDTS format; nor is it 
possible to read in two DEMs of different formats. 

1. Select the New command from the File menu and confirm that you 
wish to delete all data. 

2. Select the Import command from the File menu. 

3. Find and Open the file 1144CEL0.DDF. 

4. Select the Import File Type to be USGS DEM and select OK. 

5. Select the OK button to import the DEM. 

6. Select the Coordinate Conversion command from the Edit menu. 

7. Select the Current Coordinates button and define the DEM 
coordinates to be UTM NAD 27 (US), Zone 12, with units of Meters 
for both horizontal and vertical (leave the vertical system as Local). 

8. Select OK. 
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9. Now set the conversion coordinate system to UTM NAD 27 (US), Zone 
13, and units of Meters for both horizontal and vertical (again leave 
the vertical system to Local). 

10. Select the Convert button. 

11. Select the Export command from the File menu. 

12. For the Save as type: select Arc/Info Grid (*.asc). 

13. Change the filename to parachute.asc. 

14. Select the Save button. 

We now have the Parachute DEM saved in UTM Zone 13 coordinates so it 
will be placed geographically next to the Rulison DEM.  With both DEMs now 
saved in the Arc/Info ASCII grid file format, we can read them in together. 

1. Select the New command from the File menu and confirm that you 
wish to delete all data. 

2. Select the Import command from the File menu. 

3. Find and Open the file named rulison.asc. 

4. Select the Import file type to be Arc/Info Grid File and select OK. 

5. Select the Add button. 

6. Find and Open the file named parachute.asc. 

7. Select the OK button to import both DEMs. 

8. Select the DEM module . 

9. Select the Display Options command from the Display menu. 

10. Toggle on the display of No data cells. 

You will see a small gap of undefined elevations near the bottom of the two 
DEMs.  This is a common occurrence when transforming grids and so you 
must now interpolate across the boundary to fill in the gap. 

1. Select the Select DEM cells tool . 

2. Drag a box around the no data cells in the gap between the two DEMs. 

3. Select the Fill NODATA Cells command from the DEMs menu. 
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You have now completed the transformation of the Parachute quadrangle from 
UTM Zone 12 coordinates to UTM Zone 13 coordinates so that it could be 
used together with the Rulison quadrangle to delineate a watershed.  This same 
process would apply no matter what type of data you have (DEMs, TINs, 
Feature Objects, etc.).  Remember though in the case of the DEMs we had to 
first read in the Rulison quadrangle and export it as an Arc/Info ASCII grid.  
Then, after converting the Parachute quadrangle, we were able to read the two 
in together. 

21.4 Converting Data from Multiple Coordinate Systems 
In this example, the coordinate system we want to work in is the UTM 
coordinate system.  We have a DEM already in the correct UTM coordinates, 
but our land use file is in State Plane while our soils file is in Geographic 
(latitude – longitude) coordinates. 

We will first read the soils file in, convert the file, and then save the file.  
Second, we will read the land use file in and convert it.  At this point, all three 
data sets are in the UTM coordinate system.  Then, we can read the soil file 
back in and then import the DEM. 

1. Select the Map module . 

2. Select the Import command from the File menu. 

3. Find and Open the file named aspensogeographic.shp. 

4. Make sure the Import file type is Feature Object Polygon Shape File 
and then select OK. 

5. Select the Coverage Options button. 

6. Set the Attribute Set to Soil Type. 

7. Confirm that you want to change the coverage type. 

8. Select OK. 

9. Select OK to import the soils. 

You have now imported the soils file.  If you move your cursor over the soils 
data and notice the x-y-z coordinate tracking window you should see that these 
data are in Geographic or latitude longitude coordinates.  Negative x values are 
indicative of longitudes in the western hemisphere. 

1. Select the Coordinate Conversion command from the Edit menu. 
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2. Select the Current Options button. 

3. Change the Horizontal System to Geographic NAD 27 (US) and the 
vertical Units to be Meters, leaving all other settings the same. 

4. Select OK. 

5. For the Convert to options set the Horizontal Units to UTM NAD 27 
(US) and Zone 12 114W to 108W.  Set both the Horizontal Units and 
the vertical Units to Meters. 

6. Select the Convert button. 

Now we will save the soils data to a .map file so that we can read it back in 
after converting the land use data. 

1. Select the Save command from the File menu. 

2. Set the Save file type to be Feature Object Files (*.map). 

3. Enter aspensoutm.map for the file name and select the Save button. 

4. Select New from the File menu and confirm that you wish to delete 
everything. 

5. Select Import from the File menu. 

6. Find and Open the file aspenlustplane.shp. 

7. Confirm that the input file type is a shapefile and select OK. 

8. Select the Coverage Options button. 

9. Set the Attribute type to Land Use. 

10. Select OK to confirm that you wish to change the attribute set. 

11. Select OK for the Coverages dialog. 

12. Select OK to import the land use file. 

13. Select Coordinate Conversion from the Edit menu. 

14. Select the Current Options button. 

15. Set the Horizontal System to State Plane NAD 27 (US), the St. Plane 
Zone to Utah Central – 4302, the Horizontal Units to U.S. Survey 
Feet, and the vertical Units to U.S. Survey Feet. 

16. Select OK. 
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17. For the Convert to options set the Horizontal Units to UTM NAD 27 
(US) and Zone 12 114W to 108W.  Set the Horizontal Units to Meters 
and the vertical Units to Meters. 

18. Select the Convert button. 

Now that the land use is in UTM coordinates read in the soil map file and the 
DEM. 

11. Select the Open command from the File menu. 

12. Find and Open the file named aspensoutm.map (the file you saved for 
the soils above). 

13. Select the Append button so that it adds this coverage to the existing 
feature object data. 

14. Select the Import command from the File menu. 

15. Find and Open the file named aspen.dem. 

16. Set the Import file type to USGS DEM and select OK. 

17. Select OK to import the DEM. 

21.5 Conclusion 
Through these three examples, you should now have a better idea of how the 
coordinate conversion tools can be used in WMS.  These examples represent 
typical problems you may encounter while collecting geographic data for use 
in WMS. 
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