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Introductions & Logistics:

* |Instructor: =]

* Students: Introduce yourself, your job,
your experience with CAE tools,
and your expectations for this class.
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What is the value of this class?

You practice using ADS You gain expertise

You learn the same methods
used by ADS experts in the
examples directory.

With the aid of an instructor, you
get hands-on experience.
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Topic 1:

ADS Basics and Circuit
Simulation Fundamentals




Topics and measurements in this class:

Built-in example designs

Tuning feature \
System behavioral models

Amp, filter, and mixer measurements
Measurement equations

DC simulations: curves, bias, sweeps

Models, parameters, libraries AEP"eS tO:

AC simulations: gain, group delay, noise

Use of DesignGuides: filter and smith chart RFICa RF board,
S-parameters: matching & optimization : -
Momentum, E-Syn, DAC u\Wave circuits,
Transient & Harmonic Balance and Systems.

2-tone simulations such as TOI (IP3)
Noise figure, power and distortion
Circuit Envelope simulations EF
Modulated sources: GSM & CDMA b
Ptolemy simulation

and more... J

ADS 2009 (version 1.0)
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Schedule of Topics and Lab exercises

Approximately 3 topics per day:

Lab 1: user interface,

Day 1 |1 . Circuit Simulation Fundamentals S,"he:“:‘,“f];apt,“re’
2. System Design Fundamentals s'mu:'o asies.
3. DC Simulation and circuit modeling
Day 2 4. AC Simulation and nqise contribu.tio.ns | Labs 2 - 9
5. S-Parameters, Matching and Optimization receiver system
6. Filters: DesignGuide, Transient, Momentum >With émplif_ier .
S 7- Harmonic Balance Simulations and filter circuits.
2/ ° | 8. Circuit Envelope Simulation
9. Final Circuit & System simulations )
GOAL: Complete all the labs - you will be busy!
Extra: The instructor may have class exercises or demos, if had
* applicable. Also, if time allows, ask for information on other i

topics, circuit simulations, Design Guides, or examples.

ADS 2009 (version 1.0)
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How this class is structured:

Lecture: 25 % Lab Exercises: 75 %
Instructor describes the theory All exercises build on each other.
and the lab exercise using Optional steps are not required and
overhead slides, demos, etc. are for fast-paced students.

Extra Exercises are provided for
future practice.

Average lecture time:
30 min (+/- 10 min).

Fund[1]
Fund|2]

Average lab time:
about 1.5 hrs (+/- 15 min).

there’s more about this topic on the next
slide.

ADS 2009 (version 1.0)
Copyright Agilent Technologies 2009

Agilent Technologies Slide 1 -7



Logistics and Materials:

* Class hours:

* Food, facilities, phone:

« WORKBOOK
- Contains: slides, lab exercises, appendix.

* About the COMPUTERS
- Login:

_ Password:

= It’s time to get started... =>

ADS 2009 (version 1.0)
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Here is ADS Simplified: 3 steps &
=

@ STEP 1: design capture {g} STEP 2: Simulation

Insert circuit & system Netlist is
components and set automatically sent to
up the simulation. the siﬁulator.
i STEP 3: display the results Simulation results
Plot or list data & (data) are written to
write equations. ; a dataset.

ADS 2009 (version 1.0) SR .
Copyright Agilent Technologies 2009 Slide 1 -9




ADS Windows: Main, Schematic, Status, Data Display

Main window: manage projects, open
or copy designs, and get examples...
& Advanced Design System 2009 (Main) Q@@

File View Tools Window DesignKit DesignGuid

OSSR BB »

File View Project View

= 'F" C:\users\default\amp_1900_prj

= E] ac_sim.dds

Schematic window: capture and modify
circuits, setup or run simulations...

= [ amp_1900_prj ] ac_sim (Schematic):2

File Edit Select View Insert Options Tools Layout Simulate ‘Window DynamicLink

- Qe E & N

_ WipR @ 9 .Cl AR R QES,
Schematic setup _2...

RN=T TR

v I HarmonicBalance

V Palette

Ell arEqh

Meast

R ac_sim.dsn
@ ac_sim_bat_sweep.dsn
f AMP_1900.dsn

R bjt_pkg.dsn
] ckt_env_basic.dds

Project
Directory

gah_ottage - mag oty /mag (i

Al
H B Ophons

Start- 100 MHZ R

Skp= 10 MHZ
CakNokemies
Nokse Nodk [fl=-vort

RC <
R=SE004M W

ckt_env_basic.dsn
ckt_env_gsm.dds

Data Display window: plot and
list data, also write equations...

File  Edit View ory  Optior

D@[ﬂ@ I} El ‘.') QUVQQ\@\

s XL

ools Page Window Help

X

HEEE @

Default

CRAEEEE

Dataset pFr—r—rrm

freq, GHz

0] v]cleE @] |8

T T T
20 25 30 35

40

R
< RE

S Rk I)

DC_Blck
I DC Bkt

Simulation
Controller

4 hpeesofsim 50506:0
File Simulation/Synthesis Text Window

Simulation / Synthesis Messages ™

Resource usage:
Total stopwatch time: 3.47 seconds.

Simulation finished: dataset ‘ac_sin' written in:
‘C:\usersi\defaultNanp_1900_prj-/data’

< >

Simulation Status window:
simulation info: messages, errors, etc...

ADS 2009 (version 1.0)
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Start ADS and create a project...

) ADS Tools b e Or, use a
allp t
Srograms D ADS Documentation Advanced R deSktOp
Design Sysk
i@ Advanced Design System 2009 ™ Advanced Design System - shortcut.

m RF Designer
NOTE: UNIX users use a script! P Uninstall ADS Getting Started dialog...

& Getting Started with ADS

Use menu ADS Main Window: Search the Knowledge Center H Go ]

commands ENNEHa R AR A A C R - Aallnt Technoloies ' H A

or ICon S — File View Tools Window Designkit DesignGuide Help

= = _ . I_ Projects Help Center
s , " . i i
OEFO%20CR B T —

: Open an existing project Agilent EEsof Webe

i F i| Project View Open an example project Applications &

Customer newsletter archive

Open a recently used project

File Browser Project Listing

— Knowledge center &
| = @& default

Manuals

5 New Project

Technical support &
» MName Technical support contacts

Use Fi|e> NeW Pro'ect " Vendor libraries for ADS &
command or lcon. J C:\ users \ ads or default\ lab1 tidos

‘Web-based training#
‘What's Newa

Project Technology Files:

[ADS Standard: Length unit--mil V] View Details. ..

Close

Use the File menu or the File Browser to open a profete |

ADS 2009 (version 1.0)
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ADS Main window Tools...

Click Tools > Preferences:

& Advanced Design System 2009 (Main) =13 & Main Preference @
vFilé_ Vie‘f Window DesignKit  DesignG iz
4] Configuration Explorer... E Warning Bell Enable Physical Connectivity Engine (PCE)

v| Error Bell
rores Use PCE for Drawing (layer ordered)
Large Toolbar Bitmap

[] pisplay Project Listing

File View E Examples Search....

= Bpliciy Start Recording Macro. ..

Playback Macro... 7 ; s
= ; \ble the Getting Started Dialog Box arElin R |

- Text Editor... = -
cbbmatic Wizard Wire Thickness

Command Line. .. A O Thin

& . ;
Advanced Design SysFem StA:tup... SaveNggject State on Exit @ Medium
Hot Key/Toolbar Configuration. .. Create InNl Schematic Window O Thick

A 4

Preferences...

Qut Window External Text Editor

ew Window [ write.exe ‘

License Information. ..

[C] New/Open Design in

Queue Manager. ..
x

\

KiAdvancediDesien Sysiem Seiumi il For this course, these will be
L)
Design Type Supported B .
O AostogF oy turned off in the lab exercise.
(® Both, With Default : Y
: : ou can try them later!
i Setup is for setting the ry
esign

schematic availability of
either Analog or DSP Next, inside the

x ] [we=] (= ] | components or both. project..

New settings will be effective once the application is restarted.

ADS 2009 (version 1.0)
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Files and folders are automatically created
for new projects and a blank schematic
window opens!

& Advanced Design System 2009 (Main) Q@@
File View Tools ‘Window DesignKit DesignGuide Help

o= ER Em-l'ﬁ\ When you are in a
File View | Project View \. project, these iCOﬂS

'
L Clusersigefautlobi E become active so that
| you can open the

windows.

File Yiew

File Browser

..............................

& & data ) .
B de_sim.cfg Next, the Schematic window...

& de_sim.cfg.old

[& hpeesofsim.cfg
@ hpeesofsim.cfg.old
& layout.prf

B mischemeor The Project View is empty until you create the

+- 3 mom_dsn

# 6 networks schematics, simulate to produce data, and display

[& schematic.prf

-8 syntheds the results. But ADS automatically builds folders
and files when you create a project.

ADS 2009 (version 1.0)
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) Schematic window...

Use Window > Open Designs
Use Options > Preferences to change grid, color, etc. for unsaved designs.

= [ lab1_prj ] untitled1 (Schematic):5

File it Select View Inse @ ols Layout Simulate Window DynamicLink DesignGuide DK SCHEMATIC Help
— == L] e +2 -z = = % 5] ote
lizis o 4@% o Wip @ O Sfd AR R Q&G T d B IR
| v :
: | Lumped-Componen v =] '@ ||| ] UI
create, Lmpsaoprents_ d s Bz ﬁ N @ = Rotate By Increment
open, N lRotates the selected component or
and - S Zoomlng and .. . . . l|shape based on the current Rotation
: Lum;ed-wn.’n Artwork - ‘View allicons: - - - - - [ncrement (angle) setting.
Save m Sources_contolled . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
d ; - é Sources-Freq Domain R T S T T S R R R S S S S P T S All icons have
eSIQnS' S- A Sources-Modulated .
A ‘I::Sources-ModuIated-DSP-Based R balloon help
s -Noi
= —{I Sg::z:: -'I’[:'\ZeDomain S .
ocreed || b Simulation-DC o .
A Simiaton-AC - - | ADS has many palettes - with many
= || 4 Sfmulaﬁon-S_Param 5 a g . )
s )L aton 552 - - | components for creating schematics
£ Simulation-XDB o . . '
PLC gi:u:::g:-gr;ﬁgz? o and S|mU|at|0n SetUpS
imul - [ PR .
.{;D. Simulation-Batch T T RS R R R R R

Simulation-ChannelSim

Select: Enter the starting point 0items wire 7.500, -3.000 -0.125, -1.750 in  A/RF  SimSchem

NOTE: A new schematic becomes a .dsn file in the
networks directory only after you save it with a name.

More on schematic! :

ADS 2009 (version 1.0)
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Inserting and editing components

Activate / Deactivate

Component History: type the
name = get the component ! toggle icons...

End command
or use ESC.

# [ lab1_prj ] uni'tled1 * (Schematic):5
File Edit Select

DK SCHEMATIC

¢v Insert Options Tools Layo Simulate Window DynamicLink DesignGuide

’ Lumped-Components
Palette =
& &
SP SP Lab ! :E i ] -
Y i Edit components to see and L
Prm Swp tzTes L=1.0nH

Options

|
i modify parameter values.

Term = Inductor:5
T D
[ Refl Bt RefN at \ L Parameter Entry Mode
— il > T h e Cu rSO r' S h OWS Irftance Mame ({name[ <start:stop=]) ‘ Standard V]
Linetar "
2

Osclest CrOSS_ h a i rS a n d a n Selec.t Parameter i - §
\ image of the } |::>

Tune/Opt/Stat/DOE Setup...

=
o
EXA
T T

component you are More...
= ompeenty
inserting.
: Vi
MaxGain I PwrEain l < [ [] Display parameter on schematic
Wion 0 ltm wire =il 3 Cut Paste [ Component Options... ]

I_M : Number of devices in parallel, (default: 1) ‘

Parameters are defined: _M is multiplicity. =—1—>

[ OK ] [ Apply ] [ Cancel ] [ Reset ] [ Help ]

ADS 2009 (version 1.0)
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Some useful schematic commands

You will use these and others in the lab exercises!

=

Next, the Library

# [ lab1_prj ] HBtest (Schematic): 2

File [Edit| Select View Insert Options Tools Layout Simulate Window DynamicLink DesignGuide DK SCHEMATIC Help
— - : . + ;----. +2 -2 - — ! .: .E. ‘;% ] N7 f"r_’
L] i1 J g S o i ® QT 8 WS [T 6 o BE B i
~
. N\ nn
| Lumg vl L= ﬂ I3 I”@lll @ |IE
Palett A
¥ Cut QX e - :
ifier harmonic balance simu
el (B Copy rtec Push / Pop for
R @ Paste Ctri+v sub-circuits.
& Advanced Copy/Paste » RFin 17 . 1 £ . “out
[" ] Delete Dal o U .-!-\
—H peleteAl | Hot keys are labeled. a t, <« R
G C=Cseries C=3.5pF R2
Move » 1 L=Lshunt R=50 Ohm
‘ R=50
4 T Rotate R I_ = = =
DCFee)
¢ Mirror About X Shift+x — |
E o A . g Edit Component Parameters... .
SHOR ab Mclirror AZOUt h Shlft+Y’ MHz - Edit Component Artwork. .. Select Com mand IS aISO UserI e
AMNGnoRd ot [+ Break Connections e VAR
LG Component ) — ) ) Bci[1]=960 MHz Dii) Select All Ctrl+a
[f] Deactivate/Activate der[1]=5
o Wire/Pin Label Yo 58 Deactivate and Short/Activat Select By Name...
eactivate an (alg crivate o
; h reguires 1.33 seq
PRL Scale/Oversize ’ & Unix C180 li:" Deselect Area
» Group Edit Parameter Value...
. 111 Deselect all
Edit > Component > swap Comporerts... Y
Search/Replace Reference... Deselect By Name... ?
haS many uses. 0 item| Update Component Definitions... | 2,000 -0.375, -4.250 in AJRF  SimSchem
re— Create Hierarchy...
| Properties...
"'Ff_- Change Component Text Layer
Component Text Attributes. ..

ADS 2009 (version 1.0)
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ylly| Library vendor parts + all your circuits
Search in any column - including URLs

& Component Library D@@

= Analog/RF Libraries Al search H Search H Search H Search H
- Projects
- Analog Parts Library (No L... Component Description Library Vendor A
# Analog/RF AT41486: AVNKS6 Pack... RF_Transistor.. Agilent Techn... L |
Block Text Fonts pb_hp_AT41511_19931202 AT41511: SOT143 Pack... RF_Transistor... Agilent Techn... L
#- Board Demo Design Kit pb_hp_AT41511_19950125 AT41511: - . = :
Frequently Used DSP Com... pb_hp_AT41533_19950125 AT41533: * Izr;“ﬁ?n:'ni?n";p:;‘;';tdg;?gn i’:ﬁ]gxf e
- HF Diode Library pb_hp_AT41586_19931202 AT41586: o P " , gn wir e Search
% Measurement Based SMT ... | pb_hp_AT41586_19950125 AT41586: ST e el e L
% Microwave Transistor Library || pb_hp_AT42010_19920721 AT42010: field above the column. o
#- RF Passive SMT Library pb_hp_AT42010_19921101 AT42010, * To hide or show a column, right click on any
= RF Transistor Library pb_hp_AT42035_19911003 AT42035, e
Packaged BITs pb_hp_AT42035_19920721 AT42035: * To rearrange columns, drag the column name left
Packaged GaAs FETs pb_hp_AT42035_19921101 AT42035: or rlghf-
Packaged Power MOSF... pb_hp_AT42070_19920721 AT42070: * To resize columns, drag the seperator between
- S Parameter Library (No L... | |pb_hp_AT42070_19921101 AT42070, column names.
' pb_hp_AT42070_19931202 AT42070: AVNK70 Pack... RF_Transistor.. Agilent Techn... L ¥ |
[ Download Libraries. .. ] < >

Select the part and it is |
attached to your cursor, - _h%_l: L -
ready to insert. | P

One more slide on schematics... |:>

ADS 2009 (version 1.0)
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Check your Schematic for errors

Click: Tools > Check Representation Before or after simulation!
#= Check Representation: 2 @

#= Check Representation Report: 2

Open connections
D Bus connectivity errors Report for C:iusers\default)labl prj\networks\HBtest (schematic):

[ modal mismatches {schematic vs layout) ThereRisRoneRinconnectealpin:
[] PortjPin mismatches v_DC SRC1, pin 1 (1.625,3.625)

Ll
V_DC SRC1, pin 1 (1.625,3.625)
[] parameter value mismatches (schematic vs layout)
There is one unconnected wire:
|
|
J

Overlaid components Connecting (1.625,3.875) (2.125,3.875) (2.125,4.875)
[ OK ] [ Cancel ] [ Heb ] Overlaid items: \
€S Ground 2 R4
RFin
R Vi TS Ground
[ = [ e
R=50 Ohm A
— X1
V_1Tone =
) SRCS —
__T_ V=01V l
+] V. DC -| Freq=080 MHz o o
= v DC +| vDC
R X SRC1  =SRC2
=50V=[ Vdc=20V e Vde=5.0V—] Vde=2.0V
=5sRC3
— ; —] vde=385v = =
= View
i %4 Clear Highlightin F3
Unconnected wire . ghlighting

Next, setting up a simulation...:>

ADS 2009 (version 1.0)
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First step: insert a Simulation Controller

Select the palette:

' Simulation-S_Param v

Simulation-DC
Simulation-AC
Simulaﬁon-S=Param
Simulation-HB
Simulation-LSSP
Simulation-XDB
Simulation-Envelope
Simulation-Transient
Simulation-Batch
Simulation-ChannelSim
Simulation-Instrument
Simulation-Budget
Simulation-Sequencing

Other Palette items: e
Sweep Plan, Options,
Meas Eqn. Some
items (measurements
and components) are
simulation specific.

ADS 2009 (version 1.0)
Copyright Agilent Technologies 2009

/ *NOTE asterisk means schematic is not yet saved.

: ' Simulation-5_Param

Palette

= [ lab1_prj ] Ipf * (Schematic):1
File Edit Select View Insert Options Too

oEegs k -ea

Click the gear and
insert the controller.

in || vsWR | v | ¢

Select: Enter the starting point

Start=1.0 GHz L

Stop=10.0 GHz L1
Step=0.5 GHz L=1.0nH
R:
¥ Term R N Term
Term1 '62 Term?2
MNum=1 o - MNum=2
Z=50 Ohm = C=3.0 pF Z=50 Ohm
i 1
Oitems wire 6.500, -1.375 2.250, -2.750 in A/RF  SimSchem

>

v

Agilent Technologies

Next, editing the controller! |:>
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%Il Next, edit the Simulation parameters...

= Scattering-Parameter Simulation:3 @
@ S- PARAM ETE RS S_Param Instance Name
sP1

S Param Frequency | Parameters I Noise I Output I Display “— Dlsplay tab IIStS a”

SP1 the settings for on-
SweepVar="freq" | By default, freq is the swept variable here! screen d|Sp|ay

Start=100 MHz
St°p=2 GHz \ Frequency \
Step=100 MHZ Sweep Type @
FreqConversion=no N ® start/Stop O Center/span OUtPUt tab allows
CalcNoise=yes st [10 :GHZ D you to select what
| | S [0 Jor ¥ goes to the dataset.
Edit on-screen if the Nm. ofpts. 19 |
parameter IS dISplaved Or [] use sweep plan
use the dialog box.
You will learn to use these Almost ready to
in the lab exercises! = ]6 o 1Y o | [ e simulate...
~—"

ADS 2009 (version 1.0)
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El Running the simulation...

Click: Simulate > Simulation Setup:

Before you simulate: Lsimulation Setup:3
* You can name the dataset file. smaten mode = —
- If not, default dataset = schematic name. | = == === m
Distributed
Dataset files (.ds) are in the Ca =rm
DATA directory.
&  Data Display
Data Display windows (.dds) 1 = | (o ]
are in the PROJECT directory. s mter
[ Simulate ][ Apply ” Cancel H Help ]
/
To simulate: use F7 key, click Simulate, | ~
or click the gear icon on the schematic.

: : ...and the simulation runs!
NOTE: Servers can allow parallel simulation.

ADS 2009 (version 1.0)
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§| Simulation information: Status Window

One way to stop a Opens when simulating or click:
. . . & hpeesofsim 4:0
SImUIatlon_ISynth_eSIs - Simulation/Synthesis Text Window
> StOp Slml.llathn - Simulation / Synthesis Messages
2
Or, use schematic window
simulate command.:
Simulate | & Simulate F7 Status / Summaty
Simulation Setup... S hpeesofsin (*) _ A
Copyright Agilent Technologies
/ Simulation Variables Setup... SP SP1[1] <C:\ \default\labl_prj\networks\lpf> freg=(1 GHz->10
Stop and Release Simulator... | ||.... .. [] o users = FhIpRymetierEE e rear ‘
/ Resc'%gi:luziggﬁatch time: 0.97 seconds.
SlmU|at|0n Varlables ||St (tuning) Simulation finished: dataset "lpf' written in:
‘C:Nusershdefaultylabl_prj-sdata’
. :
The simulation results:

dataset (.ds file) written
into the data directory.. | ] | When finished, the

Data Display opens...:>

ADS 2009 (version 1.0)
Copyright Agilent Technologies 2009
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-~ Data Display (DDS) window

It automatically opens or you can open this window
from any Schematic or the ADS Main window:

ge:au":t File Edit View Insert Marker History Options Tools Page Window Help
dalase - = 4 rume 2 -2 o
ozgae o9 Ryl
Marker W g
Toolbar: —| Y X WAV | I &
peaks and Palette =) . ] A
valleys , [ NE ~ +Data displays open empty the first
—— time, unless you use a template.
ElE
First, select a < ’% B * You insert plots, lists, equations
plot, list or Eqn using the default dataset file or other
for the data... | |l ; dataset files that are specified
’ DIl P explicitly. 3
< >
[ ] m|i‘\ page 1 Ji
NOTE: Use the Options menu for control of DDS features - Next, plotting data...

turn on/off toolbar icons, set Hot Keys, etc.

ADS 2009 (version 1.0)
Copyright Agilent Technologies 2009
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—>

Next, the S(2,1) plot
and more ...

List or plot the simulation data...

File Edit View Insert Marker History Options Tools Page ‘Window Help

QUIZ:

What is this? }% S Lh O 9 «&id
w i Other datasets and DDS
VXN WMAWV equations, click here!

Answer: = B g & @/ =
a8l

Datasets and Equation\s/ Traces
Ipf Trace Elptions..k

J Plat Type \ Plot Options |

=
S E

freq dB(5(2, 1)) \L

2 . o) :

el i Trace Options: edit data
STEPS: gﬁg —<peete<< ||| traces or equations here.
1) Insert the plot, list, or equation. |
2) Select the data or equations. advensd \reasurement equations and
3) Options - edit data or plot. [ show Hierarchy variables from schematic are
4) Save/name the DDS window. [Manage Datasets...] also available.

)

[ Cancel ] [ Help ]

Answer: default dataset

ADS 2009 (version 1.0)
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You control all your simulation data

Here is S(2,1) and more - the default DDS name is the same as the schematic!

Page g Ipf [page 1]:0
New Page... File Edit “iew Insert Marker History Options Tools Page Windoi Help
Rename Page... 7 [ W R 2 -

Delete Page : [j E ﬂ % % *H’ ‘E’ "Q Q Q Q ‘g @ ° I(gserI >F;|-emp|ates
T : e » Create Pages
—— ot : FEEEmE | o
_ T in marker * History for traces
Previous Page 5 ype arke .

B Y A Y freqto move it. * Zoom into plots
i e N\ « Scroll through lists
page 2 —

freq=1 ZEKGH= P
Page tabs e " ¥ |dB(szTF20 453 2
1 (8]
(see bottom). | <5y e st Plots, Traces,
— freq=1.900GHz @
R dB(s_opt.5(2.1))=36.279| £ and Markers can
Also, use R 0 o be edited.
— 10 . r —r —r—r—r
mouse Wh'eel 0 1 2 3 a indep(s_circles. GaCircle1) (0.000 to 51.000)
to zoom in/ freq, GHz
| _ Inductor Values
out. D ol arker_diff = m2 - m1 | marker o N Cval
' N I
P 250,699 2100E-9
] XC =olg][<C = -1/ (2 pi ™ THOOM ™ TOe-TZ]| 370.080 3.100E-4
. -8.377] 489.460 4.100E-4
Trace label: explicit BIL_val=[in - 10n - 200n] ELETY 510054
H 847.602 7.100E-4
dataset...path if not B =27 pi* 1900M * L_val
the default dataset.

Write equations using ADS functions to operate on data.

\ page 1 AN page 2 J Next, Tuning. :

ADS 2009 (version 1.0)
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TUNING PARAMETERS: tune mode = simulation!

|@| Simulate > Tuning... . o 4 means
Select parameters, tune, and watch the results! 5 the trace
g e history is
e 40 |
g% Tune Parameters ; i 2' i "l ' é i ' 1|c| tu rned on.
Simulate | freq. GHz
Ipf
e sider ioves 2 |
Tune o I Tr 4 [erm
Parameters LiL e l | I Term?2
[ Include Opt Params J (nH) oF) TE_l MNum=2
. =1.0 pF 7=AM Ohm,
[ Enable/Disable. .. J value |1 3 - 7T _—
- S E=TpF T
[] snap Slider to Step | -
Traces and Yalues e | —
Recall... : . . . .
ST > &0 | S-PARAMETERS I List of available simulation
[ e ] p— variables: Simulate >
- i ) SP1 I i i -
[ estensc | o o F SormepVartfred" Simulation Variables Setup:
step (o1 | (o3| SweepPlan=
[ cose | hew | Scale [Lin v in v Stat=1.0GHz = | == [ ovbmston | ststs | 0 oe
St0p=1 00 GHZ Name Tune Vall Unit Format Min/+/+- 9 Unit Max Unit Step Unit
Step=1.0 GHz °F w—
CaICNOise=n° *¢ c 3.0 me \::::: 1.5 p 5 pF 0.3 pF

ADS 2009 (version 1.0)
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Views of an ADS Project Directory

.
PrOJect for exam ple: I ab1_prj ‘File_ Vievit Tools Window DesignKit Desi-.gnGuide Help
O R BEM »E
£ .dds files (data display server) Fleview | Project view |
] Data display windows you create to - B e
1 1 H HBtest.dsn
dlsplay S|mulat|9n d.ata. You cannot see o T
these in the Main window. iR} Ipf.dsn Flle Bromser
PA.dsn = & I:atleJr]‘
. . . @ :a'rf_ful.rec
€ |— data directory contains .ds files (datasets) o
. . . . B de_sim.cfg.old
This is the simulation data. D dep fulrec
B hpeesofbrowser.cfg
B hpeesofsim.cfg

| B hpeesofsim.cfg.old
63 [——networks directory contains .dsn files (designs) gﬁd;'f
. These are layouts and schematics with simulation setups. %22%‘;2;3&,..09
netlist.log
- 2 networks
|- 3 notebook

&5

B pnk_schematic.prf

The prf, Cfg y |Og a nd Some / % gg?zj:jt)‘rao?:ct_state.ael

[ save_project_state.bak

. OTHER folders / files other files can be ignored. B shemstcpr
mom_dsn (Momentum) + % ;z:tel?;sgls

substrates (Momentum) 4 & verfiation
| synthesis (used for E-Syn & DSP) __ These folders are not required

___ verification (used for DRC) unless using the specific tool
| notgbook or model, etc. To delete ADS files,
verilog Use: File > Delete

ADS 2009 (version 1.0)
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ZAP your projects for e-mail or disk

From the Main window, click: File > Archive or Unarchive
& Archive Project @

Archive Project: | Ci\users\defaultilabl_prj ‘ [ Browse... ] [Working Directory] [Startup Directoryl [Example Directoryl
To File: C:lusersidefaulty ‘ [ Browse. .. ] [Working Directory] [Startup Directory]
Archive Project Hierarchy N OT E : ArCh |Ve f| IeS
become .ZAP files (like .ZIP files).
They can include all networks,
autinarchive Broject S §ata, and display files (entire
Unarchive File: ’C1"il-lsersiclef'aull:1I l [ Browse. .. ] [Worldng Directory] [Startup Directory] projeCt
To Directory: ’C:'l,users\,default'l, I[ Browse. .. ] [Woridng Directory] [Startup Directory]
Open Project After Unarchive

At the end of this course, archive your projects to C:\temp and then copy the
ZAP files to your floppy or CD drive. Be sure to delete the datasets if using a
floppy disk - not necessary if copy to a CD or if you are e-mailing a zap file.

ADS technical support in the United States call: 1 - 800 - 473-3763.
Or, on the Web: |&] http:/feesof.tm.agilent. com/support/supp101. html

ADS 2009 (version 1.0)
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ADS has some powerful features:

» Templates

 Examples =
* Design Guides

 Smart Simulation Wizard

 Test Labs and Test Benches
e Link to GENESYS

The next few slides briefly shows these features.
Then you will start the first lab exercise!
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Templates for simulation and data display

# [ lab1_prj ] untitled3 * (Schematic):3
File  Edit

Options

You can also make your own templates:
File > Save Design as Template...

ST T A L EE

Tools

Select  View

#= Insert Template:3

VAR
Pa Schematic Design Templates .-
3GPPFDD_BS_R¥X_test ~ | BT Curve Tracer |
| 3GPPFDD_BS_TX_test
3GPPFDD_UE_R¥_test »
3GPPFDD_UE_Tx_test #] voc JRERLE
i BIT_curve_tracer > = SsRC1 s 1c
ConvPulseRespT =-| ‘e=\CE 2, ~
ConvStepRespT TR .
[ DC_BIT_T 7 fywid |oc Insert your device
DC_FET_T SRC2 . .
E PET rve. tracer VCE=0 e or circuit and
HB1 Tone simulate. But you
o - : y
HE1Tone & Component Library/Template Browser: 1 - .
t{ HB 1 Tone Libraries Templates n e e d to Ve rl fy
HBZTone| = 3 DDS Templates - Name Desciiption [] .| R SWEEP I DC .
p HBZTone: g Eustomized BJT_curve_tracer BJT curve tracer with power consumption calc :I o S ettl n g S : n O d e S y
Linearpull = Msoen:entum_tuslomize d FET_curve_tracer FET curve tracer with power consumption calc D C1 ; .
“ . omentum_User S_Params_Quad_Smith_Plr $11.522 on Smith Charts; $12,521 on polar ph q ,
L".-'earSte g mnmen:um:gmduct S_Params_Quad_dB_Smith 511,522 on Smith Charts; dB(512).dB(S21) on " " SweepVar: “CE b I a S 1) Va rl a b | eS )
MixCony i Fiodcl] S_Params_Quad_dB_Smith_Log 511,522 on Smith Charts; dB(S12)8(521) an DCt Start=0
MivTAT S_ParamsLargeSignal Large Signal S-parameters and Stability factor * Stop:s p a ra m ete rS R
E < SProbeT Use with SProbeT schematic template Step=0.1
SProbePairT Use with SProbePairT schematic template
11 with "'zoomed-in"* frequency ranc -
MNote: Do H gain and noise figure circles E{I':'»p|3‘!.l' Te fTIFIlBI"-.'
- D a ta D I S p | a y a I S O gain and stability circles d'smemp 1
nd load stability circles and K. "BJT_CUNQ_‘GC&I“
— has templates! ey
r OK e oo . gain, harmonic distortion vs. pov v
HB2Tone Output power, gain, TOI L‘ >
I ‘ =g Select template and press "0K" to insert or "Cancel” to abort. - . .
Select: Enter th 1.500, 1.875 1.375, 2.750 in  A/RF  SimSchem
0K Cancel

ADS 2009 (version 1.0)
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Examples and Example Search...

[

& Advanced Design System 2008 (Main

File View Tools Window DesignKit Desi

52 e @i

File Yiew Project View

File Browser |
| = & examples A
t. .

£ 1xEV

1 Antennas-Prop

2 BehavioralModels

£ CDMA

£ CDMAZK

3 Com_Sys

3 Connected_Solutions

3 DesignKit

£ DSP

£ DTV

£ EDGE

£ GSM

£ HSDPA

£ HSUPA

3 Instruments

£ LTE

3 Momentum

3 Mw_Ckts

3 PtolemyDocExamples

1 RF_Board
3 RF_SiP
£3 RFIC

R IR R

& & & & & &5 & & & 55 8 8 5 285558 &)

&

FieView | Main window File View icons

=

i Example Search @

acpr_is_136received
acpr_is_136transmitted

Search Results

Components Keywords Expressions # & 1xEV_SignalSource_prj L
+- £ BS_TX_ptj

Query # 3 MS_TX_prj

ACPR| # €3 AmpP2D_pri

lacpr [+ 3 AmpS2D_prj

acpr_is_136 [+ 3 CDMAZK_Measurement_prj

[+
[+

3 SignalSource_prj
£ 1595_prj

ol % €3 OFDM_WLAN_prj
acEr; # £3 RFSystem_prj
acprtest #- 63 Measurement_TCH_ptj
[+ 3 amplifier_prj
#- 3 CartesianFB_prj v
Show Yalid Search Words Path
Tips [
AND and OR are supported (boolean logic)
* = Wildcard Mode
Open Selected Project
£ = Project not installed in your ADS directory sl

Copy to Current Project

Yiew Only

&

3 SDFHdICosi

C:lusersidefaultilabl_prj

= 5i9na|Integ:I Search up to four words (implies AND) but do not combine AND and OR.
Copy with hierarchy or view (no hierarchy). Also, copy Data Displays!

ADS 2009 (version 1.0)
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& Getting Started with ADS

The KC: Knowledge Center

Search

Agilent Technologies

Help Center

Projects
ADS Quick Start
Adlent EEsof Weba

Create a new project
Open an existing project
Open an example project

Supported customers receive a Username and Password.

Search the Knowledge Center by topic ...

Open a recently used project

labt pri

2mp 1500 pr
amplifier_pr
quick start pri

<T

Agilent EEsof Technical Support Documents and Examples
Agilent EEsof Technical Support Documents and Examples content is created by Technical Support Engineers and other subject matter experts in EEsof EDA.
Please use the drop-down lists to access the desired category of the support documentation for a product.
Technical Support Documents and Examples |_T_|Tec)*mcal Support Documents and I_T_‘ Technical Support Documents and Examples
Internal Examples Japan Internal Japan
ADS Genesys GoldenGate
ﬂ Complete design solution Simulation, Data Display, Layout Advanced RFIC sim & verification
[@ AEL Topics | l Topics *
Boot Errors
Configuration
Connected Solutions Y t t
— ou get access to more -
-: " “cap Design Environment SystemVy
i Param. Extract] = Affordable d t d | d
e T Design Kits Ocumen S, OWn Oa S,
) Topics » Dﬁign?uiqes Topics :I
and the latest examples...
EMDS for ADS
Examples
File
‘ AMDS . General EMDS ) ) Legacy Software
3-D design/mo Genesys RF Architect Link Full 3-D Simulation
Topics * TR Topics | Topics *
N Instrument Server & IO
Layout
Library Builder
Licensing >
Children (9) show chilg Migration Child Page
Momentum
Privacy Statement®| Terms of | Online Help 000-2008%
Printing
This page has been viewed 291  SiMKt !
Simulation
Tools

ADS 2009 (version 1.0)
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Design Guides: design + simulation

DesignGuide

File Tools ‘iew

EBX

. . .
o . Filter DG ynthesis tool (E-
. Amplifier '5? Q % - >< EIEI I er IS a S n eSIS OO
Bluetooth
Filter «Current Schematic SmartComponent Sy n re p I a Ce I I | e n t)
Linearization [labl prj]:2 V| |DA_LCLowpassDT1 v
. g
Freq Mulipliers and Dividers _[(urrent Design SmartComponent Capabity e Smith Chart util ity can be for
Mixers untitled2 Design, Simulate, Yield, Display
Oscillator Overview | Filter Assistant Simulation Assistant Yield Assistant Display Assistant l I I atC h I n g .
Passive Circuit
e * Other DGs are available - some
RF System Source Load Resoonseilyng S
. . Maximally Flat as (dB)
Analog/Digital Conversion fon I 1 k t m I t
. First Element |20 | a re I e e p a es Ll
Budget Analysis
Parallel v 2 < | dBjsquare
Loadpull
Radar Applications
IBIS Library Order (M)
TDSCDMA 4
UWEB Realizations
) 25 Smith Chart Utility (8=
WLAN B [ view al Fle Edt Vew Crces Hep
ink Ul Max # - o=
V?I Link Utlllt?’ N == 3 oy (@S h SUETIPN
Signal Integrity Applications 4 1 Palette & coment schemt ot .
—— - rent Schematic martComponent
Wireline Applications e} F, aos) Z:U(Oh 2 Normaige | [12b1priJ: 2 v v
Minimum Insertion Loss:
cdmaz000 0.0000 Fp Fs Units :] m ( Define SourceLoad Network Terminations... ]
Preferences. .. m A 1 Network Response .
. o
YOU WILL USE THESE IN i
(I =" =
Mag v
St THE LAB EXERCISES!
— - B e o o o o [ v
Filter DG - Al | v -
511 |
Palette ) fin
:E' E | StartFreq: |0 StopFreq:  |2.089 Reset
ot ot Network Schematic
v 7 ] N l— -
Ak A DT
DT ot DA_LCLowpassDT_untit| 5 L @ >
’:E_ E DA LCLowpassDT1 L=14.5952 nH L=6.08608 nH g 2
- R=18-12 Ohm R=1e-1200m
ST ST \ < N =
Port Port =
Era ;! Nurr= J’ N2 O oo o 2 ’ .
T ST gl“]“g - 335 sretos Gamma: [0.00707 | < 45.0000 | z: 1.01000 | + 001010 Delete Selected Component | [ Set Defauls.. |
VSWR: 1.01424 ¥ 0.99000 | + -0.00990 2ot Value: |25.59466 | Ohm Loss: Q
= Ao 2-Element Match] [ et Close
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Smart Simulation Wizard Schematic lcon

N 1 |
[ Smart Simulation Wizard|

ot

Predefined simulation setups for devices or circuits you build.

#= Smart Simulation Circuit Setup: 6

=
Step 1 'e_;:a S Double click here to
: - ¥4 S|set up simulation
Select one of the following application types. El ; ; ;
Hn i N Your device or circuit
This determines the appropriate schematic and simulation configurations. Base Coltector
pRrap g goes here.
Type of Application SS_BJT_SIM1
=} iDevice Characterization Smartgmulation
BJT Characterization
FET Characterization
MOSFET Characterizatio p— 2%
= st . '
Amplifier Available Simulations for BIT Chava:leriz:t\un —
= Mixer ey SS_BJT_SAM2 Push into "BJT1"
Single-Ended Mixer BJT1 to edit model
Differential Mixer g v bis
= Linear Circuit v . .
Linsar 2-Port Data is automatically plotted
Linear 4-Port an -Puql.n;‘ALE, output Power Contours H H 1 .
e s omcom in predefined Data Display template:
i
B o the Pk e D
- will be invalid.
Compute 5-parameters, stabiity Factor and group delay vs frequency and Input power sweeps. " B Dwer v Owm i,
Simulation Avaabilty Legend ¢, "
+/ Avalable 2 Available: Power Amplifier Design Guide license required to run é ot S
ie - e
' o
Simulation setups or Design Guide setups (license e SR
. . . T iR e Optimal Class A
required). Type in the values to be passed into the “ e P
- . i S gem, _
setup. Simulate and the results are automatically ] =1
I e Y i

plotted in data display templates.

ADS 2009 (version 1.0) b
::3-- Agilent Technologies Slide 1 - 34

Copyright Agilent Technologies 2009 et




Test Labs and Test Benches

For S-parameter analysis, you save simulation time and memory!
ADS now contains examples of using these.

NOTE: Series IV users may remember this concept.

|%‘ S-PARAMETER TEST LAB I

S_ParamTestLab
TestLab1
Start=0.1 GHz
Stop=10 GHz

TEST LAB: simulator is flagged
to use Test Benches for analysis.
TEST BENCHES are separate
circuits with separate port

assignments — no need to put

Step=0.1 GHz all circuits on one schematic
with consecutive port numbers
for multi-stage designs.

<+«—— For example, set up an
optimization to create a

Test Bench Test Bench . .
simulation model equal to the
Measured_tb Modeled_tb ds t
TB1 TB2 measure -parameters.

More on this later: in the S-parameter analysis section.

ADS 2009 (version 1.0)
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ADS link with GENESYS...

Use ADS with GENESYS or Spectrasys — some rules apply.

M Launch GENESYS Synthesis: 1 X
58 Layout  Simulate  Window  Dynamicl
(¢ Create a New Synthesis Design
‘ w (" Open an Existing Workspace
SPECTRASYS...

Synthesis Type

|Aclive Filter LI
[~ Copy ADS Substrate to GENESYS

Electronic Notebook. ..

Purpose: transfer GENESYS

schematics to ADS for analysis. |
oK Cancel | _ Heip |

P> £ Yeew Schematx Acton Jook  Widies Hep

o e Ple Ble | || % el N
Qpen e $ . "
B e GENESYS circuit:
v . j
2V QrteS
Save A
» . Workspaces b . ] +
S S > YA Y A
~ Page Seb g +
A e T orer Term MFilter1_Schdifidfie
: TERM_ 1 o1 1 TERM_2
B coor ] -
. » TR e— Now, the lab

exercise!

NOTE: ADS prj and GENESYS workspace must be opened on PC at the |:>
same time. Also, models not mapped in both will be reported.
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=7 1= What the lab is about ...

Lab 1:

Circuit Simulation Fundamentals

Agilent Technologies Slide 1 - 37



Learn Circuit Simulation Basics

» Create a new project: lab1

* Build a low-pass filter in the schematic
« S-parameter simulation

* Display the results: S21 transmission
* Tune the filter response

 Create another schematic in lab1 project

» Copy an example RFIC amplifier into lab1 project
 Setup the Vin and Vout node voltage names

* Perform a Harmonic Balance simulation

* Display the spectrum and gain equation results

NOTE: Lab 1 can be skipped if you already
know the basic operation of ADS. Or, try the MORE ON THE LAB:

extra exercises at the end of the lab.
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Low-pass filter: S-parameter simulation

Build the filter, simulate and tune the filter parameters...

- Term

£ lerm

-

SET UP THE

SIMULATION i L
. MNum=1
=50 Ohm imzl £ Tune Parameters
= C ¥ Simulate Iof
—I-_ C1 e sicer oves |2
# Scattering-Parameter Simulation:4 @ = C=1 p F {-t} P Tune
Ss_:;alram Instance Name ‘ NN cLc o
Frequency Parameters | Noise | Output  » [ Jnckle Opt Poroms J R (pF)
R | % | S-PARAMETERS I [ Enable/Disable... ] value |1 5
g Max |2 6
T [7] snap Slider to Step ’ ’
ép'] o Traces and Values
Frequency -_ -
Sweep Type Linear v Start:1 0 GHZ E8Eb00 Recall... o o
® Startjstop O Center/Span Stop:100 GHz Trace Visibility. ..
Start 1.0 GHz v [ Reset Yalues ]
Stop 10.0 [z v 0
Step-size 0.5 GHz v - [ Update Schematic ] Min 0—| 0—|
Hum. of pts. 19 -10— Step lo1 0.3
= 5 - [ Close ] [ Help ] le Li Lin v
[[] use sweep plan gﬁ 20 ocalefiln_ i
(D - ] f — ~.
= req=6.000GHz -
m -
3 dB(S(2,1))=-2.066 dB(5(2.1)) J—
YT mem(memory1 dB(S(2,1)}) memory1 Ipf.L1.L=1.36 nH Ipf.C2.C=4 62 pF
b mem(memory2 dB(S(2,1))) memory2 Ipf L1.L=048 nH Ipf.C2.C=4 62 pF :>
-40 T T T T T T 1 | | |
OK ] [ Apply ] [ Cancel ] [ Help ] 0 2 4 6 8 10
freq, GHz
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RFIC example: Harmonic Balance simulation

With Vin and Vout labeled, check the sub-circuit, and simulate.

/

Win . Wout
RFin 1 ¢ . |1 ¢ @ HARMONIC BALANCE I
I\ I\
é R W S Ground 0 3 c
R1 ~ : HarmonicBalance VAR
C1 Cc2 R
R=50 Ohm PA O - L1 -z HE1 WAR1
_ o C=Cseries & | =|shunt C=35PF Sis Freq[1]=960 MHz Cseries=7 pF
& R=50 Order[1]=5 Lshunt=7.5 nH
% 1Tone -1 =
SRCS -
6’ v=01 v File Edit View Insert Marker History Options Tools Page Windol Help
-| Freq=960 MHz  § ! ODEegse Rkl 9 il Qd X
+] v oc + S DC - [ HBtest v &5
v DC — =
= SRC3 .T\S/ngsov.'_';S/dREP,J:N Sdmn Start the
- | Wdc=395Y ' il
1 i & lab now!
L = = M Gain = Vout /v "/
- freq Gain . 1
2 0.0000 Hz 0,000 /0.000 ]
- : o e | wine | £
Write and list the_—" |

gain equation.

freq, GHz

<

dBm{vout)
e
Oy S —
B
s
—
L,
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NOTE: If you finish early, try
the lab Extra Exercises!
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